*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

installed vim, broke web UI

XigmaNAS Packages
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
meamo
NewUser
NewUser
Posts: 6
Joined: 05 Sep 2015 15:55
Status: Offline

installed vim, broke web UI

#1

Post by meamo » 09 Sep 2015 18:13

I installed vim with 'pkg install vim' and it worked fine. However, when upon the next boot I get the message "/usr/local/lib/libpng16.so.16: version PNG16_0 required by /usr/local/bin/php-cgi not defined" straight after "Welcome to NAS4Free!" and the web interface no longer works - I just get a white page. I've tried removing vim and the packages that came with it but no joy.

I've only just got my new NAS working as I like, is it possible to recover from this without reinstalling?

User avatar
b0ssman
Forum Moderator
Forum Moderator
Posts: 2458
Joined: 14 Feb 2013 08:34
Location: Munich, Germany
Status: Offline

Re: installed vim, broke web UI

#2

Post by b0ssman » 09 Sep 2015 18:56

please read

http://wiki.nas4free.org/doku.php?id=faq:0073
Also, bear in mind that if you use a Full install, you cannot expect support if something breaks. There is no way that anyone would be able to guess what part(s) of the system you damaged (accidentally or intentionally). You have been warned.
Nas4Free 11.1.0.4.4517. Supermicro X10SLL-F, 16gb ECC, i3 4130, IBM M1015 with IT firmware. 4x 3tb WD Red, 4x 2TB Samsung F4, both GEOM AES 256 encrypted.

meamo
NewUser
NewUser
Posts: 6
Joined: 05 Sep 2015 15:55
Status: Offline

Re: installed vim, broke web UI

#3

Post by meamo » 09 Sep 2015 19:11

Brilliant, thanks.

psichod
NewUser
NewUser
Posts: 1
Joined: 03 Jul 2014 21:09
Status: Offline

Re: installed vim, broke web UI

#4

Post by psichod » 25 Oct 2015 02:35

I learned that upgrading the "png" package to version 1.6.18 fixed the issue for me.
Here is what I ran: "pkg install png"

Post Reply

Return to “Packages”