*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

MTU setting not applied

Everything to improve your speed, LAGG, VLAN, VPN, Port Forwarding, DNS, Gateway
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

MTU setting not applied

#1

Post by ChriZathens » 27 Jan 2015 10:16

Been trying to figure it out myself for a few days now, but failed miserably so far..
Anyways, I have a D-Link DGS-108 Gigabit switch, which supports jumbo frames.
Since my home seedbox uses an atom cpu (GA-D525TUD with a realtek nic, transfer speeds to my NAS were far from great. (around 30MB/sec, while transferring the same file from windows PC to NAS could easily achieve 60-65MB/sec)
So I thought what the hell let's try jumbo frames to see what happens.
So, changed MTU of windows to 9K, seedbox to 9K and wanted to do the same on n4f. So wrote 9000 in the mtu setting, save, asked me to reboot and after reboot, ifconfig shows this:

Code: Select all

$ ifconfig
nfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=82008<VLAN_MTU,WOL_MAGIC,LINKSTATE>
	ether xx:xx:xx:xx:xx:xx
	inet 192.168.1.102 netmask 0xffffff00 broadcast 192.168.1.255
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
So mtu is still at 1500.. Tried with lower values, like 6000 or 4500, but still nothing
Tried to write mtu 9000 in ifconfig extra options, but still the same.
FreeBSD manual reports that jumbo frames are supported unless I get something wrong... :oops:
This is the motherboard I have (also in my sig): MSI GF615M-P33
While in there it says that the NIC is a Realtek 8211CL, n4f reports my NIC as nfe0, (and msi website states that chipset is nforce 430) so that's what I searched for (besides the fact that I cannot find anything about 8211cl in the manual)
Mind you I am still in n4f version 9.1.0.1 - Sandstorm (revision 847)
Any ideas welcome..!
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4923
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: MTU setting not applied

#2

Post by raulfg3 » 27 Jan 2015 11:19

aparently there are other people with same problem: http://lists.openwall.net/linux-kernel/2012/08/09/669
check point 2:
2. full description: my mainboard (Asus M4N82 deluxe) has an onboard nvidia/realtek 8211cl
ethernet card.
The forcedeth detects the card, but is unable to bring up the phy, disabling additional features
(MTU limited to 1500).
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

Re: MTU setting not applied

#3

Post by ChriZathens » 27 Jan 2015 11:26

I apparently have hit a wall, then? Damn...
I have somewhere an HP server NIC (http://h18004.www1.hp.com/products/serv ... index.html)
I suppose there will be no problems with this, what do you think?
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4923
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: MTU setting not applied

#4

Post by raulfg3 » 27 Jan 2015 12:02

is based on 82574L Intel, so no problems expected.

https://www.freebsd.org/cgi/man.cgi?que ... ormat=html
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

Re: MTU setting not applied

#5

Post by ChriZathens » 27 Jan 2015 12:55

I guess I have to find some time to install it then...
Thanks a lot raul
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

Post Reply

Return to “XigmaNAS Networking Tune-up”