*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
provels
experienced User
experienced User
Posts: 107
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#31

Post by provels »

FWIW, I disabled the FW update check and I saw same copy speeds as before. I believe what your seeing, but maybe it's a driver or network issue rather than Samba.
Peder
XigmaNAS 11.3.0.4.7538 Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

Jack Foobar
experienced User
experienced User
Posts: 110
Joined: 07 Jul 2015 01:24
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#32

Post by Jack Foobar »

Jack Foobar wrote:I think I'm getting closer to figuring out what's up. After going to System/Advanced, and disabling outbound Firmware update check(supposedly only updates at login), my speeds have picked up. I'm wondering if something under the Samba/udp/ip hood is confusing the WAN with the LAN. It's still not great, but it's not 12 MB/s now either. I just think this build is extremely wonky on the samba side of things. I don't see how a outbound check could affect samba though. Hard to diagnose voodoo, so take that anecdotally.
Nope. That wasn't it. Dropped back to 12 MB/s... I think samba is just broken on this one. IP direct xfer seems to be fine. Samba is just busted.

maarten
Starter
Starter
Posts: 38
Joined: 17 Jul 2012 20:20
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#33

Post by maarten »

Problem solved, restarted my server and SAMBA/CIFS speeds are normal again. Thanks for all support and advice.

Jack Foobar
experienced User
experienced User
Posts: 110
Joined: 07 Jul 2015 01:24
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#34

Post by Jack Foobar »

provels wrote:FWIW, I disabled the FW update check and I saw same copy speeds as before. I believe what your seeing, but maybe it's a driver or network issue rather than Samba.
Thanks for checking for me. I appreciate it. It was a red herring. I am still seeing a metric fkton of errors in Samba though, and not the cute printer kind. I'm going to swap out NIC's and see if it's a hardware problem.

erik
experienced User
experienced User
Posts: 83
Joined: 14 Jul 2014 09:45
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#35

Post by erik »

Do also check the NIC's at the client side.
I had terrible performance with a new nas4free version that turned out to be a problem with a Realtech nic in a windows client.
primary NAS: 2*8Tb raidz1, backup NAS: 6*2TB raidz2, remote backup NAS: 3*2TB raidz1 : All NAS4Free 11.0

provels
experienced User
experienced User
Posts: 107
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#36

Post by provels »

erik wrote:Do also check the NIC's at the client side.
I had terrible performance with a new nas4free version that turned out to be a problem with a Realtech nic in a windows client.
I had the same issue. When I finally upgraded to a gig switch a few weeks ago, copying large files server to client would crash the Realtek NIC, but upgrading to the latest driver fixed it.
Peder
XigmaNAS 11.3.0.4.7538 Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

Jack Foobar
experienced User
experienced User
Posts: 110
Joined: 07 Jul 2015 01:24
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#37

Post by Jack Foobar »

Just an update on the samba issue.

So it seems the installed samba version 4.3.11 for this build has security updates that disallows some older authentication methods and downgrades the client to NT1 protocol when it attempts to do so. I don't know why it's downgrading it(which it is), but I'm assuming that little punk is mandating a minimum revision/security level for the client for security reasons. I'm on Ubuntu 16.04/Xenial and the latest samba revision is 4.3.9, which was before the security issue of privilege escalation/de-escalation was addressed in 4.3.11. The server is set to SMB2 or SMB3(Doesn't matter. Clients end up on NT1)

What 4.3.11 addressed:

https://www.samba.org/samba/history/samba-4.3.11.html

Results seen:

https://bugs.launchpad.net/ubuntu/+sour ... ug/1598463

https://bugs.launchpad.net/ubuntu/+sour ... ug/1572876

On my client end:

samba (2:4.3.9+dfsg-0ubuntu0.16.04.2) xenial-security; urgency=medium

* SECURITY REGRESSION: NTLM authentication issues (LP: #1578576)
- debian/patches/samba-bug11912.patch: let msrpc_parse() return
talloc'ed empty strings in libcli/auth/msrpc_parse.c.
- debian/patches/samba-bug11914.patch: make
ntlm_auth_generate_session_info() more complete in
source3/utils/ntlm_auth.c.

On neither end:

Samba 4.4.5

Changes since 4.4.4:
--------------------
o Stefan Metzmacher <metze@samba.org>
* BUG 11860: CVE-2016-2119: Fix client side SMB2 signing downgrade.
* BUG 11948: Total dcerpc response payload more than 0x400000.

I've had hemorrhoids give me less shit than this samba security crap.

But maybe there's a glimmer of hope. I see this in the freebsd pkg repo:

pkg search samba
p5-Samba-LDAP-0.05_2 Manage a Samba PDC with an LDAP Backend
p5-Samba-SIDhelper-0.0.0_3 Create SIDs based on G/UIDs
samba-nsupdate-9.8.6_1 nsupdate utility with GSS-TSIG support
samba-virusfilter-0.1.3_1 On-access anti-virus filter for Samba
samba36-3.6.25_3 Free SMB and CIFS client and server for Unix
samba36-libsmbclient-3.6.25_2 Shared lib from the samba package
samba36-nmblookup-3.6.25 NetBIOS Name lookup tool
samba36-smbclient-3.6.25 Samba "ftp-like" client
samba42-4.2.14 Free SMB/CIFS and AD/DC server and client for Unix
samba43-4.3.11_1 Free SMB/CIFS and AD/DC server and client for Unix
samba44-4.4.5_1 Free SMB/CIFS and AD/DC server and client for Unix

So perhaps the next update can assist in ungimping some select clients that can't jump above the samba revision hurdle.
Here's hoping. Thanks for your time.

bocman
Starter
Starter
Posts: 21
Joined: 01 Apr 2013 11:46
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#38

Post by bocman »

zoon01 wrote:
sleid wrote:
Jack Foobar wrote:Samba/CIFS only enabled server. Seeing this error repeat - didn't know NAS4Free had a printer option.

smbd[11029]: pcap cache not loaded
smbd[11029]: [2016/07/31 20:25:37.444219, 1] ../source3/smbd/server_reload.c:69(delete_and_reload_printers)
smbd[11029]: Failed to fetch record!
smbd[11029]: [2016/07/31 20:25:37.444025, 1] ../source3/printing/printer_list.c:234(printer_list_get_last_refresh)
smbd[11029]: pcap cache not loaded
smbd[11029]: [2016/07/31 20:25:24.229041, 1] ../source3/smbd/server_reload.c:69(delete_and_reload_printers)
smbd[11029]: Failed to fetch record!
smbd[11029]: [2016/07/31 20:25:24.228957, 1] ../source3/printing/printer_list.c:234(printer_list_get_last_refresh)
Hello,
Did you activate the firewall of Nas4Free?
Short solution: set Samba logging to normal logging, this should be fixed in samba itself more upstream.
Not much we can do, or simply ignore this.
Hi, I have the same messages in logs and I use minimal logging mode in CIFS/SBM settings
Also I don't use firewall, Zeroconf/Bonjour...

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#39

Post by raulfg3 »

bocman wrote: Hi, I have the same messages in logs and I use minimal logging mode in CIFS/SBM settings
Also I don't use firewall, Zeroconf/Bonjour...
explanation here: viewtopic.php?f=21&t=11339
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

bocman
Starter
Starter
Posts: 21
Joined: 01 Apr 2013 11:46
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#40

Post by bocman »

raulfg3
Thank you!

bocman
Starter
Starter
Posts: 21
Joined: 01 Apr 2013 11:46
Status: Offline

Re: NAS4Free 10.3.0.3.2898 released (FreeBSD 10.3-RELEASE-P5)

#41

Post by bocman »

Hi, in I have messages in my system.log

Code: Select all

lighttpd[2642]: (connections.c.291) SSL: 1 error:1407609C:SSL routines:SSL23_GET_CLIENT_HELLO:http request 
lighttpd[2642]: (mod_fastcgi.c.1744) connect failed: No such file or directory on unix:/var/tmp/fastcgi/php.socket-1 
lighttpd[2642]: (mod_fastcgi.c.2846) backend died; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1 
What are its mean and how can I fix a problem?

Thank you!

Post Reply

Return to “Release Builds”