*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 796
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#1

Post by zoon01 »

The NAS4Free Team is pleased to announce the release of version 11.0.0.4.4141 - Sayyadina, this version replaces rev4124 !!!

Download build 11.0.0.4.4141
Read the readme_11.0

Major Change!

cifs/smb note:
==============
From Samba 4.5.0 and up the default value for the "ntlm auth" option is changed from "yes" to "no".
This may have impact on very old clients which doesn't support NTLMv2 yet.
Only if you really need NTLMv1 Authentication you can set in Additional Parameters: "ntlm auth = yes".

BUILD 11.0.0.4.4141

Changes after release 11.0.0.4.4067
===================================
- Update translations.
- Encrypt user passwords in config.
- Add Home icon to menu.
- Add new framework backup/restore.
- Add new framework service afp.
- Upgrade syncthing to 0.14.25.
- Upgrade tzdata to 2017b.
- Upgrade jQuery to 3.2.0.
- Upgrade samba to 4.6.1.
- Fix drop down menu on touchscreen with Firefox.
- Fix issues forcing vfs.zfs.min_auto_ashift to be 12 for new pools.
- Fix afp shares, now no longer get deleted.

Note:
Clear your browser's cache to avoid display issues after upgrade.
Make a new backup of your system configuration and store this on safe location.

Known bugs:
===========
- IE11 and Edge browser does not operate correctly with novnc. Enter & Escape button problematic,
this will be fixed at a later release, use Chrome or other browser or connect with putty client.

Enjoy!

Regards,
The NAS4Free Team
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

User avatar
zoon01
Developer
Developer
Posts: 796
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#2

Post by zoon01 »

Because of some issues 4124 release now replaced for 4141 release.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

jt01
NewUser
NewUser
Posts: 3
Joined: 23 Feb 2015 23:26
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#3

Post by jt01 »

zoon01 wrote:
28 Mar 2017 01:33
Because of some issues 4124 release now replaced for 4141 release.
Does this mean 4124 has been replaced with 4141? Or does this indicate a problem with 4141?

Thanks in advance for the clarification.

User avatar
zoon01
Developer
Developer
Posts: 796
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#4

Post by zoon01 »

upgrade to 4141 please, 4124 has a few bugs that are now fixed in 4141.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

Pachuco
NewUser
NewUser
Posts: 6
Joined: 02 Jul 2016 17:38
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#5

Post by Pachuco »

The upgraded was without a hint of a problem - at least until immediately afterwards (though I'm not yet certain what happened).

In an attempt to find out why I, after the update, cannot access my pool from Windows/Android, I realises that I didn't have NTP Time Server enabled (and an 8 min difference in system times could explain my problem). Enabling it in n4f gives an 'Error Code 1', informing it couldn't be done (I then manually updated the n4f system time). Does anyone else have this issue?

I can log in as root (e.g. PuTTY, GUI, WinSCP), and I'm presently investigating further why I cannot access pool from any of three PCs and an Android phone. The latter allows me to see the pool folders, but selecting one prompts me for a 'LAN password' so I suppose it has the same issue as the PCs (where using 'net use \\server\folder /user:server\user_name gives error code 86).

I'd be grateful for any ideas!
System specs: NAS4Free 10.3.0.3 x64-embedded on Microserver Gen8 (819185-421) / Xeon CPU E3-1220L V2 @ 2.30GHz - 12GB DDR3 1333MHz ECC (KTH-PL313E/8G) - Bios (HP) J06 07/16/2015; Storage: 2x WD Red NAS HDs (WD40EFRX) in mirrored ZFS

User avatar
zoon01
Developer
Developer
Posts: 796
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#6

Post by zoon01 »

Pachuco wrote:
30 Mar 2017 00:56
The upgraded was without a hint of a problem - at least until immediately afterwards (though I'm not yet certain what happened).

In an attempt to find out why I, after the update, cannot access my pool from Windows/Android, I realises that I didn't have NTP Time Server enabled (and an 8 min difference in system times could explain my problem). Enabling it in n4f gives an 'Error Code 1', informing it couldn't be done (I then manually updated the n4f system time). Does anyone else have this issue?

I can log in as root (e.g. PuTTY, GUI, WinSCP), and I'm presently investigating further why I cannot access pool from any of three PCs and an Android phone. The latter allows me to see the pool folders, but selecting one prompts me for a 'LAN password' so I suppose it has the same issue as the PCs (where using 'net use \\server\folder /user:server\user_name gives error code 86).

I'd be grateful for any ideas!
Try NTLMv1 Authentication in cifs/smb: you can set in Additional Parameters: "ntlm auth = yes".
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

Pachuco
NewUser
NewUser
Posts: 6
Joined: 02 Jul 2016 17:38
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#7

Post by Pachuco »

@zoon01

That did it :-)

Much appreciated together with all the efforts of keeping n4f updated and relevant!
System specs: NAS4Free 10.3.0.3 x64-embedded on Microserver Gen8 (819185-421) / Xeon CPU E3-1220L V2 @ 2.30GHz - 12GB DDR3 1333MHz ECC (KTH-PL313E/8G) - Bios (HP) J06 07/16/2015; Storage: 2x WD Red NAS HDs (WD40EFRX) in mirrored ZFS

slaycock
experienced User
experienced User
Posts: 89
Joined: 24 Jun 2012 17:15
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#8

Post by slaycock »

Following my replacement of USB and CF boot devices with some £20 32GB SSD I can report that all three of my Nas4free machines (1xGPT and 2xMBR) all upgraded from 4067 to 4141 without incident.

User avatar
alexey123
Moderator
Moderator
Posts: 1560
Joined: 19 Aug 2012 08:22
Location: Israel, Karmiel
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#9

Post by alexey123 »

High developers!
Can you modify /etc/rc.d/lighttpd for automatic allow ipv6 access to webgui ?

Differences

Code: Select all

--- lighttpd.orig	2017-03-26 20:15:26.000000000 +0300
+++ lighttpd	2017-04-01 10:22:38.000000000 +0300
@@ -84,6 +84,7 @@
 		fi
 	fi
 	_ipv6addr=""
+	_ipv6network=""
 	if configxml_isset "//interfaces/*[enable]/ipv6_enable"; then
 		_ipv6addr=`configxml_get "//interfaces/lan/ipv6addr"`
 		_ipv6subnet=`configxml_get "//interfaces/lan/ipv6subnet"`
@@ -108,7 +109,7 @@
 	_hostsallow=`configxml_get "//system/webgui/hostsallow"`
 	_hostsallow_disable=0
 	if [ -z "$_hostsallow" ]; then
-		_hostsallow="$_network"
+		_hostsallow="$_network $_ipv6network"	
 	fi
 	_hostsallow="${_hostsallow} 127.0.0.1"
 	if configxml_isset "//system/webgui/hostsallow_disable"; then
I attach file and patch
You do not have the required permissions to view the files attached to this post.
Home12.1.0.4 - Ingva (revision 7091)/ x64-embedded on AMD A8-7600 Radeon R7 A88XM-PLUS/ 16G RAM / UPS Ippon Back Power Pro 600
Lab 12.1.0.4 - Ingva (revision 7091) /x64-embedded on Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz / H61M-DS2 / 4G RAM / UPS Ippon Back Power Pro 600

User avatar
ms49434
Developer
Developer
Posts: 944
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#10

Post by ms49434 »

alexey123 wrote:
01 Apr 2017 10:31
High developers!
Can you modify /etc/rc.d/lighttpd for automatic allow ipv6 access to webgui ?
...

Code: Select all

# This patch file was generated by NetBeans IDE
# It uses platform neutral UTF-8 encoding and \n newlines.
--- a/<html>lighttpd (<b>4145</b>)</html>
+++ b/<html><b>Current File</b></html>
@@ -85,6 +85,8 @@
 		fi
 	fi
 	_ipv6addr=""
+	_ipv6subnet=""
+	_ipv6network=""
 	if configxml_isset "//interfaces/*[enable]/ipv6_enable"; then
 		_ipv6addr=`configxml_get "//interfaces/lan/ipv6addr"`
 		_ipv6subnet=`configxml_get "//interfaces/lan/ipv6subnet"`
@@ -113,10 +115,41 @@
 	# hosts allow
 	_hostsallow=`configxml_get "//system/webgui/hostsallow"`
 	_hostsallow_disable=0
-	if [ -z "$_hostsallow" ]; then
-		_hostsallow="$_network"
+	# fallback if hostsallow is empty
+	if [ -z "${_hostsallow}" ]; then
+		# add IPv4 network
+		if [ -n "${_network}" ]; then
+#			if [ -z "${_hostallow}" ]; then
+				_hostsallow="${_network}"
+#			else
+#				_hostsallow="${_hostsallow} ${_network}"
+#			fi
 	fi
+		# add IPv6 network
+		if [ -n "${_ipv6network}" ]; then
+			if [ -z "${_hostallow}" ]; then
+				_hostsallow="${_ipv6network}"
+			else
+				_hostsallow="${_hostsallow} ${_ipv6network}"
+			fi
+		fi
+	fi
+	# add IPv4 localhost
+	if [ -n "${_network}" ]; then
+		if [ -z "${_hostsallow}" ]; then
+			_hostsallow="127.0.0.1"
+		else
 	_hostsallow="${_hostsallow} 127.0.0.1"
+		fi
+	fi
+	# add IPv6 localhost
+	if [ -n "${_ipv6network}" ]; then
+		if [ -z "${_hostsallow}" ]; then
+			_hostsallow="::1"
+		else
+			_hostsallow="${_hostsallow} ::1"
+		fi
+	fi
 	if configxml_isset "//system/webgui/hostsallow_disable"; then
 		_hostsallow_disable=1
 	fi
could you please verify and confirm above changes please.
You do not have the required permissions to view the files attached to this post.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
alexey123
Moderator
Moderator
Posts: 1560
Joined: 19 Aug 2012 08:22
Location: Israel, Karmiel
Contact:
Status: Offline

Re: NAS4Free 11.0.0.4.4141 released (FreeBSD 11.0-RELEASE-P8)

#11

Post by alexey123 »

I check - 403 error on ip4 and ipv6
Image

Also I inspect my patch and I find error - result of routine get_network inet6 re1 is ipv6 network fe80::9e5c:8eff:fe82:99b8%re1/64. Red marked no need part

I attach working code and /var/etc/lighttpd.conf
You do not have the required permissions to view the files attached to this post.
Home12.1.0.4 - Ingva (revision 7091)/ x64-embedded on AMD A8-7600 Radeon R7 A88XM-PLUS/ 16G RAM / UPS Ippon Back Power Pro 600
Lab 12.1.0.4 - Ingva (revision 7091) /x64-embedded on Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz / H61M-DS2 / 4G RAM / UPS Ippon Back Power Pro 600

Post Reply

Return to “Release Builds”