*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[SOLVED] Shutdown causes reboot in 11.1.0.4.5019 (it was the WOL)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Indyman
NewUser
NewUser
Posts: 3
Joined: 04 Mar 2017 02:58
Status: Offline

[SOLVED] Shutdown causes reboot in 11.1.0.4.5019 (it was the WOL)

#1

Post by Indyman » 18 Dec 2017 21:27

I just upgraded to embedded version 5019 and whenever a shutdown command is issued the system reboots instead. Is there a bug in the new firmware or is it something else? In order to get to shutdown I have to manually shut off the computer. The system worked fine in previous firmware versions. Any ideas? Thank you
Last edited by Indyman on 19 Dec 2017 18:42, edited 1 time in total.
N4F 11.1.0.4.5019 embedded system on Intel DX975XBX with Core2Duo @2.4 GHz and 8Gb ECC memory, Intel 75Gb SSD and 2,3 and 4Gb WD HD (ZFS) as storage

User avatar
zoon01
Developer
Developer
Posts: 766
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: Shutdown causes reboot in 11.1.0.4.5019

#2

Post by zoon01 » 19 Dec 2017 06:53

add a tunable hw.acpi.disable_on_poweroff="0" in loader.conf

see freebsd handbook 11.16.3.5

11.16.3.5 System Powers Up After Suspend or Shutdown

First, try setting hw.acpi.disable_on_poweroff="0" in loader.conf(5). This keeps ACPI from disabling various events during the shutdown process. Some systems need this value set to 1 (the default) for the same reason. This usually fixes the problem of a system powering up spontaneously after a suspend or poweroff.

I can not reproduce this issue on my own machine.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.84 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

Re: Shutdown causes reboot in 11.1.0.4.5019

#3

Post by ChriZathens » 19 Dec 2017 09:11

This has happened to me in the past when I had WOL enabled.
Do you have WOL enabled? If yes, can you disable it and try again?
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

Indyman
NewUser
NewUser
Posts: 3
Joined: 04 Mar 2017 02:58
Status: Offline

Re: Shutdown causes reboot in 11.1.0.4.5019

#4

Post by Indyman » 19 Dec 2017 17:56

Thanks zoon01 and ChriZathens - I will try this and see. I boot the machine remotely via a magic packet from my Windows machine so I need WOL enabled. Is there a difference between WOL ON and WOL ON_MAGIC_PACKET that would cause this?
N4F 11.1.0.4.5019 embedded system on Intel DX975XBX with Core2Duo @2.4 GHz and 8Gb ECC memory, Intel 75Gb SSD and 2,3 and 4Gb WD HD (ZFS) as storage

Indyman
NewUser
NewUser
Posts: 3
Joined: 04 Mar 2017 02:58
Status: Offline

Re: [SOLVED] Shutdown causes reboot in 11.1.0.4.5019 (it was the WOL)

#5

Post by Indyman » 19 Dec 2017 18:53

OK - it was the WOL. Previously I had the WOL setting under LAN Management as WOL_MAGIC. For some reason when I upgraded firmware the setting was changed from WOL_MAGIC to ON. I was able to reproduce this: having WOL set to "ON" causes reboot on shutdown but having it set to WOL_MAGIC produces normal shutdown behavior. Strange - maybe it is related to an acpi issue? Thanks again to zoon01 and ChriZathens for your helpful suggestions!
N4F 11.1.0.4.5019 embedded system on Intel DX975XBX with Core2Duo @2.4 GHz and 8Gb ECC memory, Intel 75Gb SSD and 2,3 and 4Gb WD HD (ZFS) as storage

slaycock
experienced User
experienced User
Posts: 91
Joined: 24 Jun 2012 17:15
Status: Offline

Re: [SOLVED] Shutdown causes reboot in 11.1.0.4.5019 (it was the WOL)

#6

Post by slaycock » 13 Jul 2018 14:39

I've just come across this thread which has resolved my problems of rebooting on shutdown (currently using 11.2.0.4.5748). I think this solution is sufficiently useful that it should actually be included as a hint on the lanManagement page in the WOL section e.g. 'If reboot occurs using WOL_ON, ry WOL_MAGIC'

Post Reply

Return to “Release Builds”