*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 799
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#1

Post by zoon01 »

Warning: if you use thebrig, OBI or other stuff that use PHP, please do not upgrade until extensions are updated to support latest PHP 7.2.x or disable those extensions before upgrade!

The NAS4Free Team is pleased to announce the release of version 11.1.0.4.5127 - Atomics

Download build 11.1.0.4.5127
Please Read always the readme_11.1 file

BUILD 11.1.0.4.5127

Changes after release 11.1.0.4.5109
===============================
- WebGUI code & framework improvements.
- Upgrade gzip to 1.9.
- Upgrade syncthing to 0.14.44.
- Fix transmission starting.
- Fix bug in email setup.
- Fix remove geli flags before deleting a geli device.

Note:
Clear your browser's cache to avoid display issues after upgrade when coming from older release like past 11.0 series.
Make a new backup of your system configuration and store this on safe location, the system config.xml has been upgraded!

Enjoy!

Regards,
The NAS4Free Team
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

jamaroney
Advanced User
Advanced User
Posts: 258
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#2

Post by jamaroney »

All works fine for me, including transmission - thanks!

netware5
experienced User
experienced User
Posts: 136
Joined: 31 Jan 2017 21:39
Location: Sofia, BULGARIA
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#3

Post by netware5 »

Updated successfully from 5019.
XigmaNAS 12.1.0.4 - Ingva (rev.7542) embedded on HP Proliant Microserver Gen8, Xeon E3-1265L, 16 GB ECC, 2x4TB WD Red ZFS Mirror

User avatar
lux
Advanced User
Advanced User
Posts: 201
Joined: 23 Jun 2012 11:37
Location: Bielefeld, Germany
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#4

Post by lux »

updated from r5065 without any Problem!

THX to all Dev's!
Home:11.3.x.7014/emb@32GB USB|1270v2@X9SCA-F|ECC32GB|i340-T4[lagg@GS108Tv2&smb-mch]|M1015@IT|9HDD~40TB@3xRaidZ1+1HDD+2SSD i335&i520+1xi800P@ZIL|~44W idle@SS-400FL2|Nanoxia Deep Silence 6B|24/7
Services: CIFS, FTP, TFTP, SSH, NFS, Rsync, Syncthing, Webserver, BitTorrent, VirtualBox | Extensions: OBI, TheBrig[certbot, Asterisk] | Extensions via vBox: Pi-hole & Jellyfin @DebianVM's
Test:12.x/emb@16GB USB|X3 420e@M4A88TD-V|16GB|i350-T2|M1015@IT|8xHDD+3xSSD[different Size&Brand]RaidZ1+2|for TESTing only

User avatar
mooblie
experienced User
experienced User
Posts: 88
Joined: 23 Jun 2012 13:31
Location: The Highlands, Scotland
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#5

Post by mooblie »

Upgrade with no problems on two elderly HP Microservers: N36L and N40L.

AFP read speeds went from 96MB/s up to 108MB/s - practically saturating Gigabit Ethernet on a lowly N36L !

Many thanks to all concerned!!
Martin

vicmarto
NewUser
NewUser
Posts: 13
Joined: 19 Apr 2016 02:37
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#6

Post by vicmarto »

Hello,

Just upgraded the Nic of my NAS4Free to a 10Gbe Intel X540-T1 but... Autoselect configures it as 1000baseT, and can't force 10Gbe in the web, please, check attached capture.

Is this normal?
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#7

Post by raulfg3 »

vicmarto wrote:
18 Feb 2018 14:50
Hello,

Just upgraded the Nic of my NAS4Free to a 10Gbe Intel X540-T1 but... Autoselect configures it as 1000baseT, and can't force 10Gbe in the web, please, check attached capture.

Is this normal?
No, but first revise cable, most of the times is a bad cable that do not support expected speed ( I suffer this with a cat5 cable that do not work at 1000 only at 100 MB, once change the cable to cat6, I have 1000 MB).

PD: Check switch too, not only NIC and cable must be 10GB
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

vicmarto
NewUser
NewUser
Posts: 13
Joined: 19 Apr 2016 02:37
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#8

Post by vicmarto »

raulfg3 wrote:
18 Feb 2018 21:25
vicmarto wrote:
18 Feb 2018 14:50
Hello,

Just upgraded the Nic of my NAS4Free to a 10Gbe Intel X540-T1 but... Autoselect configures it as 1000baseT, and can't force 10Gbe in the web, please, check attached capture.

Is this normal?
No, but first revise cable, most of the times is a bad cable that do not support expected speed ( I suffer this with a cat5 cable that do not work at 1000 only at 100 MB, once change the cable to cat6, I have 1000 MB).

PD: Check switch too, not only NIC and cable must be 10GB
Thanks for reply raulfg3.

Have tried with another cable (this one cat.7, the other one was cat.6a) and same happens! But, it's strange, because 10Gbe can't be selected in the web interface, but ifconfig says it's connected as 10Gbe (and transfer speed confirms it):

Code: Select all

	ix0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=e407bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWTSO,RXCSUM_IPV6,TXCSUM_IPV6>
	ether ---------------
	hwaddr -------------
	inet 10.0.0.1 netmask 0x80000000 broadcast 127.255.255.255 
	nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
	media: Ethernet autoselect (10Gbase-T <full-duplex,rxpause,txpause>)
	status: active
No switch, it's a direct connection between 2 computers. ifconfig of the other computer:

Code: Select all

	en5: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
	options=67<RXCSUM,TXCSUM,VLAN_MTU,TSO4,TSO6>
	ether  ---------------
	inet6 fe80::14f3:377f:7a60:c085%en5 prefixlen 64 secured scopeid 0x6 
	inet 10.0.0.2 netmask 0xffffff00 broadcast 10.0.0.255
	nd6 options=201<PERFORMNUD,DAD>
	media: autoselect (10GbaseT <full-duplex,flow-control>)
	status: active
It's really strange, what can be?

User avatar
ms49434
Developer
Developer
Posts: 950
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#9

Post by ms49434 »

The options displayed in the WebGUI are usually not required because autoselect is the preferred option. Each driver comes with a specific set of supported media types which can be queried via

Code: Select all

ifconfig -m [interface name]
If you want to force a specific media type that isn't listed you should look into adding parameter into the extra option field on the interface page, read the ifconfig manual and the driver documentation.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Onichan
Advanced User
Advanced User
Posts: 240
Joined: 04 Jul 2012 21:41
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#10

Post by Onichan »

Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#11

Post by raulfg3 »

Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.
Use SMB instead NTLM
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Onichan
Advanced User
Advanced User
Posts: 240
Joined: 04 Jul 2012 21:41
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#12

Post by Onichan »

raulfg3 wrote:
21 Feb 2018 06:59
Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.
Use SMB instead NTLM
Not sure what you mean? Only NTLM I know of is the Auth protocol, If I do ntlm auth = disabled then it breaks my shares. Nothing coming to mind about SMB auth.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#13

Post by raulfg3 »

12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Onichan
Advanced User
Advanced User
Posts: 240
Joined: 04 Jul 2012 21:41
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#14

Post by Onichan »

Are you talking about SMBv1 vs SMBv2? If so I already disabled SMBv1 on mine last year as well for security reasons. All four options Server Max. Protocol, Server Min. Protocol, Client Max. Protocol and Client Min. Protocol are set to SMB2.

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1143
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#15

Post by JoseMR »

Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.

Hello, a workaround for this issue(if ZFS ACL not required) is to disable the "ZFS ACL" support for each share under "Services > CIFS/SMB > Share > Edit"
Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

Onichan
Advanced User
Advanced User
Posts: 240
Joined: 04 Jul 2012 21:41
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#16

Post by Onichan »

JoseMR wrote:
25 Feb 2018 01:51
Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.

Hello, a workaround for this issue(if ZFS ACL not required) is to disable the "ZFS ACL" support for each share under "Services > CIFS/SMB > Share > Edit"
Regards
That fixed it, thank you. The only reason I had ZFS ACL's enabled was a while back the logs were getting spammed if they weren't enabled.

tonyd
Starter
Starter
Posts: 24
Joined: 01 Nov 2012 16:20
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#17

Post by tonyd »

Onichan wrote:
25 Feb 2018 03:57
JoseMR wrote:
25 Feb 2018 01:51
Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.

Hello, a workaround for this issue(if ZFS ACL not required) is to disable the "ZFS ACL" support for each share under "Services > CIFS/SMB > Share > Edit"
Regards
That fixed it, thank you. The only reason I had ZFS ACL's enabled was a while back the logs were getting spammed if they weren't enabled.
I had the same problem with this build. I haven't touched my CIFS/SMB settings in a long time. This workaround also worked for me (needed to restart the CIFS/SMB service after updating the shares).

Before applying the workaround I was getting basically the same thing in the logs:

Code: Select all

Feb 24 22:52:15	fs	smbd[10234]: [2018/02/24 22:52:15.438193, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Feb 24 22:52:15	fs	smbd[10234]: user does not have list permission on snapdir /mnt/pool1/dsets/public/.zfs/snapshot
Feb 24 22:52:15	fs	smbd[10234]: [2018/02/24 22:52:15.438225, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 24 22:52:15	fs	smbd[10234]: access denied on listing snapdir /mnt/pool1/dsets/public/.zfs/snapshot
Feb 24 22:52:15	fs	smbd[10234]: [2018/02/24 22:52:15.438239, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 24 22:52:15	fs	smbd[10234]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/pool1/dsets/public, failed - NT_STATUS_ACCESS_DENIED.

User avatar
Viper780
Starter
Starter
Posts: 29
Joined: 23 Jun 2012 14:54
Location: Vienna / Austria / Europe
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#18

Post by Viper780 »

I've tried to download the latest Files
zoon01 wrote:
08 Feb 2018 19:34
The NAS4Free Team is pleased to announce the release of version 11.1.0.4.5127 - Atomics

Download build 11.1.0.4.5127

BUILD 11.1.0.4.5127
But on SF I'm getting an 500 Error that the "https://sourceforge.net/projects/nas4free/files/" is missing.
Is there any mirror? Or can I expect a new version soon?

best regards
Daniel

User avatar
ms49434
Developer
Developer
Posts: 950
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#19

Post by ms49434 »

SourceForge recently migrated to a new datacenter and new hardware. There are issues here and there - SF.net ops do their best to stabilize the platform.
You can get the latest SF.net operations updates from here: https://twitter.com/sfnet_ops
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

danzi
Starter
Starter
Posts: 66
Joined: 11 Nov 2012 23:24
Location: Budapest
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#20

Post by danzi »

11.1.0.4 - Atomics (revision 5127)


Slight formatting discrepancy between the two pages below:

Disks - ZFS - Configuration - Current

v.s.

Disks - ZFS - Configuration - Detected
----------------------------------------------
Dell T130 - 32Gb ECC - ESXi 6.7
VM Full Instal - 11.2.0.4 - Omnius (revision 6005)
HP/LSI 9121-4i SAS2008 Pass Through mode
2 x 2Tb ZFS mirror
1 x 3Tb UFS
----------------------------------------------

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#21

Post by raulfg3 »

can you please post a screen capture or someting to check?
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Tommy.Z
NewUser
NewUser
Posts: 1
Joined: 28 Jan 2018 10:43
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#22

Post by Tommy.Z »

WOL on my N36L is now working!
Thanks

doktornotor
Advanced User
Advanced User
Posts: 200
Joined: 16 May 2017 00:22
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#23

Post by doktornotor »

raulfg3 wrote:
21 Feb 2018 06:59
Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.
Use SMB instead NTLM
Not really sure what you mean here. We have SMB1 completely disabled across the entire network (not installed on W2016 servers, and disabled via GPO on workstations.) Yet, definitely seeing https://bugzilla.samba.org/show_bug.cgi?id=13175

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5117
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: NAS4Free 11.1.0.4.5127 released (FreeBSD 11.1-RELEASE-P6)

#24

Post by raulfg3 »

doktornotor wrote:
08 Mar 2018 09:24
raulfg3 wrote:
21 Feb 2018 06:59
Onichan wrote:
21 Feb 2018 01:01
Windows Previous versions broke again, same permission issue as last time this happened.

Code: Select all

Feb 20 18:56:17	nas	smbd[3243]: FSCTL_GET_SHADOW_COPY_DATA: connectpath /mnt/stuff/public, failed - NT_STATUS_ACCESS_DENIED.
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850650, 0] ../source3/modules/vfs_default.c:1375(vfswrap_fsctl)
Feb 20 18:56:17	nas	smbd[3243]: access denied on listing snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850639, 0] ../source3/modules/vfs_shadow_copy2.c:2063(shadow_copy2_get_shadow_copy_data)
Feb 20 18:56:17	nas	smbd[3243]: user does not have list permission on snapdir /mnt/stuff/public/./.zfs/snapshot
Feb 20 18:56:17	nas	smbd[3243]: [2018/02/20 18:56:17.850611, 0] ../source3/modules/vfs_shadow_copy2.c:1847(check_access_snapdir)
Last time I remember using it was NAS4Free-x64-embedded-11.1.0.4.5019 so might have been either this version or last version that broke it.
Use SMB instead NTLM
Not really sure what you mean here. We have SMB1 completely disabled across the entire network (not installed on W2016 servers, and disabled via GPO on workstations.) Yet, definitely seeing https://bugzilla.samba.org/show_bug.cgi?id=13175
Yes, sorry. the problem is ACL related and not NT1(SMB) related.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Post Reply

Return to “Release Builds”