*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 766
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#1

Post by zoon01 » 31 Jul 2018 16:26

We are pleased to announce the release of XigmaNAS version 11.2.0.4.5774 - Omnius

Download build 11.2.0.4.5774
Please Read the readme_11.2 file


Changes after release 11.1.0.4.5762
======================
- WebGUI code & framework improvements.
- Update translations.
- Upgrade devcpu-data to 1.18.
- Upgrade e2fsprogs to 1.44.3.
- Upgrade php to 7.2.8.
- Upgrade virtualbox-ose to 5.2.16.

Note:
- Make a new backup of your system configuration and store this on safe location, the system config.xml could be upgraded!
- Clear your browser's cache to avoid display issues after upgrade when coming from older nas4free release.

Regards,
Team XigmaNAS
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.84 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

User avatar
Snapshot
Starter
Starter
Posts: 31
Joined: 02 Dec 2015 10:27
Location: Wiltshire, England
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#2

Post by Snapshot » 31 Jul 2018 22:05

Upgraded from 5750 and nothing obviously broken....
HP Gen8 Microserver, Intel i5-3470T, 16GB RAM, 4 x 3TB WD Reds, Samsung Bar 32GB USB stick

User avatar
lindsay
Forum Moderator
Forum Moderator
Posts: 307
Joined: 23 Jun 2012 09:59
Location: Steinkjer,Norway
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#3

Post by lindsay » 31 Jul 2018 22:42

Upgrade OK here too
Protected by smoothiebox Red,Green,
Purple,Orange Zones/VLAN`s
Powered by AMD A10-6700T


XigmaNAS Box-1 11.2.0.4 - Omnius (revision 6625)
Platform : x64-embedded on 2X Intel(R) Xeon(R) CPU E5-2620 v4 @ 2.10GHz
Motherboard: ASUS Z10PA-D8, 2xSocket-2011-3
SATA Controllers : 1X Avago Technologies (LSI) SAS2008 and 1x Avago Technologies (LSI) SAS2308
Pool 1 (Media-Pool) 8X4TB in raidz2
Pool 2 (Media-Pool-2) 4X2TB in raidz2 and 2X2TB in mirror mirror and 2X3TB in mirror
Pool 3 (Media-Pool-3) 2X2TB in mirror and 2X4TB in mirror and 2X1TB in mirror

provels
experienced User
experienced User
Posts: 99
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#4

Post by provels » 03 Aug 2018 18:07

Upgraded here, no issues.
Last edited by provels on 04 Aug 2018 23:07, edited 2 times in total.
Peder
XigmaNAS 11.3.0.4.6928 Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

adultery_nas
Starter
Starter
Posts: 31
Joined: 12 Apr 2015 05:34
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#5

Post by adultery_nas » 03 Aug 2018 22:53

Works perfectly! Thanks for the frequent updates!! 8-)

doktornotor
Advanced User
Advanced User
Posts: 182
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#6

Post by doktornotor » 04 Aug 2018 10:52

adultery_nas wrote:
03 Aug 2018 22:53
Works perfectly! Thanks for the frequent updates!! 8-)
+1 8-)

netware5
experienced User
experienced User
Posts: 118
Joined: 31 Jan 2017 21:39
Location: Sofia, BULGARIA
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#7

Post by netware5 » 04 Aug 2018 21:05

Successfully upgraded from 11.1.0.4 rev.5673 Embedded to 11.2.0.4 rev.5774 using LiveCD and fresh install, then imported saved configuration. Zpool also upgraded.

Thanks to the developers!
XigmaNAS 12.0.0.4 - Reticulus (rev.6881) embedded on HP Proliant Microserver Gen8, Xeon E3-1265L, 16 GB ECC, 2x4TB WD Red ZFS Mirror

User avatar
apollo567
Site Admin
Site Admin
Posts: 716
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#8

Post by apollo567 » 04 Aug 2018 23:04

Upgrade worked for me also.
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

netware5
experienced User
experienced User
Posts: 118
Joined: 31 Jan 2017 21:39
Location: Sofia, BULGARIA
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#9

Post by netware5 » 12 Aug 2018 00:17

I've just discovered that IPMI status is not available anymore. In Diagnostics > Information > IPMI Stats there is a message "No IPMI sensor data available".

In System > Advanced > loader.conf the ipmi_load variable is set to YES.

May be a bug in 5774?
XigmaNAS 12.0.0.4 - Reticulus (rev.6881) embedded on HP Proliant Microserver Gen8, Xeon E3-1265L, 16 GB ECC, 2x4TB WD Red ZFS Mirror

doktornotor
Advanced User
Advanced User
Posts: 182
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#10

Post by doktornotor » 12 Aug 2018 10:21

netware5 wrote:
12 Aug 2018 00:17
I've just discovered that IPMI status is not available anymore. In Diagnostics > Information > IPMI Stats there is a message "No IPMI sensor data available".

In System > Advanced > loader.conf the ipmi_load variable is set to YES.

May be a bug in 5774?
Works just fine here.

netware5
experienced User
experienced User
Posts: 118
Joined: 31 Jan 2017 21:39
Location: Sofia, BULGARIA
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#11

Post by netware5 » 12 Aug 2018 13:32

doktornotor wrote:
12 Aug 2018 10:21
netware5 wrote:
12 Aug 2018 00:17
I've just discovered that IPMI status is not available anymore. In Diagnostics > Information > IPMI Stats there is a message "No IPMI sensor data available".

In System > Advanced > loader.conf the ipmi_load variable is set to YES.

May be a bug in 5774?
Works just fine here.
Seems to be that something was broken when the config has been imported after upgrade from 11.1 to 11.2. The issue fixed by setting the ipmi_load variable to NO, then apply, then set it again to YES, then apply and reboot.
XigmaNAS 12.0.0.4 - Reticulus (rev.6881) embedded on HP Proliant Microserver Gen8, Xeon E3-1265L, 16 GB ECC, 2x4TB WD Red ZFS Mirror

kfnas
Starter
Starter
Posts: 67
Joined: 06 Mar 2014 18:41
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#12

Post by kfnas » 13 Aug 2018 14:31

since few release ago, I can see some increasing usage of logs, which are by default in /var/log directory mounted /dev/md0 on / (ufs, local, noatime, acls) via mdconfig. Looks like compression is not on and after time the root / of the system become full.

df -h
Filesystem Size Used Avail Capacity Mounted on
/dev/md0 120M 120M 222K 100% /

question:

what is the proper way on the embedded version to add in command scripts or rc.conf menu to enable the compression of the md0 and or resize it please?

It looks like it is not possible to resize it without unmount first:

mdconfig -r -u md0 -s 256M
mdconfig: ioctl(/dev/mdctl): Operation not supported

thank you

wbond
NewUser
NewUser
Posts: 3
Joined: 11 Oct 2015 03:58
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#13

Post by wbond » 19 Aug 2018 16:37

I updated from 11.1.0.4 - Atomics (revision 5403) and everything looks good, except UPS monitoring. Status->Monitoring->UPS shows empty graphs:
Screen Shot 08-19-18 at 08.22 AM.PNG
I'm seeing this following error in the system log:

root: ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd'

The UPS status looks normal (Online) on the main status screen and the Diagnostics->Information->UPS screen looks normal as well.

Is anyone else seeing this, or know of a fix?

thanks
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4921
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#14

Post by raulfg3 » 19 Aug 2018 18:22

Delete .rdd files And reboot to regenerarte as new files.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#15

Post by crest » 20 Aug 2018 09:26

wbond wrote:
19 Aug 2018 16:37
I updated from 11.1.0.4 - Atomics (revision 5403) and everything looks good, except UPS monitoring. Status->Monitoring->UPS shows empty graphs:

Screen Shot 08-19-18 at 08.22 AM.PNG

I'm seeing this following error in the system log:

root: ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd' ERROR: No DS called 'ovoltage' in '/mnt/pool01/cifs-share-dataset/rrd/ups.rrd'

The UPS status looks normal (Online) on the main status screen and the Diagnostics->Information->UPS screen looks normal as well.

Is anyone else seeing this, or know of a fix?

thanks
Hello wbond,
discovered the same problem and found it broken in r5682, see also here => viewtopic.php?f=46&t=1081&p=86232#p86232
raulfg3 wrote:
19 Aug 2018 18:22
Delete .rdd files And reboot to regenerarte as new files.
This is not working, it just solves the error output to the log but battery voltage data will not be updated.

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

doktornotor
Advanced User
Advanced User
Posts: 182
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#16

Post by doktornotor » 23 Aug 2018 13:50

There's no need to reboot (in fact, completely useless as you've noticed). Just re-save the monitoring settings after deleting the screwed RRDs.
Screenshot_UPS_Monitoring.png
You do not have the required permissions to view the files attached to this post.

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: XigmaNAS 11.2.0.4.5774 released (FreeBSD 11.2-RELEASE-P0)

#17

Post by crest » 26 Aug 2018 06:00

doktornotor wrote:
23 Aug 2018 13:50
There's no need to reboot (in fact, completely useless as you've noticed). Just re-save the monitoring settings after deleting the screwed RRDs.

Screenshot_UPS_Monitoring.png
No, it's not what it is supposed to be ;)
Your screenshot shows the output AC voltage values rather than to show the battery DC voltage like below for a APC Back-UPS ES 550G:
rrd-ups_daily.png

But anyway please provide the raw output of your UPS - you can find it under Diagnostics > Information > UPS > NUT and tick 'Show RAW UPS Info', it would be interesting which parameters are provided by the CyberPower vendor for this UPS.
You do not have the required permissions to view the files attached to this post.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Post Reply

Return to “Release Builds”