*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 799
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#1

Post by zoon01 »

We are pleased to announce the release of XigmaNAS version 11.2.0.4.6177 - Omnius.

First BACKUP your current Configuration!
READ readme_11.2.txt please before you do anything!

Be aware that gvinum and geom raid5 will die for sure!
Softraid note:
==============
The option to create a softraid has been removed, existing softraid configurations are not impacted.
Softraid will be marked as deprecated in future 12.x series.
Please migrate to ZFS if you haven't done yet.

Download build 11.2.0.4.6177

Changes after release 11.2.0.4.6154
======================
- WebGUI code & framework improvements.
- Added kernel patch to fix a panic with lagg and vlan.
- Downgrade virtualbox-ose to 5.2.18. (again output on VNC)
- Upgrade tmux to 2.8.
- Upgrade tzdata to 2018g.
- Upgrade dialog to 1.3-20181022.
- Upgrade samba to 4.8.6.
- Fix my.cnf default location if not defined by user.

Note:
- Make a new backup of your system configuration and store this on safe location, the system config.xml could be upgraded!
- Clear your browser's cache to avoid display issues after upgrade when coming from older release.

Regards,
Team XigmaNAS
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

arghdubya
NewUser
NewUser
Posts: 10
Joined: 05 May 2018 02:31
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#2

Post by arghdubya »

Thanks for the update!

I have clean installed a Root-on-ZFS with 11.2.0.4 - Omnius (revision 6177)
boot is stripe (1 drive)
qty 6 (mixed 2 and 3 tb) drives in a Z1

So far so good except
1. Unformatted drives (even using HDD format ZFS Storage without checking GPT) are missing from vdev creation drive picker screen.
2. GPT labels aren't used in vdev creation, just device names like ada1p1, missing benefits from appending serial numbers of drives.

If this is by design, maybe something more obvious needs to be in the GUI.

I was able to make the pool with labels after SSH'ing in, so just an FYI.
1: N40L 4gb [(6) int 2tb +esata mediasonic (4) 2tb] 20tb's in Z2 , Marvel based eSata, boot on ZFSonRoot
2: Noontec (J1800 based) 4gb 2bay NAS with 1tb mirror, dedup on, rev5074, USB boot
3: UNAS 4bay Intel DH61DL 8gb, Marvel MiniPCIe AHCI, SDD boot root-on-ZFS , (6) 3tb in Z1 (10tb total currently)
& 4 QNAPs, 1 Synology, Win2008 EX495, Vsphere 6.7, Win Server 2016 AD

arghdubya
NewUser
NewUser
Posts: 10
Joined: 05 May 2018 02:31
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#3

Post by arghdubya »

I spoke too soon.
I turned on Active Directory auth and got file errors when checked in Information -- MS Domain
/usr/local/lib/samba4/private/libgenrand-samba4.so: version SAMBA_4.8.6 required by /usr/local/lib/libndr.so.0 not found

switching to Local User Auth
I don't get shares to show in Information in CIFS/SMB

SSH:
xigmanas: /# smbstatus
/usr/local/lib/samba4/private/libsamba-debug-samba4.so: version SAMBA_4.8.6 required by /usr/local/lib/libsamba-util.so.0 not found
xigmanas: /#
xigmanas: /# ls -l /usr/local/lib/libsamba*
-rwxr-xr-x 1 root wheel 225636 Nov 2 16:11 /usr/local/lib/libsamba-credentials.so.0
-rwxr-xr-x 1 root wheel 1331477 Nov 2 16:11 /usr/local/lib/libsamba-errors.so.1
-rwxr-xr-x 1 root wheel 375228 Nov 2 16:11 /usr/local/lib/libsamba-hostconfig.so.0
-rwxr-xr-x 1 root wheel 1177374 Nov 2 16:11 /usr/local/lib/libsamba-passdb.so.0
-rwxr-xr-x 1 root wheel 139123 Nov 2 16:12 /usr/local/lib/libsamba-policy.so.0
-rwxr-xr-x 1 root wheel 957965 Nov 2 16:11 /usr/local/lib/libsamba-util.so.0
xigmanas: /#

Again, clean install on root-on-zfs
1: N40L 4gb [(6) int 2tb +esata mediasonic (4) 2tb] 20tb's in Z2 , Marvel based eSata, boot on ZFSonRoot
2: Noontec (J1800 based) 4gb 2bay NAS with 1tb mirror, dedup on, rev5074, USB boot
3: UNAS 4bay Intel DH61DL 8gb, Marvel MiniPCIe AHCI, SDD boot root-on-ZFS , (6) 3tb in Z1 (10tb total currently)
& 4 QNAPs, 1 Synology, Win2008 EX495, Vsphere 6.7, Win Server 2016 AD

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1145
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#4

Post by JoseMR »

arghdubya wrote:
05 Nov 2018 06:06
Thanks for the update!

I have clean installed a Root-on-ZFS with 11.2.0.4 - Omnius (revision 6177)
boot is stripe (1 drive)
qty 6 (mixed 2 and 3 tb) drives in a Z1

So far so good except
1. Unformatted drives (even using HDD format ZFS Storage without checking GPT) are missing from vdev creation drive picker screen.
2. GPT labels aren't used in vdev creation, just device names like ada1p1, missing benefits from appending serial numbers of drives.

If this is by design, maybe something more obvious needs to be in the GUI.

I was able to make the pool with labels after SSH'ing in, so just an FYI.

Hello, your issue is completely expected, ZFS disk has to be imported after a reinstall just once, this default behavior also applies for FreeBSD, but I will give you some tips that will help you and others for future RootOnZFS re-installs:

After a XigmaNAS re-install and imported config, after booting to the newly installation, Go To: Disks > Management > HDD Management and check Clear Configuration and push Import, this updated the config.xml to expose your drives to to the WebGUI in case some are missing, though this should be already stored in your last saver config.xml.

After the previous steps, simply Go To: Tools > Execute Command and execute the below commands:

To import any ZFS pools available:

Code: Select all

zpool import -f -a
To Import any ZFS pools available with they gpt/labels:

Code: Select all

zpool import -f -a -d /dev/gpt
In case you imported them without "-d /dev/gpt", export the pool and retry with the -d option.


Now you can Go To: Disks > ZFS > Configuration > Synchronize and synchronize the zroot datasetd you want to expose to the WebGUI, you may usually uncheck here /var and /tmp, or every zroot data set to isolate them from the WebGUI.

After performing this simple steps, the zpool.cache should be updated and you are good to go.

TIP:Additionally if you want to prevent this from happening each time you re-install RootOnZFS, make a small script/postinit command to backup/restore your "/boot/zfs/zpool.cache" automatically.

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

User avatar
Snufkin
Advanced User
Advanced User
Posts: 339
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#5

Post by Snufkin »

arghdubya wrote:
05 Nov 2018 06:06
So far so good except
...
2. GPT labels aren't used in vdev creation, just device names like ada1p1, missing benefits from appending serial numbers of drives.

I was able to make the pool with labels after SSH'ing in, so just an FYI.
Option you looking for has never been there, if you created a VDev from scratch.
You can add GPT labeled disk to existent VDev only.

There is a way to stay in GUI and work around above limitation (tested for mirror VDev only).
  • You just need to create a VDev based on single partition, e.g. ad0p1.
  • Then go to Disks | ZFS | Pools | Tools page and add second disk but under its GTP label.
  • You'll get VDev built on disks referenced by both partition and label.
  • At the end just delete first disk and re-add it again but under its label.
XNAS 11.4.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2
ZFS 2 x HGST HDN726040ALE614, L2ARC PLEXTOR PX-128M5S

arghdubya
NewUser
NewUser
Posts: 10
Joined: 05 May 2018 02:31
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#6

Post by arghdubya »

Thanks Gentlemen, I forgot normal behavior.
I got used to seeing another pool with many replaced drives, and yes, the GUI does show labels in the Tools command for an already created vdev/pool.
I'm sure there are reasons for the 2-step we have with the pool creation, and don't want to take this thread off-topic.
1: N40L 4gb [(6) int 2tb +esata mediasonic (4) 2tb] 20tb's in Z2 , Marvel based eSata, boot on ZFSonRoot
2: Noontec (J1800 based) 4gb 2bay NAS with 1tb mirror, dedup on, rev5074, USB boot
3: UNAS 4bay Intel DH61DL 8gb, Marvel MiniPCIe AHCI, SDD boot root-on-ZFS , (6) 3tb in Z1 (10tb total currently)
& 4 QNAPs, 1 Synology, Win2008 EX495, Vsphere 6.7, Win Server 2016 AD

karlandtanya
Starter
Starter
Posts: 50
Joined: 23 Jan 2014 15:31
Location: nelson twp, OH, USA
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#7

Post by karlandtanya »

Upgraded from 6154 embedded perfectly.
Also, phpmyadmin works now!

Keep up the good work; xigmanas is better with each release.

arghdubya
NewUser
NewUser
Posts: 10
Joined: 05 May 2018 02:31
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#8

Post by arghdubya »

I just restored the config from 5975 or 5925 on a USB booting HP MicroServer.
And it seems fine and Samba is fine as well.
I did some pkg installs (Emby) on the root-on-zfs clean install I did, and maybe something botched Samba. I'll look more into it later.
1: N40L 4gb [(6) int 2tb +esata mediasonic (4) 2tb] 20tb's in Z2 , Marvel based eSata, boot on ZFSonRoot
2: Noontec (J1800 based) 4gb 2bay NAS with 1tb mirror, dedup on, rev5074, USB boot
3: UNAS 4bay Intel DH61DL 8gb, Marvel MiniPCIe AHCI, SDD boot root-on-ZFS , (6) 3tb in Z1 (10tb total currently)
& 4 QNAPs, 1 Synology, Win2008 EX495, Vsphere 6.7, Win Server 2016 AD

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1145
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#9

Post by JoseMR »

arghdubya wrote:
06 Nov 2018 05:21
I just restored the config from 5975 or 5925 on a USB booting HP MicroServer.
And it seems fine and Samba is fine as well.
I did some pkg installs (Emby) on the root-on-zfs clean install I did, and maybe something botched Samba. I'll look more into it later.
Hello, Do not install Emby on XigmaNAS Full Platforms, the Dependency List for Emby is insanely huge(notice samba48 also dependency) and some system core files/rc's may gets overwritten causing system malfunction, this is because XigmaNAS does not ship with a database of the already installed packages/dependencies.

This is one of those packages that must be jailed/isolated from the system, however the built-in VirtualBox may be another easier option if you are not into jails stuff.

Additionally since you use RootOnZFS you can use the same HDD/SSD as the VirtualBox VM's data store if you want to minimize disk writes to the storage array, a ZFS/Volume or Dataset may be good candidate, note that critical VM's/Jails must be placed on a redundant data storage location unless zroot is mirrored.

P.S
Note that creating a dataset directly to the XigmaNAS "zroot" from the WebGUI may cause the dataset not to be mounted below "/mnt/dataset" but below /zroot/dataset, and this is expected, this is because the WebGUI wont let you make for an mountpoint override during this step from "Disks > ZFS > Datasets > Dataset",

Alternatively, you can make the dataset below "/mnt/" with one liner command easily executed from the WebGUI like shown below:

Code: Select all

zfs create -o canmount=on -o mountpoint=/mnt/Data zroot/Data
If you already created the dataset from WebGUI and want to move it to "/mnt/Data" simply use:

Code: Select all

zfs set mountpoint=/mnt/Data zroot/Data
Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1145
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#10

Post by JoseMR »

Notice: I found a regression on RootOnZFS installer, that affects all new installs from revision 6177, this was cause by possibly lag in my source repo and I provided a previous version of the zfsinstaller.sh file without the required code for the proper zfs datasets, this has been fixed already and it will be available for the next release which also includes new features and general improvements, more on that HERE, upgrades from WebGUI are non affected.

I'm really sorry for this mistake I've made and for the all inconveniences this can cause. :oops:

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

doktornotor
Advanced User
Advanced User
Posts: 200
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#11

Post by doktornotor »

A bug with Diagnostics > Log > Settings
diaglog_settings.png
You do not have the required permissions to view the files attached to this post.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5119
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#12

Post by raulfg3 »

you need to enable remote syslog to modify port.

error appears if you do not enable remote syslog?
You do not have the required permissions to view the files attached to this post.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

doktornotor
Advanced User
Advanced User
Posts: 200
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#13

Post by doktornotor »

raulfg3 wrote:
11 Nov 2018 00:45
you need to enable remote syslog to modify port.
I am not trying to enable remote syslog or modify port. This validation error should not appear when the remote syslog is disabled, there are other settings there that work without remote syslog. Also, I did not even submit anything, the error is there directly when loading the page.

doktornotor
Advanced User
Advanced User
Posts: 200
Joined: 16 May 2017 00:22
Status: Offline

Re: XigmaNAS 11.2.0.4.6177 released (FreeBSD 11.2-RELEASE-P4)

#14

Post by doktornotor »

doktornotor wrote:
10 Nov 2018 23:42
A bug with Diagnostics > Log > Settings

diaglog_settings.png
Fixed in 6195, thanks. 8-)

Post Reply

Return to “Release Builds”