Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 747
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#1

Post by zoon01 » 20 Jun 2019 01:59

We are pleased to announce the release of XigmaNAS version 11.2.0.4.6766 - Omnius.

First BACKUP your current Configuration!
READ readme_11.2.txt please before you do anything!

Download build 11.2.0.4.6766

Changes after release 11.2.0.4.6743
===================================
- Update translations.
- WebGUI code & framework improvements.
- Add loglevel for sshd.
- Use external ldb 1.3.8.
- Upgrade nano to 4.3.
- Upgrade bsnmp-ucd to 0.4.3.
- Upgrade mariadb to 10.2.25.

fixes:
===
- Fix set correct file permissions.

Basic Note:
- Make a new backup of your system configuration and store this on safe location, the system config.xml could be upgraded!
- Clear your browser's cache to avoid display issues after upgrade when coming from older release.

Regards,
Team XigmaNAS
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.77 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

provels
experienced User
experienced User
Posts: 96
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#2

Post by provels » 20 Jun 2019 02:45

Upgraded from 6743 without issue. Thanks to all the devs.

Will v.11 become obsoleted by v.12 soon?
Peder
XigmaNAS 11.2.0.4 (6766) Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

User avatar
zoon01
Developer
Developer
Posts: 747
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#3

Post by zoon01 » 20 Jun 2019 02:54

provels wrote:
20 Jun 2019 02:45
Upgraded from 6743 without issue. Thanks to all the devs.

Will v.11 become obsoleted by v.12 soon?
v.11.x become obsoleted by v.12.x one day, we have not set a time/date yet,
for now we support both versions, v11 is pretty stable, v12.0 needs some time and later on a 12.1 release.
We will see how it goes, users do not have to rush to switch.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.77 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

provels
experienced User
experienced User
Posts: 96
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#4

Post by provels » 20 Jun 2019 03:13

zoon01 wrote:
20 Jun 2019 02:54
v.11.x become obsoleted by v.12.x one day, we have not set a time/date yet,
for now we support both versions, v11 is pretty stable, v12.0 needs some time and later on a 12.1 release.
We will see how it goes, users do not have to rush to switch.
Only curious. I've been with you since 9..x with my antique HP server. Thanks again.
Peder
XigmaNAS 11.2.0.4 (6766) Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

biggsy
experienced User
experienced User
Posts: 80
Joined: 02 Jul 2012 10:24
Location: Sydney, Australia
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#5

Post by biggsy » 24 Jun 2019 11:27

Attempting to use File Manager in the last two 11. releases (6743 & 6766) I have encountered the following error:

Code: Select all

Parse error: syntax error, unexpected ',', expecting ']' in /usr/local/www/quixplorer/_config/.htusers.php on line 7 
The first time I saw this, in 6743, I tracked it down to a missing comma at the end of line 6 - the entry for root and fixed it then. I had never edited this file before.

Unfortunately, I don't know when the error might have been introduced because I don't use File Manager very often but it has returned in 6766.

6 ['root','redacted stuff here.Wy1','/','http://localhost',1,'',32847,1]comma missing here
7 ['','','/','http://localhost',1,'',32847,1],
8 ['root','','/','http://localhost',1,'',32847,1]
9 ];
10 ?>

Please let me know if there is any more information needed.

User avatar
ms49434
Developer
Developer
Posts: 638
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#6

Post by ms49434 » 24 Jun 2019 19:31

biggsy wrote:
24 Jun 2019 11:27
Attempting to use File Manager in the last two 11. releases (6743 & 6766) I have encountered the following error:

Code: Select all

Parse error: syntax error, unexpected ',', expecting ']' in /usr/local/www/quixplorer/_config/.htusers.php on line 7 
The first time I saw this, in 6743, I tracked it down to a missing comma at the end of line 6 - the entry for root and fixed it then. I had never edited this file before.

Unfortunately, I don't know when the error might have been introduced because I don't use File Manager very often but it has returned in 6766.

6 ['root','redacted stuff here.Wy1','/','http://localhost',1,'',32847,1]comma missing here
7 ['','','/','http://localhost',1,'',32847,1],
8 ['root','','/','http://localhost',1,'',32847,1]
9 ];
10 ?>

Please let me know if there is any more information needed.
- please run /etc/rc.d/fmperm and post the output of /usr/local/www/quixplorer/_config/.htusers.php, wrapped in 'code' tags and hashed passwords stripped.
- please edit and immediately save a user record in Tools > File Manager > Admin and post the output of /usr/local/www/quixplorer/_config/.htusers.php, wrapped in 'code' tags and hashed passwords stripped.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

biggsy
experienced User
experienced User
Posts: 80
Joined: 02 Jul 2012 10:24
Location: Sydney, Australia
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#7

Post by biggsy » 24 Jun 2019 23:58

Content of /usr/local/www/quixplorer/_config/.htusers.php after running /etc/rc.d/fmperm:

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
After adding new user 'test':

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
Thanks for looking at this.

EDIT - I'm fairly sure that I had the missing comma in place on line 6 before I ran /etc/rc.d/fmperm.

User avatar
ms49434
Developer
Developer
Posts: 638
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#8

Post by ms49434 » 25 Jun 2019 00:53

biggsy wrote:
24 Jun 2019 23:58
Content of /usr/local/www/quixplorer/_config/.htusers.php after running /etc/rc.d/fmperm:

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
After adding new user 'test':

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
Thanks for looking at this.

EDIT - I'm fairly sure that I had the missing comma in place on line 6 before I ran /etc/rc.d/fmperm.
The issue is caused by the remote syslog server configuration when checkbox "Send system event messages." is enabled.
If you are forwarding syslog messages to a remote syslog server, could you please disable the above checkbox, select save and rerun the test?
If you are not forwarding syslog messages, the above checkbox is hidden. Please enable the service (to unhide the checkbox), uncheck the checkbox, uncheck enable service, save the setting and rerun the test.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

biggsy
experienced User
experienced User
Posts: 80
Joined: 02 Jul 2012 10:24
Location: Sydney, Australia
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#9

Post by biggsy » 25 Jun 2019 02:00

Sorry, I forgot to repeat the add a new user step.

Here's the sanitized .htusers.php before unchecking "Send system event messages.":

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
. . . and after :

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>

User avatar
ms49434
Developer
Developer
Posts: 638
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#10

Post by ms49434 » 25 Jun 2019 02:16

biggsy wrote:
25 Jun 2019 02:00
Sorry, I forgot to repeat the add a new user step.

Here's the sanitized .htusers.php before unchecking "Send system event messages.":

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
  ['','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
. . . and after :

Code: Select all

<?php
$GLOBALS["users"] = [
  ['David','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['Phil','','/mnt/POOL1','http://localhost',0,'^.ht',17,1],
  ['test','','/mnt','http://localhost',0,'^.ht',17,1],
  ['admin','','/','http://localhost',1,'',32847,1],
  ['root','','/','http://localhost',1,'',32847,1]
];
?>
Many thanks for testing, a bug fix has been developed and has been committed:
6773 - loop is not needed and
6774 - rename field 'system' to 'sendsystemeventmessages' to avoid xpath issues
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

biggsy
experienced User
experienced User
Posts: 80
Joined: 02 Jul 2012 10:24
Location: Sydney, Australia
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#11

Post by biggsy » 25 Jun 2019 02:25

Thank you, ms49434, for finding and fixing this so quickly.

jamaroney
Advanced User
Advanced User
Posts: 210
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#12

Post by jamaroney » 25 Jun 2019 12:52

ms49434 wrote:
25 Jun 2019 00:53
If you are not forwarding syslog messages, the above checkbox is hidden. Please enable the service (to unhide the checkbox), uncheck the checkbox, uncheck enable service, save the setting and rerun the test.
I had the same problem w/ 6766 - the instructions above yielded no success. I then went into the .htusers.php and added the necessary comma, and all is now OK w/ File manager.

I have an embedded install - I assume that if if the system is rebooted, I will again have to go to that file and add the comma?

User avatar
ms49434
Developer
Developer
Posts: 638
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#13

Post by ms49434 » 25 Jun 2019 13:16

jamaroney wrote:
25 Jun 2019 12:52
ms49434 wrote:
25 Jun 2019 00:53
If you are not forwarding syslog messages, the above checkbox is hidden. Please enable the service (to unhide the checkbox), uncheck the checkbox, uncheck enable service, save the setting and rerun the test.
I had the same problem w/ 6766 - the instructions above yielded no success. I then went into the .htusers.php and added the necessary comma, and all is now OK w/ File manager.

I have an embedded install - I assume that if if the system is rebooted, I will again have to go to that file and add the comma?
Please do a search for <system> in config.xml and report back the number of occurences. If the result is not 1, please report the xml hierarchy of the found tags, i.e. <xigmanas><system>.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

jamaroney
Advanced User
Advanced User
Posts: 210
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#14

Post by jamaroney » 25 Jun 2019 13:47

ms49434 wrote:
25 Jun 2019 13:16

Please do a search for <system> in config.xml and report back the number of occurences. If the result is not 1, please report the xml hierarchy of the found tags, i.e. <xigmanas><system>.
"<system>" occurs only once.

jamaroney
Advanced User
Advanced User
Posts: 210
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#15

Post by jamaroney » 25 Jun 2019 15:59

jamaroney wrote:
25 Jun 2019 12:52
ms49434 wrote:
25 Jun 2019 00:53
If you are not forwarding syslog messages, the above checkbox is hidden. Please enable the service (to unhide the checkbox), uncheck the checkbox, uncheck enable service, save the setting and rerun the test.
I had the same problem w/ 6766 - the instructions above yielded no success. I then went into the .htusers.php and added the necessary comma, and all is now OK w/ File manager.

I have an embedded install - I assume that if if the system is rebooted, I will again have to go to that file and add the comma?
UPDATE: After all I did above, I saved the system config onto my PC. I then rebooted XNAS, and it wouldn't start, saying no config file could be found. I had to do a fresh embedded install of 6766, and when I restored it to my saved config (with change in syslog setting), File manager worked fine. I don't know if the comma I added in .htusers.php messed up something else, so perhaps the best route is to simply change the syslog setting, save the new config file (just in case), and reboot.

stevencomerthor
NewUser
NewUser
Posts: 7
Joined: 22 Jan 2015 14:39
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#16

Post by stevencomerthor » 01 Jul 2019 20:17

biggsy wrote:
24 Jun 2019 11:27
Attempting to use File Manager in the last two 11. releases (6743 & 6766) I have encountered the following error:

Code: Select all

Parse error: syntax error, unexpected ',', expecting ']' in /usr/local/www/quixplorer/_config/.htusers.php on line 7 
The first time I saw this, in 6743, I tracked it down to a missing comma at the end of line 6 - the entry for root and fixed it then. I had never edited this file before.

Unfortunately, I don't know when the error might have been introduced because I don't use File Manager very often but it has returned in 6766.

6 ['root','redacted stuff here.Wy1','/','http://localhost',1,'',32847,1]comma missing here
7 ['','','/','http://localhost',1,'',32847,1],
8 ['root','','/','http://localhost',1,'',32847,1]
9 ];
10 ?>

Please let me know if there is any more information needed.
Thank you!! :D

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4900
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 11.2.0.4.6766 released (FreeBSD 11.2-RELEASE-P10)

#17

Post by raulfg3 » 02 Jul 2019 09:38

12.0.0.4 - BETA (revision 6625)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes
Old Wiki

Post Reply

Return to “Release Builds”