*New 12.1 series Release:
2020-09-13: XigmaNAS 12.1.0.4.7743 - released

*New 11.4 series Release:
2020-09-12: XigmaNAS 11.4.0.4.7741 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 811
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#1

Post by zoon01 »

We are pleased to announce the release of XigmaNAS version 12.1.0.4.7683 Ingva.
This is a new stable release for the 12.x branch.

First BACKUP your current Configuration!
READ readme_12.1.txt please before you do anything!

Download build 12.1.0.4.7683

Changes after release 12.1.0.4.7664
===================================
- WebGUI code & framework improvements.
- Return to transmissioin 2.92.
- Upgrade mariadb to 10.5.
- Upgrade virtualbox-ose to 5.2.44.
- Upgrade bash to 5.0 P18.
- Upgrade syncthing to 1.7.1.

Regards,
Team XigmaNAS


Basic Note:
- Make a new backup of your system configuration and store this on safe location, the system config.xml could be upgraded!
- Clear your browser's cache to avoid display issues after upgrade when coming from older release.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

User avatar
Earendil
Moderator
Moderator
Posts: 53
Joined: 23 Jun 2012 15:57
Location: near Boston, MA, USA.
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#2

Post by Earendil »

Installs just fine. Transmission's webgui is back. Thanks Zoon.
Earendil

XigmaNAS server:
-AMD A10-7860K APU
-Gigabyte F2A88XM-D3HP w/16GB RAM
-pool0 - 4x 2 TB WD green HDDs
-pool1 - 6x 8 TB WD white HDDs
-Ziyituod (used to be Ubit) SA3014 PCI-e 1x SATA card
-External Orico USB 3.0 5 bay HDD external enclosure set at RAID 5
--5x 4 TB WD green HDDs
-650W power supply

User avatar
sea1150
experienced User
experienced User
Posts: 105
Joined: 23 Jun 2012 07:01
Location: South Urals
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#3

Post by sea1150 »

Can anyone write about mariadb's work? Are there any problems? It works fine for me on version 11.4.0.4!
XigmaNAS 11.4.0.4 x64-embedded on - ASUS P8H61-I LX R2.0-GLAN, i5-3570 CPU @ 3.40GHz, 16GB Memory Kit, PCIEx2 Marvell 88SE9230 AHCI 4xSATA controller, HDD: 2x2Tb-UFS, 4x1Tb-RaidZ & 1xSSD L2ARC.
XigmaNAS 11.4.0.4 x64-embedded in - VM on ESXi 6.7, 16GB ECC RAM, LSI SAS2008 IT passtrough mode on HP Proliant DL180G6 2xL5640, 112GB RAM, HDD: 12Bay
- and more... My work and all versions

andkaz73
NewUser
NewUser
Posts: 5
Joined: 22 Jul 2020 03:13
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#4

Post by andkaz73 »

Mariadb after update dont work. When trying to restart in webGUI:
"Error: The changes could not be applied (Error Code 1)."
How to repair Mariadb?

Chucko
Starter
Starter
Posts: 27
Joined: 18 Jan 2016 09:48
Location: Silicon Valley, CA, USA
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#5

Post by Chucko »

STILL can't upgrade full install from the web interface. I lose the connection to XigmaNAS after uploading from my desktop.

Currently on FreeBSD 12.1.0.4, rev 7389. Desktop is macOS 10.15.6, Safari browser.

Chucko
Starter
Starter
Posts: 27
Joined: 18 Jan 2016 09:48
Location: Silicon Valley, CA, USA
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#6

Post by Chucko »

Fortunately I had the command line update instructions bookmarked, and they worked fine: https://www.xigmanas.com/wiki/doku.php? ... mmand_line
Chucko wrote:
22 Jul 2020 04:27
STILL can't upgrade full install from the web interface. I lose the connection to XigmaNAS after uploading from my desktop.

Currently on FreeBSD 12.1.0.4, rev 7389. Desktop is macOS 10.15.6, Safari browser.

User avatar
sea1150
experienced User
experienced User
Posts: 105
Joined: 23 Jun 2012 07:01
Location: South Urals
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#7

Post by sea1150 »

andkaz73 wrote:
22 Jul 2020 03:17
Mariadb after update dont work. When trying to restart in webGUI:
"Error: The changes could not be applied (Error Code 1)."
How to repair Mariadb?
Temporary solution:
add via web interface a variable mysql_limits = "" to rc.conf and restart service MariaDB
XigmaNAS 11.4.0.4 x64-embedded on - ASUS P8H61-I LX R2.0-GLAN, i5-3570 CPU @ 3.40GHz, 16GB Memory Kit, PCIEx2 Marvell 88SE9230 AHCI 4xSATA controller, HDD: 2x2Tb-UFS, 4x1Tb-RaidZ & 1xSSD L2ARC.
XigmaNAS 11.4.0.4 x64-embedded in - VM on ESXi 6.7, 16GB ECC RAM, LSI SAS2008 IT passtrough mode on HP Proliant DL180G6 2xL5640, 112GB RAM, HDD: 12Bay
- and more... My work and all versions

andkaz73
NewUser
NewUser
Posts: 5
Joined: 22 Jul 2020 03:13
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#8

Post by andkaz73 »

sea1150 wrote:
22 Jul 2020 12:22
Temporary solution:
add via web interface a variable mysql_limits = "" to rc.conf and restart service MariaDB
I try it. Mariadb is working, but Nextlcoud, installed from OneButtonInstaller dont work (Internal Server Error). Ok, I try "occ" command:

Code: Select all

sudo -u www php occ maintenance:mode --on

An unhandled exception has been thrown:
Doctrine\DBAL\DBALException: Failed to connect to the database: An exception occurred in driver: SQLSTATE[HY000] [2002] No such file or directory in /mnt/Pool1/nextcloud/www/lib/private/DB/Connection.php:67
Stack trace:
#0 /mnt/Pool1/nextcloud/www/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(889): OC\DB\Connection->connect()
#1 /mnt/Pool1/nextcloud/www/lib/private/DB/Connection.php(194): Doctrine\DBAL\Connection->executeQuery('SELECT * FROM `...', Array, Array, NULL)
#2 /mnt/Pool1/nextcloud/www/3rdparty/doctrine/dbal/lib/Doctrine/DBAL/Query/QueryBuilder.php(200): OC\DB\Connection->executeQuery('SELECT * FROM `...', Array, Array)
#3 /mnt/Pool1/nextcloud/www/lib/private/DB/QueryBuilder/QueryBuilder.php(216): Doctrine\DBAL\Query\QueryBuilder->execute()
#4 /mnt/Pool1/nextcloud/www/lib/private/AppConfig.php(331): OC\DB\QueryBuilder\QueryBuilder->execute()
#5 /mnt/Pool1/nextcloud/www/lib/private/AppConfig.php(109): OC\AppConfig->loadConfigValues()
#6 /mnt/Pool1/nextcloud/www/lib/private/AppConfig.php(287): OC\AppConfig->getApps()
#7 /mnt/Pool1/nextcloud/www/lib/private/legacy/OC_App.php(883): OC\AppConfig->getValues(false, 'installed_versi...')
#8 /mnt/Pool1/nextcloud/www/lib/private/Server.php(662): OC_App::getAppVersions()
#9 /mnt/Pool1/nextcloud/www/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC\{closure}(Object(OC\Server))
#10 /mnt/Pool1/nextcloud/www/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet('OC\\Memcache\\Fac...')
#11 /mnt/Pool1/nextcloud/www/lib/private/Server.php(1699): OC\ServerContainer->query('OC\\Memcache\\Fac...')
#12 /mnt/Pool1/nextcloud/www/lib/private/Server.php(853): OC\Server->getMemCacheFactory()
#13 /mnt/Pool1/nextcloud/www/3rdparty/pimple/pimple/src/Pimple/Container.php(118): OC\Server->OC\{closure}(Object(OC\Server))
#14 /mnt/Pool1/nextcloud/www/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet('OC\\App\\AppManag...')
#15 /mnt/Pool1/nextcloud/www/lib/private/AppFramework/Utility/SimpleContainer.php(163): OC\ServerContainer->query('OC\\App\\AppManag...')
#16 /mnt/Pool1/nextcloud/www/3rdparty/pimple/pimple/src/Pimple/Container.php(114): OC\AppFramework\Utility\SimpleContainer->OC\AppFramework\Utility\{closure}(Object(OC\Server))
#17 /mnt/Pool1/nextcloud/www/lib/private/ServerContainer.php(124): Pimple\Container->offsetGet('OCP\\App\\IAppMan...')
#18 /mnt/Pool1/nextcloud/www/lib/private/Server.php(1889): OC\ServerContainer->query('OCP\\App\\IAppMan...')
#19 /mnt/Pool1/nextcloud/www/lib/private/legacy/OC_App.php(347): OC\Server->getAppManager()
#20 /mnt/Pool1/nextcloud/www/lib/private/legacy/OC_App.php(114): OC_App::getEnabledApps()
#21 /mnt/Pool1/nextcloud/www/lib/base.php(647): OC_App::loadApps(Array)
#22 /mnt/Pool1/nextcloud/www/lib/base.php(1090): OC::init()
#23 /mnt/Pool1/nextcloud/www/console.php(49): require_once('/mnt/Pool1/next...')
#24 /mnt/Pool1/nextcloud/www/occ(11): require_once('/mnt/Pool1/next...')

andkaz73
NewUser
NewUser
Posts: 5
Joined: 22 Jul 2020 03:13
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#9

Post by andkaz73 »

And another program, which use Mariadb, started in jail, also dont work

User avatar
sea1150
experienced User
experienced User
Posts: 105
Joined: 23 Jun 2012 07:01
Location: South Urals
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#10

Post by sea1150 »

andkaz73 wrote:
22 Jul 2020 15:18
And another program, which use Mariadb, started in jail, also dont work
try use bind_address=0.0.0.0 in my.cnf and read man https://mariadb.com/kb/en/mariadb/confi ... with-mycnf
or use mysql_secure_installation if it was a clean install or if you are using a clean database
i don't know how it works OneButtonInstaller and jail with MariaDB
XigmaNAS 11.4.0.4 x64-embedded on - ASUS P8H61-I LX R2.0-GLAN, i5-3570 CPU @ 3.40GHz, 16GB Memory Kit, PCIEx2 Marvell 88SE9230 AHCI 4xSATA controller, HDD: 2x2Tb-UFS, 4x1Tb-RaidZ & 1xSSD L2ARC.
XigmaNAS 11.4.0.4 x64-embedded in - VM on ESXi 6.7, 16GB ECC RAM, LSI SAS2008 IT passtrough mode on HP Proliant DL180G6 2xL5640, 112GB RAM, HDD: 12Bay
- and more... My work and all versions

andkaz73
NewUser
NewUser
Posts: 5
Joined: 22 Jul 2020 03:13
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#11

Post by andkaz73 »

sea1150 wrote:
22 Jul 2020 16:18

try use bind_address=0.0.0.0 in my.cnf and read man https://mariadb.com/kb/en/mariadb/confi ... with-mycnf

i don't know how it works OneButtonInstaller and jail with MariaDB
Of course bind address always is 0.0.0.0 and before this update, on Xigmanas 12.1.0.4.7664, all programs works fine. And, of course, any program works with the database in the same way, connecting to database and performs SQL requests. Now I downgrade to 7664 version and in future start upgrade after one week minimum after release.

User avatar
sea1150
experienced User
experienced User
Posts: 105
Joined: 23 Jun 2012 07:01
Location: South Urals
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#12

Post by sea1150 »

just transferred my working databases to a test server with XigmaNAS 12.1.0.4.7683 and mariyadb 10.5 and got the result - everything works and all applications connect to the database, local and remote. Maybe I'm doing something wrong !?
XigmaNAS 11.4.0.4 x64-embedded on - ASUS P8H61-I LX R2.0-GLAN, i5-3570 CPU @ 3.40GHz, 16GB Memory Kit, PCIEx2 Marvell 88SE9230 AHCI 4xSATA controller, HDD: 2x2Tb-UFS, 4x1Tb-RaidZ & 1xSSD L2ARC.
XigmaNAS 11.4.0.4 x64-embedded in - VM on ESXi 6.7, 16GB ECC RAM, LSI SAS2008 IT passtrough mode on HP Proliant DL180G6 2xL5640, 112GB RAM, HDD: 12Bay
- and more... My work and all versions

andkaz73
NewUser
NewUser
Posts: 5
Joined: 22 Jul 2020 03:13
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#13

Post by andkaz73 »

sea1150 wrote:
22 Jul 2020 16:57
just transferred my working databases to a test server with XigmaNAS 12.1.0.4.7683 and mariyadb 10.5 and got the result - everything works and all applications connect to the database, local and remote. Maybe I'm doing something wrong !?
Glad that everything works for you. Sorry, NAS is previous version now, no more experiments

User avatar
sea1150
experienced User
experienced User
Posts: 105
Joined: 23 Jun 2012 07:01
Location: South Urals
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#14

Post by sea1150 »

Maybe you need to accommodate changes in the new MariaDB version, do mysql_upgrade or something else. But for sure with MariaDB in this assembly everything is in order, except for the start, but this is more likely for the FreeBSD 12.1 version itself. This problem shows up from time to time from version to version, and I think that sooner or later it will be fixed. For example: https://bugs.freebsd.org/bugzilla/show_ ... =225657#c2
It also makes no sense for developers to stand still, MariaDB versions lower than 10.4 will soon be removed from ports, so the older the release is used, the faster it will be worked out.

PS: I'll add, I am not using 12.1 yet. For me they work unstably in another. For me, for example, the FreeBSD 12.1 system itself behaves strangely on ESXi under heavy load on the disk subsystem with LSI SAS2008 in passthrough mode simply reboots and everything is not fixing signs in the logs. 11 versions work long and stable
XigmaNAS 11.4.0.4 x64-embedded on - ASUS P8H61-I LX R2.0-GLAN, i5-3570 CPU @ 3.40GHz, 16GB Memory Kit, PCIEx2 Marvell 88SE9230 AHCI 4xSATA controller, HDD: 2x2Tb-UFS, 4x1Tb-RaidZ & 1xSSD L2ARC.
XigmaNAS 11.4.0.4 x64-embedded in - VM on ESXi 6.7, 16GB ECC RAM, LSI SAS2008 IT passtrough mode on HP Proliant DL180G6 2xL5640, 112GB RAM, HDD: 12Bay
- and more... My work and all versions

Victek
Starter
Starter
Posts: 51
Joined: 01 Jul 2012 20:23
Location: Barcelona - Spain
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#15

Post by Victek »

Devs, thanks for the update with Transmission fix. Nextcloud works also. Good job!
Build: XigmaNAS 12.1.0.4 (rev. 7743) amd64-embedded on Sandisk 64GB SSD. Supermicro X10SLL-F-Bios v3.2- Intel(R) Xeon(R) CPU E3-1231 v3 @ 3.40GHz - 32GB Crucial DDR3 ECC (CT102472BD160B), LSI 2008-8i IT mode, Storage: 3x Seagate Ironwolf 10TB. Raidz. Enclosure; Fractal Design R6.

User avatar
jerryone
Starter
Starter
Posts: 60
Joined: 22 Sep 2017 21:45
Location: Timisoara
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#16

Post by jerryone »

Back to latest update. For me is working fine for just a use. Thanks dev
Dell T610 Xeon x5650 x2 , 192 GB DELL ECC, HBA 9211-8i LSI x2 , 7xHGST-4TB, 2xSamsung 1TB, , 1xKingston 128GB-SSD boot sys
CIFS/SMB, Syncthing, DLNA/UPnP MiniDLNA, BitTorrent, Plex Media Server

RockBomber
NewUser
NewUser
Posts: 1
Joined: 16 Nov 2019 09:46
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#17

Post by RockBomber »

sea1150 wrote:
22 Jul 2020 12:22
Temporary solution:
add via web interface a variable mysql_limits = "" to rc.conf and restart service MariaDB
Thank You! It's work for me. MariaDB just started, SeaFile in the jail can connect to MariaDB and works fine

igor_franz
NewUser
NewUser
Posts: 9
Joined: 19 Oct 2019 17:56
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#18

Post by igor_franz »

Virtualbox ceased to work after update!

I'm getting errors when i try to connect to /phpvirtaulbox/index.html:
"Could not connect to host (http://127.0.0.1:18083/)"
Details:

Code: Select all

Exception Object
(
    [message:protected] => Could not connect to host (http://127.0.0.1:18083/)
    [string:Exception:private] => 
    [code:protected] => 64
    [file:protected] => /usr/local/www/phpvirtualbox/endpoints/lib/vboxconnector.php
    [line:protected] => 220
    [trace:Exception:private] => Array
        (
            [0] => Array
                (
                    [file] => /usr/local/www/phpvirtualbox/endpoints/lib/vboxconnector.php
                    [line] => 3374
                    [function] => connect
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                        )

                )

            [1] => Array
                (
                    [file] => /usr/local/www/phpvirtualbox/endpoints/lib/vboxconnector.php
                    [line] => 951
                    [function] => remote_hostGetDetails
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                            [0] => 
                        )

                )

            [2] => Array
                (
                    [file] => /usr/local/www/phpvirtualbox/endpoints/api.php
                    [line] => 316
                    [function] => __call
                    [class] => vboxconnector
                    [type] => ->
                    [args] => Array
                        (
                            [0] => hostGetDetails
                            [1] => Array
                                (
                                    [0] => 
                                    [1] => Array
                                        (
                                            [0] => Array
                                                (
                                                    [data] => Array
                                                        (
                                                            [responseData] => Array
                                                                (
                                                                )

                                                        )

                                                    [errors] => Array
                                                        (
                                                        )

                                                    [persist] => Array
                                                        (
                                                        )

                                                    [messages] => Array
                                                        (
                                                        )

                                                )

                                        )

                                )

                        )

                )

        )

    [previous:Exception:private] => 
)


Location:http://127.0.0.1:18083/
My virtual machines didn't start too...
What can i do to get access again?

edit: from vboxwebsrv i get:
00:00:38.309544 SQPmp Request 14 on socket 9 queued for processing (1 items on Q)
00:00:38.309554 SQW01 Processing connection from IP=127.0.0.1 socket=9 (1 out of 2 threads idle)
00:00:38.309739 SQW01 Access for user 'vboxusers' denied

second edit:
tried to start the relevant VMs manually, which failed with "unknown/wrong uuid"
after digging and poking around, i saw that with vboxmanage list vms none of my machines were present.
I added them manually via the registervm and then i could start them again.
So this is fine again. Only via the webif there is no connect...
Partially solved my problem...
rootonzfs: xigmanas 12.1-release full install

st1969
NewUser
NewUser
Posts: 11
Joined: 15 Mar 2020 13:49
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#19

Post by st1969 »

sea1150 wrote:
22 Jul 2020 16:18
i don't know how it works OneButtonInstaller and jail with MariaDB
works with OBI an Nextcloud...thanks

User avatar
rwps
Starter
Starter
Posts: 34
Joined: 19 Sep 2012 13:55
Location: Australia
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#20

Post by rwps »

I've gone back to using embedded (I realise my NAS, should be just that a NAS, so no need for the full install).
And I was impressed with how straight forward the move to the new release was.
coming from 12.0... I like the cleaner interface and feel.
Pool loaded and Shares (SMB) working fine.
many thanks!
Version: 12.1.0.4 - Ingva (revision 7683), Platform: x64-Embedded on Xeon E3-1265L V2, System: HP ProLiant MicroServer Gen8, Ram: 8gb ECC,
Pool 1: 2x 12tb, mirror . Pool 2: 1x4tb 1x3tb, one stripe as a backup by Rsync of Pool 1
Donate to XigmaNAS :) I do, & it's a tiny price to pay to support the good work that provides the rock of my home network

jamaroney
Advanced User
Advanced User
Posts: 275
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#21

Post by jamaroney »

I don't understand why Transmission was downgraded to 2.92 when the simple fix I recommended in the thread for release 7664 (utlizing https://github.com/54mv39/web) could easily have been merged into this new release.

See separate thread https://xigmanas.com/forums/viewtopic.p ... 791#p94791

The fix is also an improvement to Transmission's standard WebGUI, and should be a regular part of XNAS releases

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5183
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#22

Post by raulfg3 »

jamaroney wrote:
01 Aug 2020 14:05
I don't understand why Transmission was downgraded to 2.92 when the simple fix I recommended in the thread for release 7664 (utlizing https://github.com/54mv39/web) could easily have been merged into this new release.

See separate thread https://xigmanas.com/forums/viewtopic.p ... 791#p94791

The fix is also an improvement to Transmission's standard WebGUI, and should be a regular part of XNAS releases
+1, I agree,


perhaps developers can add this patch and tested a new beta to be sure that works for all ?.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

vinceducat
Starter
Starter
Posts: 22
Joined: 14 Oct 2013 19:00
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#23

Post by vinceducat »

sorry i rewrite here i think i haven't validate the post yesterday but today il realise my post was replace in newbie section ...

Since last update Nextcloud install from OBI dont work anymore

how can il solve this pb

the message is :

Internal Server Error

The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.

Nextcloud 17.0.1
PHP Version 7.4.8
OBI 0.4.1
NextOwnCloud 0.3.5
12.1.0.4 - Ingva (revision 7683) FreeBSD 12.1-RELEASE-p7 #0 r363366M: Mon Jul 20 16:59:25 CEST 2020 + OBI
x64-embedded sur AMD Athlon(tm) 64 X2 Dual Core Processor 4200+

User avatar
Snufkin
Advanced User
Advanced User
Posts: 345
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#24

Post by Snufkin »

vinceducat wrote:
02 Aug 2020 12:42
Nextcloud 17.0.1
PHP Version 7.4.8
Reason: Nextcloud 17 is not compatible with PHP 7.4.
Solution: Downgrade XNAS to PHP 7.3 (your last working XNAS version), upgrade NC to 18 branch, then upgrade XNAS
XNAS 11.4.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2
ZFS 2 x HGST HDN726040ALE614, L2ARC PLEXTOR PX-128M5S

vinceducat
Starter
Starter
Posts: 22
Joined: 14 Oct 2013 19:00
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#25

Post by vinceducat »

Snufkin wrote:
02 Aug 2020 16:56
vinceducat wrote:
02 Aug 2020 12:42
Nextcloud 17.0.1
PHP Version 7.4.8
Reason: Nextcloud 17 is not compatible with PHP 7.4.
Solution: Downgrade XNAS to PHP 7.3 (your last working XNAS version), upgrade NC to 18 branch, then upgrade XNAS
thanks ;-)

so i have no access to the web inteface of Nextcloud is it possible to upgrade Nextcloud manually ? in command line even if it is install trought OBI ?

how it is possible to downgrade XNAS to php 7.3 ??
12.1.0.4 - Ingva (revision 7683) FreeBSD 12.1-RELEASE-p7 #0 r363366M: Mon Jul 20 16:59:25 CEST 2020 + OBI
x64-embedded sur AMD Athlon(tm) 64 X2 Dual Core Processor 4200+

User avatar
Snufkin
Advanced User
Advanced User
Posts: 345
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#26

Post by Snufkin »

vinceducat wrote:
02 Aug 2020 19:08
so i have no access to the web inteface of Nextcloud is it possible to upgrade Nextcloud manually?
in command line even if it is install trought OBI ?
Look at Nextcloud Administration Manual Maintenance » Upgrade manually
vinceducat wrote:
02 Aug 2020 19:08
how it is possible to downgrade XNAS to php 7.3 ??
Just like complete XNAS upgrade, but this time take previous XNAS image from your backup and proceed as usual.
XNAS 11.4.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2
ZFS 2 x HGST HDN726040ALE614, L2ARC PLEXTOR PX-128M5S

karlandtanya
Starter
Starter
Posts: 51
Joined: 23 Jan 2014 15:31
Location: nelson twp, OH, USA
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#27

Post by karlandtanya »

sea1150 wrote:
22 Jul 2020 12:22
andkaz73 wrote:
22 Jul 2020 03:17
Mariadb after update dont work. When trying to restart in webGUI:
"Error: The changes could not be applied (Error Code 1)."
How to repair Mariadb?
Temporary solution:
add via web interface a variable mysql_limits = "" to rc.conf and restart service MariaDB
Tried that one; still get the same error but reverting to 7664 still works.

oli_r42
NewUser
NewUser
Posts: 6
Joined: 13 Jul 2018 23:00
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#28

Post by oli_r42 »

Upgraded via the webgui 12.1.0.4.7452 -> 12.1.0.4.7683
All working well :D
XigmaNAS 12.1.0.4 embedded
HP Proliant Gen8, Celeron CPU G1610T, 4 GB ECC, 2x 4TB WD Red in ZFS Mirror
Services: SMB, AFP, weekly scrub, daily snapshots with 1 month life.

ali_dzi
Starter
Starter
Posts: 25
Joined: 09 Oct 2013 16:17
Status: Offline

Re: XigmaNAS 12.1.0.4.7683 released (FreeBSD 12.1-RELEASE-P7)

#29

Post by ali_dzi »

Embeded upgrade went fine on both my machines (main & backup).
The only problem was that Putty (via SSH service)didn't want to
connect, even I have deleted keys from registry.

The solution was to upgrade to the newest (0.74) version of Putty.

Post Reply

Return to “Release Builds”