*New 12.1 series Release:
2020-09-13: XigmaNAS 12.1.0.4.7743 - released

*New 11.4 series Release:
2020-09-12: XigmaNAS 11.4.0.4.7741 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

Posts only related to Release Builds, all others will be removed!
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
zoon01
Developer
Developer
Posts: 811
Joined: 20 Jun 2012 21:06
Location: Netherlands
Contact:
Status: Offline

XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#1

Post by zoon01 »

We are pleased to announce the release of XigmaNAS version 11.4.0.4.7741- Accadia.
This is a new stable release for the 11.x branche.
.

First BACKUP your current Configuration!
READ readme_11.3.txt please before you do anything!

Download build 11.4.0.4.7741

Changes after release 11.3.0.4.7718
===================================
- Upgrade to FreeBSD 11.4-RELEASE-P3.
- WebGUI code & framework improvements.
- Upgrade nano to 5.2.
- Upgrade msmtp to 1.8.12.
- Upgrade iperf3 to 3.9.
- Upgrade syncthing to 1.9.0.
- Upgrade php to 7.4.10.
- Upgrade transmission to 3.00.

Regards,
Team XigmaNAS


Basic Note:
- Make a new backup of your system configuration and store this on safe location, the system config.xml could be upgraded!
- Clear your browser's cache to avoid display issues after upgrade when coming from older release.
System specs: XigmaNAS 11.2.0.4 -embedded on Samsung 860 EVO 256GB and Supermicro X10SL7-F w / Bios v3.2, IPMI v.03.86 / CPU E3-1241 v3 @ 3.50GHz - 32GB Crucial DDR3L 1600mhz ECC 1.35v , LSI 2308 on PH20.00.07.00 IT mode, Storage: 5x Western Digital Red (WD30EFRX) raidz

Development system is same system in virtualbox.

provels
experienced User
experienced User
Posts: 110
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#2

Post by provels »

Worked fine on my antique. Thanks to the devs!
Peder
XigmaNAS 11.4.0.4.7741 Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

User avatar
apollo567
Site Admin
Site Admin
Posts: 760
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#3

Post by apollo567 »

Still have this strange behaviour of the Monitoring Page under Firefox 80.01, despite deleting Webpage Cache. Edge is still fine.
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

User avatar
Snufkin
Advanced User
Advanced User
Posts: 345
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#4

Post by Snufkin »

apollo567 wrote:
13 Sep 2020 15:36
Still have this strange behaviour of the Monitoring Page under Firefox 80.01.
Jumped to 7741 (from 7633) without a hitch.
Monitoring page looks fine in Firefox 80.0.1 browser.
XNAS 11.4.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2
ZFS 2 x HGST HDN726040ALE614, L2ARC PLEXTOR PX-128M5S

User avatar
apollo567
Site Admin
Site Admin
Posts: 760
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#5

Post by apollo567 »

Snufkin wrote:
13 Sep 2020 17:31
apollo567 wrote:
13 Sep 2020 15:36
Still have this strange behaviour of the Monitoring Page under Firefox 80.01.
Jumped to 7741 (from 7633) without a hitch.
Monitoring page looks fine in Firefox 80.0.1 browser.
Thanks for checking, I am still searching for the Error.
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

User avatar
Snufkin
Advanced User
Advanced User
Posts: 345
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#6

Post by Snufkin »

apollo567 wrote:
13 Sep 2020 17:45
Snufkin wrote:
13 Sep 2020 17:31
apollo567 wrote:
13 Sep 2020 15:36
Still have this strange behaviour of the Monitoring Page under Firefox 80.01.
Jumped to 7741 (from 7633) without a hitch.
Monitoring page looks fine in Firefox 80.0.1 browser.
Thanks for checking, I am still searching for the Error.
I'd check Firefox extensions and add-ons.
XNAS 11.4.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2
ZFS 2 x HGST HDN726040ALE614, L2ARC PLEXTOR PX-128M5S

provels
experienced User
experienced User
Posts: 110
Joined: 05 Jan 2014 15:31
Location: Chicago, IL, USA
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#7

Post by provels »

apollo567 wrote:
13 Sep 2020 15:36
Still have this strange behaviour of the Monitoring Page under Firefox 80.01, despite deleting Webpage Cache. Edge is still fine.
Fine for me. Think maybe I'd try reinstalling FF or reverting to FF defaults.
Peder
XigmaNAS 11.4.0.4.7741 Embedded / MiniDLNA and CIFS/SMB only
HP ProLiant DL320 G3 / P4 660 3.6GHz HT / 4GB ECC / 2 x 3TB WD Red, ZFS Mirror / APC Back-UPS BR 800

Impulse1
Starter
Starter
Posts: 36
Joined: 06 Jul 2012 06:01
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#8

Post by Impulse1 »

I get the following error after upgrading and trying to connect to the webgui. I seem to be able to connect via ssh without issue though. Using Safari browser, and cleared my cache.

Code: Select all

Fatal error: Cannot redeclare get_vip_status() (previously declared in /usr/local/www/index.php:75) in /etc/inc/system.inc on line 892
Minor inconvenience too, but with the past couple versions, I've needed to connect using incognito mode on Safari. I can't proceed past the warning page about connecting to an untrusted https: website if I'm not in incognito. Could be a bug with Safari and not XigmaNAS?

User avatar
ms49434
Developer
Developer
Posts: 995
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#9

Post by ms49434 »

Impulse1 wrote:
14 Sep 2020 00:42
I get the following error after upgrading and trying to connect to the webgui. I seem to be able to connect via ssh without issue though. Using Safari browser, and cleared my cache.

Code: Select all

Fatal error: Cannot redeclare get_vip_status() (previously declared in /usr/local/www/index.php:75) in /etc/inc/system.inc on line 892
Minor inconvenience too, but with the past couple versions, I've needed to connect using incognito mode on Safari. I can't proceed past the warning page about connecting to an untrusted https: website if I'm not in incognito. Could be a bug with Safari and not XigmaNAS?
Please check your command scripts for Extended-GUI startup scripts. Extended-GUI hasn't been updated for a while and replaces index.php with an outdated version which causes the error message.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Impulse1
Starter
Starter
Posts: 36
Joined: 06 Jul 2012 06:01
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#10

Post by Impulse1 »

ms49434 wrote:
14 Sep 2020 01:10
Please check your command scripts for Extended-GUI startup scripts. Extended-GUI hasn't been updated for a while and replaces index.php with an outdated version which causes the error message.
Pardon my ignorance, but how would I do that? where are the startup scripts stored, and what would I be looking for that is not correct?

Thanks for the help.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5188
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#11

Post by raulfg3 »

Impulse1 wrote:
14 Sep 2020 06:37
ms49434 wrote:
14 Sep 2020 01:10
Please check your command scripts for Extended-GUI startup scripts. Extended-GUI hasn't been updated for a while and replaces index.php with an outdated version which causes the error message.
Pardon my ignorance, but how would I do that? where are the startup scripts stored, and what would I be looking for that is not correct?

Thanks for the help.
in System > Advanced > Command Scripts

disable extendedGUI and restart NAS to avoid load of extension
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Impulse1
Starter
Starter
Posts: 36
Joined: 06 Jul 2012 06:01
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#12

Post by Impulse1 »

Thanks raulfg3. didn't realise at first I could still access the other webgui pages..

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5188
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: XigmaNAS 11.4.0.4.7741 released (FreeBSD 11.4-RELEASE-P3)

#13

Post by raulfg3 »

Impulse1 wrote:
15 Sep 2020 05:36
Thanks raulfg3. didn't realise at first I could still access the other webgui pages..
yes, works, go to yourNASIP/system_rc.php instead of yournasip/index.php that is the web page that ExtendedGUI replaces and fails.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

Post Reply

Return to “Release Builds”