*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

theBrig - Jail has no networking?

Jails with XigmaNAS
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
drnicolas
Advanced User
Advanced User
Posts: 182
Joined: 15 Aug 2013 14:03
Location: Wiesbaden, Germany
Status: Offline

theBrig - Jail has no networking?

#1

Post by drnicolas » 09 Apr 2019 22:43

I managed to setup a jail in thebrig. At least it looks like working.

I can connect with "jexec 3 csh".
But inside , "ping " fails with something like "ping:ssend socket: OPeration not permitted."

I also cannot ping any other IP-Address.

What am I doing wrong ?
HP Proliant N54L - Bios Mod -16GB non-ECC-RAM - ZFS RAIDZ1 (3x3TB) - 1VM running XigmaNAS 11.2.0.4.6026

cookiemonster
Advanced User
Advanced User
Posts: 164
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: theBrig - Jail has no networking?

#2

Post by cookiemonster » 12 Apr 2019 00:51

add the allow.raw_sockets option in the "in jail allow" field, save and restart. Should fix it.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS on Supermicro X8DT3. zroot on mirrorred pair of CRUCIAL_CT64M225. Memory: 24GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 Tb in raidZ1, 1 x 3 Tb SAS drive as single stripe.
Spare1: HP DL580 G5; 128 GB ECC RAM; 4 CPU; 8 x 500 GB disks on H210i
Spare2: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Spare3: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Post Reply

Return to “Jails”