*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released

*New 11.3 series Release:
2020-04-16: XigmaNAS 11.3.0.4.7538 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Can't handle with LACP(Solved)

Link Aggregation and Fail-over.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
hellofaduck
NewUser
NewUser
Posts: 8
Joined: 29 Jun 2019 18:11
Status: Offline

Can't handle with LACP(Solved)

#1

Post by hellofaduck »

Trying to create LACP with 2 Gbit Intel NICs and Cisco SG200-18.
When i creating LACP on Xigmanas and reboots, i see 2 strange things:
1 - on xigmanas ifconfig not shows lagg0 interface, but i can see it in web gui
2 - on cisco side i see that 1 port in this LAGG group is active and 1 passive, but i dont want failover, i want a active-active mode for load balancing(and i choose a LACP mode when creating a LAGG group)(but i think i misinterper a cisco terms..)
And another question: How to use VLAN's on lagg interface or i need a separate NIC for web gui? On VLAN page i can's choose lagg0 as a network interface, but on LAN page i can, it seems very strange for me
Last edited by hellofaduck on 30 Jun 2019 14:16, edited 1 time in total.
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 8GB ECC RAM, Atom 2C4T 2.2GHz -> 2 WD RED 3TB ZFS Mirror for storage | 2 Intel 3210 480GB SSD ZFS Mirror for Proxmox VM cluster storage
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 4GB ECC RAM, Atom 2C4T 2.2GHz | 2 WD Black 500GB for Backups

igr4free
experienced User
experienced User
Posts: 94
Joined: 19 Dec 2016 15:12
Status: Offline

Re: Can't handle with LACP

#2

Post by igr4free »

Hi,
After create a lagg interface, do you asign it on Administration interface?

On Cisco, you need to specify the lacp protocol and the mode of channelgroup in active on all ports.

On vlan option, you can create it and asign on the new lagg interface. On cisco switch you need config this as trunk mode, and need to specify the vlans that you create it on xigmanas. The configuration of vlans in the cisco must be created in the portchannel port. in the individual interfaces, only the channelgroup they belong to must be indicated. When you configure the portchannel interface, it will configure the physical interfaces
XigmaNAS 12.1.0.4.7542 released (FreeBSD 12.1-RELEASE-P3) RootOnZFS (mirror disk)
HPE Proliant Microserver Gen8 / CPU: E3-1265L V2 @ 2.50GHz / Mem: 16GB DDR3 ECC / Storage: IBM ServerRaid m1015, 4x 1TB HITACHI RaidZ1, 2x 1TB HITACHI Stripe, OS Disk: 2x 80GB INTEL SSD

hellofaduck
NewUser
NewUser
Posts: 8
Joined: 29 Jun 2019 18:11
Status: Offline

Re: Can't handle with LACP

#3

Post by hellofaduck »

Thank you for reply!
No,i dont assign a administrative(webgui) interface on lagg group, should i? for me it's very strange that i don't see this interface when i run ifconfig command. and i repeat, i can't(!) create a vlans on xigmanas on lagg interface, i simply can't choose thise interface in VLAN menu to create a vlan.

P.S. You think if i assign this lagg interface as my LAN interface i can manage vlans on it?
Last edited by hellofaduck on 22 Feb 2020 17:21, edited 1 time in total.
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 8GB ECC RAM, Atom 2C4T 2.2GHz -> 2 WD RED 3TB ZFS Mirror for storage | 2 Intel 3210 480GB SSD ZFS Mirror for Proxmox VM cluster storage
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 4GB ECC RAM, Atom 2C4T 2.2GHz | 2 WD Black 500GB for Backups

hellofaduck
NewUser
NewUser
Posts: 8
Joined: 29 Jun 2019 18:11
Status: Offline

Re: Can't handle with LACP

#4

Post by hellofaduck »

Ok, i solve this wierd issue!
The key is to assign lagg0 to LAN interface, after that it show in ifconfig, VLAN settings is accessible to that interface and on CISCO side i see that all ports are Active!

UPDATE: found another NORMAL solution for this problem, after setting up a LAGG in System > Advanced > Command Scripts add a script at Post-Init with command "ifconfig lagg0 up"
then all vlans on this LAGG working OK
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 8GB ECC RAM, Atom 2C4T 2.2GHz -> 2 WD RED 3TB ZFS Mirror for storage | 2 Intel 3210 480GB SSD ZFS Mirror for Proxmox VM cluster storage
XigmaNAS 2.1.0.4 - Supermicro X9SBAA-F - 4GB ECC RAM, Atom 2C4T 2.2GHz | 2 WD Black 500GB for Backups

Post Reply

Return to “LAGG”