Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

Vlan and web admin control panel

Virtual Local Area Network.
Post Reply
skywalker
NewUser
NewUser
Posts: 2
Joined: 17 Dec 2012 19:25
Status: Offline

Vlan and web admin control panel

#1

Post by skywalker » 02 Nov 2014 00:43

Hello,

i'm having problems accessing the web admin control panel, from the vlan side. (Cifs and AFP accesses are working from both lan side and vlan side, torrent web admin is working from lan and vlan.)
web admin for nas4free is working only on lan side.
Do i need to change settings somewhere to have it working on both sides??

thanks
Giulio

skywalker
NewUser
NewUser
Posts: 2
Joined: 17 Dec 2012 19:25
Status: Offline

Re: Vlan and web admin control panel

#2

Post by skywalker » 21 Nov 2014 17:52

Best and fastest way to do it is by yourself.

I'll publish here what i did to make sure that some one that encounters the same troubles with gui not showing on vlans can manage to fix it and UNDERSTAND what has been done.

/var/etc contains the lighttpd.conf configuration file. inside of it it's contained a rule to bind the server to the ip address that has been configured in the main network card from the nas web gui
If you have vlan's obviously you can not access web gui from the vlan side. If oyu have embedded setup, and you try to change the config file and remove the server.bind setting, after reboot everything is back to original, because the files are created on boot from the main config.
I tried then to add to the config file, using advanced--->command scripts another server.bind option hoping that it would overwrite the previous setting.
command used was:

Code: Select all

echo 'server.bind = "192.168.3.78"' >> /var/etc/lighttpd.conf
this gave a error command, because you cannot have 2 settings that are the same.
Only way to do it is by changing at every boot the config file from what nas4free makes to what suits you.
After some time i came up with this:

Code: Select all

sed '/server.bind/s/192.168.3.78/0.0.0.0/g' /var/etc/lighttpd.conf
This changes the file to what i needed and webgui was supposed to appear...but it did not because the settings in command scripts are modified with the above command after they get loaded.
So you need a way to modify the file, and restart the service.
This is what i came up with:

Code: Select all

sed -i.bak '/server.bind/s/192.168.3.78/0.0.0.0/g' /var/etc/lighttpd.conf && /etc/rc.d/lighttpd stop && /usr/local/sbin/lighttpd -f /var/etc/lighttpd.conf
First part modifies the files, second part stops lighttpd and third part restarts it, without the original command wich restores the file to the original setting.
(if you try /etc/rc.d/lighttpd restart it will stop working again because all the changes are removed on service restart)
In this way, nas4free can be controlled from any vlan, any network card and any lagg that is connected to.
Best regards.
Giulio

Post Reply

Return to “VLAN”