*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Changing MTU setting in GUI stops IP address being set.

Everything to improve your speed, LAGG, VLAN, VPN, Port Forwarding, DNS, Gateway
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
NeilP
Advanced User
Advanced User
Posts: 220
Joined: 15 Jul 2012 11:45
Location: Jersey, Channel Islands, Europe
Status: Offline

Changing MTU setting in GUI stops IP address being set.

#1

Post by NeilP » 19 Mar 2019 12:56

This is more query and a bug ? I don't know.. I am happy with how my NAS box is working now, but this is just more to ask/ point out that this might be an issue


I did discuss this with raulfg3 on another post here, but under a different thread topic. Just thought I'd give it its own thread. Not for my need but merely for interest, if anyone else had this or it fixed a bug.

I have not changed any hardware.I just pulled the boot HDD, and put in another identical IDE 40gb WD drive and installed the latest XigmaNAS 11.2.0.4 - Omnius (revision 6536)

exact same hardware, as Shigwire and this problem did not occur. Upgrade to XigmasNAS and MTU 9000 stops network access.

If I boot in Shigwire and WebGUI and check Network/LAN Management I can set MTU 9000
Ip address is set static 192.168.2.2
All is good

if I check
Network/LAN management when booted to XigmaNAS
I see the MTU box is blank
if I set 9000, on reboot...although IP address is set as static, I get no IP address.

See photo below.

If I set 1500, all is good.

With Shigwire the system accepted and worked with MTU 9000 jumbo packets with XigmasNAS it does not.

Just intrigued to know why with same hardware it fails with XigmasNAS

Image

User avatar
ms49434
Developer
Developer
Posts: 751
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#2

Post by ms49434 » 19 Mar 2019 16:49

It's very easy to bring down an interface by setting an invalid or unsupported MTU value.
Other settings, i.e. kern.ipc.nmbjumbo9/kern.ipc.nmbjumbo16, might impact the support of higher MTU's as well.
Other network components, i.e. a switch, must support jumbo frames as well.
You should start to find out the maximum supported MTU of your current system by manually running

Code: Select all

ifconfig nfe0 mtu value
The value could be anything between 1500 and 9000 (/16k), a binary approach will require a maximum of 13 calls to ifconfig to get the maximum supported MTU.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

NeilP
Advanced User
Advanced User
Posts: 220
Joined: 15 Jul 2012 11:45
Location: Jersey, Channel Islands, Europe
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#3

Post by NeilP » 19 Mar 2019 18:45

OK,
Here is what it gives

Code: Select all

Last login: Tue Mar 19 17:41:13 2019
Welcome to XigmaNAS!
backupcifs: ~# ifconfig nfe0 mtu value
ifconfig: ioctl SIOCSIFMTU (set mtu): Invalid argument
backupcifs: ~# 

Code: Select all

backupcifs: ~# ifconfig| grep MTU
	options=80008<VLAN_MTU,LINKSTATE>
backupcifs: ~# 

My query was that it worked wench setting an MTU value with the same hardware, with Shigwire, in that 9000 was set and saved..

Screen Shot 2019-03-19 at 17.45.56.jpg
You do not have the required permissions to view the files attached to this post.

NeilP
Advanced User
Advanced User
Posts: 220
Joined: 15 Jul 2012 11:45
Location: Jersey, Channel Islands, Europe
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#4

Post by NeilP » 19 Mar 2019 18:50

Been googling around other ifconfig commands to try

Code: Select all

backupcifs: ~# ip 192.168.2.1 | grep mtu
ip: Command not found.
backupcifs: ~# /sbin/ifconfig
nfe0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
	options=80008<VLAN_MTU,LINKSTATE>
	ether 00:16:e6:44:40:ec
	hwaddr 00:16:e6:44:40:ec
	inet 192.168.2.2 netmask 0xffffff00 broadcast 192.168.2.255 
	inet6 fe80::216:e6ff:fe44:40ec%nfe0 prefixlen 64 scopeid 0x1 
	nd6 options=123<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL,NO_DAD>
	media: Ethernet autoselect (1000baseT <full-duplex>)
	status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> metric 0 mtu 16384
	options=600003<RXCSUM,TXCSUM,RXCSUM_IPV6,TXCSUM_IPV6>
	inet6 ::1 prefixlen 128 
	inet6 fe80::1%lo0 prefixlen 64 scopeid 0x2 
	inet 127.0.0.1 netmask 0xff000000 
	nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
	groups: lo 
backupcifs: ~# 

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4948
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#5

Post by raulfg3 » 19 Mar 2019 20:08

Last login: Tue Mar 19 17:41:13 2019
Welcome to XigmaNAS!
backupcifs: ~# ifconfig nfe0 mtu value
ifconfig: ioctl SIOCSIFMTU (set mtu): Invalid argument
backupcifs: ~#
bad, very bad.

ms49434 suggest that you try several times until find optimal MTU Value.

like this:

Code: Select all

ifconfig nfe0 mtu 8000
then try

Code: Select all

ifconfig nfe0 mtu 6000
and so on , to find the max value that your NIC support on BSD 12 (Yes: I know that suppoprt 9000 on BSD 11)


PD:there's nothing that XigmaNAS developers can do if do not work with MTU=9000 is a BSD Problem or a driver problem
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

NeilP
Advanced User
Advanced User
Posts: 220
Joined: 15 Jul 2012 11:45
Location: Jersey, Channel Islands, Europe
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#6

Post by NeilP » 19 Mar 2019 21:30

Ah OK, I get you now!

doh
I thought the command was probing the system to find the 'Value'

I have tried and ..anything above 1500 gives the Invalid Argument response.

But since the hardware is the same..it does not explain why it seemed to work and set 9000 in Shigwire.
So maybe this is not an error in XigmasNAS, but in fact an error in Shigwire, that showed 9000 being set when in fact it was not supported.

I will boot the box tomorrow back to Shigwire and try to set different MTU from the CLI again.

User avatar
ms49434
Developer
Developer
Posts: 751
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#7

Post by ms49434 » 19 Mar 2019 22:32

NeilP wrote:
19 Mar 2019 21:30
Ah OK, I get you now!

doh
I thought the command was probing the system to find the 'Value'

I have tried and ..anything above 1500 gives the Invalid Argument response.

But since the hardware is the same..it does not explain why it seemed to work and set 9000 in Shigwire.
So maybe this is not an error in XigmasNAS, but in fact an error in Shigwire, that showed 9000 being set when in fact it was not supported.

I will boot the box tomorrow back to Shigwire and try to set different MTU from the CLI again.
Do you have any of the below tunables set?

Code: Select all

hw.nfe.msi_disable
hw.nfe.msix_disable
hw.nfe.jumbo_disable
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

NeilP
Advanced User
Advanced User
Posts: 220
Joined: 15 Jul 2012 11:45
Location: Jersey, Channel Islands, Europe
Status: Offline

Re: Changing MTU setting in GUI stops IP address being set.

#8

Post by NeilP » 20 Mar 2019 07:49

No, not on either N4F Shigwire or XigmaNASz.

In both instances only change was typing in 9000 via WebGUI and hitting Save.
Never used any CLI commands before to change settings within any of the variation from FreeNAS/N4F or now XigmaNAS

Post Reply

Return to “XigmaNAS Networking Tune-up”