*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[EXTENSION] Extended GUI

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
paulj
Starter
Starter
Posts: 25
Joined: 12 Mar 2015 01:48
Status: Offline

Re: [EXTENSION] Extended GUI

#601

Post by paulj » 22 Mar 2018 19:41

When trying to mount an external USB drive using the buttons on the System page I get the following error:
rm: /mnt/*.automount*: No such file or directory
The logs show that the drive is recognized when plugged in.

Any idea why it won't mount?
Xigmanas 11.2.0.4 - Omnius (revision 6315)
Supermicro A1SRi x64-full on Intel(R) Atom(TM) CPU C2758 @ 2.40GHz 16GB ECC memory
ZFS on Root Install

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: [EXTENSION] Extended GUI

#602

Post by jasch » 13 Apr 2018 09:04

Hi crest, i have a small cosmetical Bug with Install on ESXI(its the only Diff. between the Installs).
On new System the reported Space has diff. Format and does not Fit.
Extended Gui is latest Beta via ONEButtoninstaller.


First Picture old(old.png) NAS fine, second Picture New Nas(new.png) on ESXI.
You do not have the required permissions to view the files attached to this post.
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4936
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#603

Post by raulfg3 » 13 Apr 2018 12:52

please revise new option in webGUI to show space used Vs space allocate.


viewtopic.php?f=56&t=13737
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: [EXTENSION] Extended GUI

#604

Post by jasch » 13 Apr 2018 14:19

Hi raulfg, you misunderstood me, its not about what it shows(makes no diff.) is about that the numbers are not fitting in the screen.
look plz on picture 2 the the GB for example are over Used...(when its longer then 6 spaces, 436.87GB for example)

wb Alex
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4936
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#605

Post by raulfg3 » 13 Apr 2018 15:03

ok, i`ll see now.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: [EXTENSION] Extended GUI

#606

Post by jasch » 15 Apr 2018 21:07

Hi i had a small Feature Request.
different AlarmTemp. for HDD and SSD, while 50°C is worse for HDD, its fine for SSD.

wbr Alex
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#607

Post by crest » 16 Apr 2018 07:17

Hello paulj,
paulj wrote:
22 Mar 2018 19:41
When trying to mount an external USB drive using the buttons on the System page I get the following error:
rm: /mnt/*.automount*: No such file or directory
The logs show that the drive is recognized when plugged in.

Any idea why it won't mount?
Since you use embedded install, pls check if the USB drive is recognized as /dev/da1 .... or /dev/da0 .

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#608

Post by crest » 16 Apr 2018 07:22

Hello jasch,
jasch wrote:
13 Apr 2018 09:04
Hi crest, i have a small cosmetical Bug with Install on ESXI(its the only Diff. between the Installs).
On new System the reported Space has diff. Format and does not Fit.
Extended Gui is latest Beta via ONEButtoninstaller.

First Picture old(old.png) NAS fine, second Picture New Nas(new.png) on ESXI.
Thank you for reporting and yes, there was a change in the output format for ZFS and it will be corrected in the next version of eGUI (will be in some weeks since I'm too busy at the moment.)

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#609

Post by crest » 16 Apr 2018 07:23

Hello jasch,
jasch wrote:
15 Apr 2018 21:07
Hi i had a small Feature Request.
different AlarmTemp. for HDD and SSD, while 50°C is worse for HDD, its fine for SSD.

wbr Alex
Yes, will implement it but as I wrote before, it will take some time ;)
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#610

Post by crest » 16 Apr 2018 08:23

crest wrote:
16 Apr 2018 07:17
Hello paulj,
paulj wrote:
22 Mar 2018 19:41
When trying to mount an external USB drive using the buttons on the System page I get the following error:
rm: /mnt/*.automount*: No such file or directory
The logs show that the drive is recognized when plugged in.

Any idea why it won't mount?
Since you use embedded install, pls check if the USB drive is recognized as /dev/da1 .... or /dev/da0 .

Regards
crest
Regarding to your other reporting there is a workaround available, pls download the attached file, unpack it and follow the instructions in the README.md file. This should solve the issue.
AUTOMOUNT-v01.zip
Regards
crest
You do not have the required permissions to view the files attached to this post.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: [EXTENSION] Extended GUI

#611

Post by jasch » 16 Apr 2018 11:13

Thx for the Info crest, good to know you working on it.

wbr Alex
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
jerryone
Starter
Starter
Posts: 63
Joined: 22 Sep 2017 21:45
Location: Timisoara
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#612

Post by jerryone » 20 Apr 2018 23:08

Hi,

After latest update i have the fallowing error on :

1) Temperature of my boot drive is 100 C and on gui it shows the right temp.

On the update i have disable the extension , perform the update and after that re-enable.
You do not have the required permissions to view the files attached to this post.
Dell T610 Xeon x5650 x2 , 192 GB DELL ECC, HBA 9211-8i LSI x2 , 7xHGST-4TB, 2xSamsung 1TB, , 1xKingston 128GB-SSD boot sys
CIFS/SMB, Syncthing, DLNA/UPnP MiniDLNA, BitTorrent, Plex Media Server

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#613

Post by crest » 21 Apr 2018 04:00

Hello jerryone,
jerryone wrote:
20 Apr 2018 23:08
Hi,

After latest update i have the fallowing error on :

1) Temperature of my boot drive is 100 C and on gui it shows the right temp.

On the update i have disable the extension , perform the update and after that re-enable.
Thanks for reporting, I will take care about this - it'll take some days so pls stay tuned ...

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
jerryone
Starter
Starter
Posts: 63
Joined: 22 Sep 2017 21:45
Location: Timisoara
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#614

Post by jerryone » 21 Apr 2018 10:13

Thanks! Have a nice weekend!
Dell T610 Xeon x5650 x2 , 192 GB DELL ECC, HBA 9211-8i LSI x2 , 7xHGST-4TB, 2xSamsung 1TB, , 1xKingston 128GB-SSD boot sys
CIFS/SMB, Syncthing, DLNA/UPnP MiniDLNA, BitTorrent, Plex Media Server

jasch
experienced User
experienced User
Posts: 144
Joined: 25 Jun 2012 10:25
Location: Germany
Status: Offline

Re: [EXTENSION] Extended GUI

#615

Post by jasch » 07 May 2018 12:17

Hello Crest,

sorry but another Question, after some Testing my SSD health info went from 98% to 95% so i investigated this.
(Samsung EVO 850 500GB)

177 Wear_Leveling_Count 0x0013 099 099 000 Pre-fail Always - 5
241 Total_LBAs_Written 0x0032 099 099 000 Old_age Always - 5085220275

it looks like you use the Wear_Leveling_Count -> RAW_VALUE (which is 5 so 100-5 =95%)
As far, as i know it should be the Wear_Leveling_Count -> VALUE (99 im my case, so 99%)
When i man. calculate this:
EVO 850 500gb TBW: 150TB
Total_LBAs_Written : 5085220275 -> 2.37 TB

so its 1,58% but Samsung rounds ;-) so its 99%.

as info
https://www.anandtech.com/show/8239/upd ... d-die-size

wbr Alex
XigmaNAS 12.0.0.4 (6625)@PROXMOX 5.V - Supermicro X8DTH-6F | 2x Xeon L5640 | 96GB ECC | LSI 9210-8i|LSI 9500-8e|LSI 9201-16i | 40GBe IB Mellanox |

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#616

Post by crest » 08 May 2018 08:56

jasch wrote:
07 May 2018 12:17
Hello Crest,

sorry but another Question, after some Testing my SSD health info went from 98% to 95% so i investigated this.
(Samsung EVO 850 500GB)

177 Wear_Leveling_Count 0x0013 099 099 000 Pre-fail Always - 5
241 Total_LBAs_Written 0x0032 099 099 000 Old_age Always - 5085220275

it looks like you use the Wear_Leveling_Count -> RAW_VALUE (which is 5 so 100-5 =95%)
As far, as i know it should be the Wear_Leveling_Count -> VALUE (99 im my case, so 99%)
When i man. calculate this:
EVO 850 500gb TBW: 150TB
Total_LBAs_Written : 5085220275 -> 2.37 TB

so its 1,58% but Samsung rounds ;-) so its 99%.

as info
https://www.anandtech.com/show/8239/upd ... d-die-size

wbr Alex
Hi jasch,
Thanks for reporting, you are right, will be corrected.
The pain with SSD health info is that the different vendors use a variety of methods to display the info ... :(

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#617

Post by crest » 26 Aug 2018 08:03

Hello all,

there is a new release (v0.7) of this extension available => [EXTENSION] Extended GUI.
UPDATES CAN BE DONE DIRECTLY VIA THE WEBGUI (Extension Maintenance Tab).

For a list of changes take a look at the Version History.

The translations base file on Launchpad has been updated - please proceed to Extended GUI on Launchpad for translation!

If someone wants to contribute to extension translations please refer to this topic => Translations for Extensions

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Cramin
Starter
Starter
Posts: 30
Joined: 14 Jul 2014 07:57
Location: Myszkow (Poland)
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#618

Post by Cramin » 27 Aug 2018 20:11

Hello, i have problem with E_GUI and disk temperatures. I have ZFS Pool with 2x disk RAID1 vpools. On old NAS i had vpool 4x disks and i was working good.
2018-08-27_200330.png
2018-08-27_200923.png
2018-08-27_201006.png
You do not have the required permissions to view the files attached to this post.
Intel SS4200-E - 11.2.0.4 - Omnius P2C E2200 + 2GB DDR2 + 2x (Raid1 2x500GB WD) - Home
MSI G41M-P28 S771Mod - 11.2.0.4 - Omnius Xeon E5320 + 4GB DDR3 + Raid1 2x500GB Samsung - Work

scifimike12
Starter
Starter
Posts: 18
Joined: 21 Jul 2016 05:54
Status: Offline

Re: [EXTENSION] Extended GUI

#619

Post by scifimike12 » 28 Aug 2018 17:47

Cramin wrote:
27 Aug 2018 20:11
Hello, i have problem with E_GUI and disk temperatures. I have ZFS Pool with 2x disk RAID1 vpools. On old NAS i had vpool 4x disks and i was working good.
2018-08-27_200330.png
2018-08-27_200923.png
2018-08-27_201006.png
Enable display of ZFS datasets.

Cramin
Starter
Starter
Posts: 30
Joined: 14 Jul 2014 07:57
Location: Myszkow (Poland)
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#620

Post by Cramin » 28 Aug 2018 18:28

Display of ZFS datasets is enabled.

Code: Select all

ss4200: /tmp# ls -l extended-gui_*
-rw-r--r--  1 root  wheel   61 Aug 28 18:24 extended-gui_ada0p1_missing.lock
-rw-r--r--  1 root  wheel   61 Aug 28 18:24 extended-gui_ada1p1_missing.lock
-rw-r--r--  1 root  wheel   97 Aug 28 18:24 extended-gui_cpu_check.log
-rw-r--r--  1 root  wheel    6 Aug 28 18:24 extended-gui_system_calls.sh.lock
-rw-r--r--  1 root  wheel  245 Aug 28 18:24 extended-gui_system_error.msg.locked
-rw-r--r--  1 root  wheel    0 Aug 28 18:24 extended-gui_user_auth.new
-rw-r--r--  1 root  wheel   61 Aug 28 18:24 extended-gui_user_new.log
-rw-r--r--  1 root  wheel   61 Aug 28 18:24 extended-gui_user_old.log
-rw-r--r--  1 root  wheel  103 Aug 28 18:24 extended-gui_user_online.log
-rw-r--r--  1 root  wheel   97 Aug 28 18:24 extended-gui_user_online.log.tmp
-rw-r--r--  1 root  wheel  148 Aug 28 18:24 extended-gui_ZFS.smart

extended-gui_ZFS:
total 32
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 Backups.smart
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 extensions.smart
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 Home.smart
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 Supermicro.smart
-rw-r--r--  1 root  wheel   78 Aug 28 18:24 swap_missing.lock
-rw-r--r--  1 root  wheel   44 Aug 28 18:24 swap.smart
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 Wesela.smart
-rw-r--r--  1 root  wheel  137 Aug 28 18:24 Zdjecia.smart
ss4200: /tmp#
I don't have ada0p1 and ada1p1, i have ada0, ada1, ada2, ada3. ZFS/swap is ZFS volume.

Code: Select all

2018.08.28 18:24:25 ERROR Device ada0p1 missing or config changed!
2018.08.28 18:24:26 ERROR Device ada1p1 missing or config changed!
2018.08.28 18:24:26 ERROR Device for mountpoint ZFS/swap missing or config changed!
Intel SS4200-E - 11.2.0.4 - Omnius P2C E2200 + 2GB DDR2 + 2x (Raid1 2x500GB WD) - Home
MSI G41M-P28 S771Mod - 11.2.0.4 - Omnius Xeon E5320 + 4GB DDR3 + Raid1 2x500GB Samsung - Work

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#621

Post by crest » 29 Aug 2018 07:38

Hello Cramin,
Cramin wrote:
27 Aug 2018 20:11
Hello, i have problem with E_GUI and disk temperatures. I have ZFS Pool with 2x disk RAID1 vpools. On old NAS i had vpool 4x disks and i was working good.
2018-08-27_200330.png
2018-08-27_200923.png
2018-08-27_201006.png
To me it looks like that your ZFS devices and the configuration are out of sync. Pls compare the entries under Disks > ZFS > Configuration > Current and Disks > ZFS > Configuration > Detected, most likely they are different. If it is so pls proceed to Disks > ZFS > Configuration > Synchronize and perform Synchronize, after that restart eGUI and you should see your pool as expected.

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Cramin
Starter
Starter
Posts: 30
Joined: 14 Jul 2014 07:57
Location: Myszkow (Poland)
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#622

Post by Cramin » 29 Aug 2018 12:52

Thank You!
Yes it was the problem, after sync and restart eGUI it works perfect.
Intel SS4200-E - 11.2.0.4 - Omnius P2C E2200 + 2GB DDR2 + 2x (Raid1 2x500GB WD) - Home
MSI G41M-P28 S771Mod - 11.2.0.4 - Omnius Xeon E5320 + 4GB DDR3 + Raid1 2x500GB Samsung - Work

User avatar
uniss
Starter
Starter
Posts: 35
Joined: 29 Aug 2014 19:01
Location: Dnipro, Ukraine
Contact:
Status: Offline

Re: [EXTENSION] Extended GUI

#623

Post by uniss » 23 Sep 2018 09:26

Hello.
I try to support the Ukrainian localization, and I again have a problem))) Here are the screenshots of the problem areas. Where there is no translation of the Note, I give for comparison the screen from OBI extension.
2018-09-02 13_23_06-nas.local - Розширення _ Extended GUI 0.7.png
2018-09-02 17_47_56-nas.local - Розширення _ Extended GUI 0.7 _ Обслуговування.png
2018-09-02 13_29_08-nas.local - Розширення _ OneButtonInstaller 0.4 _ Обслуговування.png
2018-09-02 17_50_26-nas.local - Діагностика _ Журнал.png
2018-09-02 17_50_15-nas.local - Діагностика _ Журнал.png
You do not have the required permissions to view the files attached to this post.
:idea: HP N40L, 16 GB RAM, 3x8TB WD Red, 3x4TB WD Red, XN 12.1.0.4.7091 embedded

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#624

Post by crest » 24 Sep 2018 08:48

Hello uniss,
uniss wrote:
23 Sep 2018 09:26
Hello.
I try to support the Ukrainian localization, and I again have a problem))) Here are the screenshots of the problem areas. Where there is no translation of the Note, I give for comparison the screen from OBI extension.
...
Thank you for reporting, I will take care about and keep you informed when I'm ready ...

Rgeards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#625

Post by crest » 24 Sep 2018 09:06

Hello all,

there is a maintenance release (v0.7.0.1) of this extension available => [EXTENSION] Extended GUI.
UPDATES CAN BE DONE DIRECTLY VIA THE WEBGUI (Extension Maintenance Tab).

THIS RELEASE SOLVES PROBLEMS DURING FIRMWARE UPGRADES THAT MAY APPEAR UNDER CERTAIN TERMS, IT IS THEREFORE HIGHLY RECOMMENDED TO UPDATE THE EXTENSION.

For a list of changes take a look at the Version History.

If someone wants to contribute to extension translations please refer to this topic => Translations for Extensions

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

george73
NewUser
NewUser
Posts: 13
Joined: 08 Jul 2018 15:41
Status: Offline

Re: [EXTENSION] Extended GUI

#626

Post by george73 » 21 Oct 2018 15:50

Hi everybody!

I have a problem.
I wired down my disk drives in my home server, so my boot disk changed from ada2 to ada4 which corresponds now my physical configuration. But now extended gui gives me this error massage on the home page: 2018.10.21 14:48:28 ERROR Device ada2 missing or config changed!
I tried to remove the extension and then reinstall it again, but the error massage still came back. Then I uninstalled again and deleted the extended-gui folder from the location of my install then reinstalled it again. The error appears again.
If I disable the system notifications on the extended gui config page, then there is no error. If I enable it, the error appears again.
Which file or config should be deleted/changed to get rid of this error message?

Thanks a lot,
George

george73
NewUser
NewUser
Posts: 13
Joined: 08 Jul 2018 15:41
Status: Offline

Re: [EXTENSION] Extended GUI

#627

Post by george73 » 21 Oct 2018 16:01

george73 wrote:
21 Oct 2018 15:50
Hi everybody!

I have a problem.
I wired down my disk drives in my home server, so my boot disk changed from ada2 to ada4 which corresponds now my physical configuration. But now extended gui gives me this error massage on the home page: 2018.10.21 14:48:28 ERROR Device ada2 missing or config changed!
I tried to remove the extension and then reinstall it again, but the error massage still came back. Then I uninstalled again and deleted the extended-gui folder from the location of my install then reinstalled it again. The error appears again.
If I disable the system notifications on the extended gui config page, then there is no error. If I enable it, the error appears again.
Which file or config should be deleted/changed to get rid of this error message?

Thanks a lot,
George
Hello All!

Never mind my post. There is a clear history button on the main page and pushing it solved my problem. Now the error message gone.
Sorry for disturbing you with my stupid mistake.

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#628

Post by crest » 22 Oct 2018 06:11

Hello george73,
george73 wrote:
21 Oct 2018 16:01
...
Hello All!

Never mind my post. There is a clear history button on the main page and pushing it solved my problem. Now the error message gone.
Sorry for disturbing you with my stupid mistake.
Welcome to the forums!

Don't worry, questions are always welcome but good to see you found the right solution for your issue ;)

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

bgold
Starter
Starter
Posts: 59
Joined: 23 May 2015 08:42
Status: Offline

Re: [EXTENSION] Extended GUI

#629

Post by bgold » 29 Apr 2019 21:36

Is there any chance of adding alarms for SSD life? Similar to the diskspace.

Thanks
XigmaNAS 12.0.0.4.6625
HP ML150 Gen9, Dual 2.4ghz, 256gb, 25TB Storage, 3-ZFS pools w/SSD cache&logs, SSD boot/data, SFP+

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 873
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] Extended GUI

#630

Post by crest » 30 Apr 2019 08:45

Hello bgold,
bgold wrote:
29 Apr 2019 21:36
Is there any chance of adding alarms for SSD life? Similar to the diskspace.

Thanks
Yes, can be done. Since the lifetime values are wide spread how the different vendors implemented in SMART it would be helpful to send me the whole SMART output of your SSDs.

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Post Reply

Return to “Extensions / Add-ons”