*New 12.1 series Release:
2020-09-13: XigmaNAS - released

*New 11.4 series Release:
2020-09-12: XigmaNAS - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

No space on 4Gb USB to install Jail, aMule

Jails with XigmaNAS
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
Posts: 1
Joined: 04 Jan 2020 10:34
Location: Minsk, Belarus
Status: Offline

No space on 4Gb USB to install Jail, aMule


Post by Serpens »

Hello everybody!

I'm going to make NAS on 3Q IPX7A-ION/330 / 4Gb SO-DIMM DDR2-800 / 4Gb USB flash.
Services I'm going to use - files share, Torrent, Mule (or MLDonkey), DLNA.

To test, I made VMware's vNAS and install XigmaNAS on MBR (no swap, no data). I opened SSH and tried to install Jail from topic "HowTo Setup a jail on top of XigmaNAS" at https://www.xigmanas.com/wiki/doku.php? ... wto:jails. manual.

Code: Select all

# fetch ftp://ftp.freebsd.org/pub/FreeBSD/releases/`uname -m`/`uname -m`/`uname -r | cut -d- -f1-2`/base.txz
command I got out of space error.

My disk (emulated a 4 Gb USB flash):
Filesystem Size Used Avail Capacity Mounted on
/dev/md0 120M 104M 15M 87% /
devfs 1.0K 1.0K 0B 100% /dev
/dev/md1 1.1G 987M 167M 86% /usr/local
procfs 4.0K 4.0K 0B 100% /proc
/dev/ada0s1a 3.7G 312M 3.4G 8% /cf
/dev/md2 496M 2.2M 483M 0% /var
tmpfs 256M 48K 256M 0% /var/tmp
/mnt/data/jail 120M 104M 15M 87% /jail
I see free space mounted /cf but I don't know, how to use it or how to distribute it to md1. I have strong knowledge Windows and Windows Server but poor of UNIX/Linux but I want and ready to study!

So I have 2 questions:
What I did wrong before?
What I should do now to solve the problem?

PS: I search INet (about install soft on FreeBSD, Jails) and this forum (about Jails, aMule, MLDonkey) but all topics I found doesn't had so problem :( . I tried to solve this problem about 3 week and got in trap.... I think it's time to ask guru's help.

User avatar
Site Admin
Site Admin
Posts: 5180
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Status: Offline

Re: No space on 4Gb USB to install Jail, aMule


Post by raulfg3 »

please read about full and embeded install, and understand how it works.

next time try this:




or better: viewtopic.php?f=71&t=14848 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Last changes

HP T510

User avatar
Posts: 1560
Joined: 19 Aug 2012 08:22
Location: Israel, Karmiel
Status: Offline

Re: No space on 4Gb USB to install Jail, aMule


Post by alexey123 »

For run jail under NAS based on FreeBSD 12.1 need more free space for each jail without any additional software
Jail1 created just now

/cf mounted read only, so you can not use it as regular filesystem
You do not have the required permissions to view the files attached to this post.
Home12.1.0.4 - Ingva (revision 7091)/ x64-embedded on AMD A8-7600 Radeon R7 A88XM-PLUS/ 16G RAM / UPS Ippon Back Power Pro 600
Lab - Ingva (revision 7091) /x64-embedded on Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz / H61M-DS2 / 4G RAM / UPS Ippon Back Power Pro 600

Post Reply

Return to “Jails”