*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[EXTENSION] OneButtonInstaller

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
raulfg3
Site Admin
Site Admin
Posts: 5119
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#151

Post by raulfg3 »

please post ls -la /mnt/NASys/

to know owner and permission of /mnt/NASys/Ext dataset
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#152

Post by IG33 »

raulfg3 wrote:
15 Feb 2020 13:20
please post ls -la /mnt/NASys/

Code: Select all

ignasv: ~# ls -la /mnt/NASys/
total 14
drwxrwxrwx  4 root  wheel     512 Feb 14 15:19 .
drwxr-xr-x  3 root  wheel     512 Feb 14 18:13 ..
drwxrwxr-x  2 root  operator  512 Feb 14 18:00 .snap
drwxrwxrwx  3 root  wheel     512 Feb 14 15:19 Ext

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5119
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#153

Post by raulfg3 »

all is good.

Sorry no more ideas what it's wrong.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#154

Post by IG33 »

raulfg3 wrote:
15 Feb 2020 17:50
no more ideas what it's wrong.
It is possible that the reasons are in the network settings in the place where the NAS is installed. I will talk to the network administrator and write if something clears up.

IG33
NewUser
NewUser
Posts: 13
Joined: 01 Sep 2016 12:48
Location: Moscow, Russia
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#155

Post by IG33 »

IG33 wrote:
14 Feb 2020 22:22
Help me, please.
...
As it turned out, the problem is related to the settings of the access restriction system in our company. Administrators are trying to figure out the problem, but I have so far bypassed it by temporarily connecting the NAS to the Internet via another provider (mobile 4G).

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#156

Post by TJF »

I have the same problem like IG33:

$ ls -la /mnt/extensions/
total 8
drwxrwxr-x 2 root wheel 512 Mar 2 14:56 .
drwxr-xr-x 4 root wheel 512 Mar 2 14:56 ..

No access restriction system at home!
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5119
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#157

Post by raulfg3 »

TJF wrote:
02 Mar 2020 14:59
I have the same problem like IG33:

$ ls -la /mnt/extensions/
total 8
drwxrwxr-x 2 root wheel 512 Mar 2 14:56 .
drwxr-xr-x 4 root wheel 512 Mar 2 14:56 ..

No access restriction system at home!
but you bon't have a folder for extension like IG33 only . and ..

please read topic from the ini, and post your steps and the output of the shell to see what appends.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#158

Post by TJF »

After installing OBI everything seems to be ok. After restart of the NAS it is totally gone.


/mnt/DATA/extensions

$ ls -la /mnt/DATA/
total 12
drwxrwxr-x 3 root wheel 512 Mar 2 18:25 .
drwxr-xr-x 4 root wheel 512 Mar 2 18:25 ..
drwxrwxr-x 3 root wheel 512 Mar 2 18:26 extensions

$ ls -la /mnt/DATA/extensions
total 12
drwxrwxr-x 3 root wheel 512 Mar 2 18:26 .
drwxrwxr-x 3 root wheel 512 Mar 2 18:25 ..
drwxrwxr-x 5 root wheel 512 Mar 2 18:37 onebuttoninstaller


$ fetch https://raw.github.com/crestAT/nas4free ... er/OBI.php && mkdir -p ext/OBI && echo '<a href="OBI.php">OneButtonInstaller</a>' > ext/OBI/menu.inc && echo -e "\nDONE"

DONE


$ ping -t 4 github.com
PING github.com (140.82.118.4): 56 data bytes
64 bytes from 140.82.118.4: icmp_seq=0 ttl=58 time=48.453 ms
64 bytes from 140.82.118.4: icmp_seq=1 ttl=58 time=47.443 ms
64 bytes from 140.82.118.4: icmp_seq=2 ttl=58 time=47.444 ms
64 bytes from 140.82.118.4: icmp_seq=3 ttl=58 time=46.960 ms

--- github.com ping statistics ---
4 packets transmitted, 4 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 46.960/47.575/48.453/0.544 ms


$ fetch https://github.com/crestAT/nas4free-one ... -v0402.zip
-> nothing happens
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#159

Post by TJF »

Before restart this (attachment) happens, when I try to install Plex Media Server.
You do not have the required permissions to view the files attached to this post.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1146
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#160

Post by JoseMR »

TJF wrote:
02 Mar 2020 19:48
Before restart this (attachment) happens, when I try to install Plex Media Server.

This error may be related due a FreeBSD issue in they PKG causing mismatch ABI errors

"There's a known issue with the official FreeBSD package builders (which use ports-mgmt/pkg-devel) causing mismatched ABI error messages for package users. Pull request addressing the issue has been submitted..."

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#161

Post by TJF »

Thank you JoseMR!

Nobody any idea, why after restart of the NAS OBI is totally gone?
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1146
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#162

Post by JoseMR »

TJF wrote:
04 Mar 2020 06:19
Thank you JoseMR!

Nobody any idea, why after restart of the NAS OBI is totally gone?
Most likely you are running an XN Embedded installation don't installed the OBI Extension in a persistent data location i.e. your ZFS pool, or have an issue with the PostInit command.

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#163

Post by TJF »

I have installed it according to the recommendation ( viewtopic.php?f=71&t=11184#p69861 ):
/mnt/DATA/extensions
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5119
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#164

Post by raulfg3 »

TJF wrote:
05 Mar 2020 08:51
I have installed it according to the recommendation ( viewtopic.php?f=71&t=11184#p69861 ):
/mnt/DATA/extensions
/mnt/DATA ia a dataset ?,

please post where point /mnt/DATA and try to copy something to it and see if survie a reboot.
12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#165

Post by TJF »

No, DATA is not a dataset! I did not put it into a dataset. May be - like JoseMR said - that is the point. I will try...
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#166

Post by TJF »

Now, that was the problem. My dataset is named "pool1". Now I installed OBI in /mnt/pool1/DATA/extensions/ and OBI works - even after restart. But I went one step too much, too deep...

After installing Plex the same error like in #410, but there is a folder with Plex-Files. S. Attachment.
You do not have the required permissions to view the files attached to this post.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#167

Post by TJF »

Meanwhile I could install Plex. It is working again -> #410
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1146
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#168

Post by JoseMR »

TJF wrote:
11 Mar 2020 15:58
Meanwhile I could install Plex. It is working again -> #410

Hi, latest Plex Media Server Extension now allow the user to initially install from official Plex Tarballs for convenience, so in case you have further problems with FreeBSD repositories with either Plex pkg version being too old or ABI/connection errors, just upload a latest Plex Tarball and that's it.

More on this in this small Plex Tarball Install/Upgrade How-To

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

TJF
Starter
Starter
Posts: 74
Joined: 06 Feb 2018 17:08
Location: Starnberg, Germany
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#169

Post by TJF »

Yes. Thank you! I've updated to the latest extension v. 4.3.015 and after that I downloaded and installed the FreeBSD-Version PlexMediaServer-1.18.7.2457-77cb9455c-FreeBSD-amd64.tar.bz2 from the Plex-Website. Installation over the extension (maintenance). Everything seems to work fine.
ASUS M5A99X EVO R2.0, AMD FX-6100, Intel CT EXPI9301CT, 16GB ECC RAM, ZFS, XigmaNAS 12.1.0.4 - Ingva (Revision 7321)

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1454
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#170

Post by ernie »

Dear all
I created a vm with xigmanas (12.1.0.4 - Ingva (revision 7509))
The vm contains 2 hdd: one for xigmanas installation and the other for data. No issue the fm works fully.
The vm is used for test.
I used a fresh install and launch the installation of obi.
I obtained the "done " information

But no extension menu with refresh.
I can ping from xigmanas 8.8.8.8
I put language in English.
I flushed the cache of my navigators (trials on safari and Firefox)
No menu
Any advice is welcome
Br
You do not have the required permissions to view the files attached to this post.
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
ms49434
Developer
Developer
Posts: 954
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#171

Post by ms49434 »

ernie wrote:
13 Apr 2020 13:29
Dear all
I created a vm with xigmanas (12.1.0.4 - Ingva (revision 7509))
The vm contains 2 hdd: one for xigmanas installation and the other for data. No issue the fm works fully.
The vm is used for test.
I used a fresh install and launch the installation of obi.
I obtained the "done " information

But no extension menu with refresh.
I can ping from xigmanas 8.8.8.8
I put language in English.
I flushed the cache of my navigators (trials on safari and Firefox)
No menu
Any advice is welcome
Br
Please double check if the extension menu is enabled and is being scanned for extensions. Go to System > Advanced Setup and uncheck "Disable Extension Menu".
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1454
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#172

Post by ernie »

Thanks it works.
I didn't know this new option.
BR
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

DFRomanov
NewUser
NewUser
Posts: 4
Joined: 19 Sep 2019 09:53
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#173

Post by DFRomanov »

I had same problem.

User avatar
ms49434
Developer
Developer
Posts: 954
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#174

Post by ms49434 »

ernie wrote:
13 Apr 2020 14:22
Thanks it works.
I didn't know this new option.
BR
The option was added in March 2017.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 550
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#175

Post by crest »

ms49434 wrote:
26 Apr 2020 15:15
ernie wrote:
13 Apr 2020 14:22
Thanks it works.
I didn't know this new option.
BR
The option was added in March 2017.
The extensions menu seems to be disabled by default now.
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1146
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#176

Post by JoseMR »

crest wrote:
26 Apr 2020 16:32
ms49434 wrote:
26 Apr 2020 15:15
ernie wrote:
13 Apr 2020 14:22
Thanks it works.
I didn't know this new option.
BR
The option was added in March 2017.
The extensions menu seems to be disabled by default now.
Manual solution is:
Extensions_Disabled.png

This was added on Revision 7486 and seems to be causing a lot of problem for newcomers.

I think like the same way the Extensions add the Postinit/Shutdown command scrips, this can be re-enabled
automatically upon an Extension install request in order to mitigate this question which will be asked over-and-over. :roll:

Had to make a quick test though. ;)

Regards
You do not have the required permissions to view the files attached to this post.
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 550
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#177

Post by crest »

JoseMR wrote:
26 Apr 2020 17:04
crest wrote:
26 Apr 2020 16:32
ms49434 wrote:
26 Apr 2020 15:15
ernie wrote:
13 Apr 2020 14:22
Thanks it works.
I didn't know this new option.
BR
The option was added in March 2017.
The extensions menu seems to be disabled by default now.
Manual solution is:
Extensions_Disabled.png


This was added on Revision 7486 and seems to be causing a lot of problem for newcomers.

I think like the same way the Extensions add the Postinit/Shutdown command scrips, this can be re-enabled
automatically upon an Extension install request in order to mitigate this question which will be asked over-and-over. :roll:

Had to make a quick test though. ;)

Regards
The question would be - what is the option good for? If users don't use extensions they don't care ;) and for the users which want to use extensions it's a stumbling block so in my opinion it would be the best to get rid of this option, what do you think of it?

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

User avatar
JoseMR
Hardware & Software Guru
Hardware & Software Guru
Posts: 1146
Joined: 16 Apr 2014 04:15
Location: PR
Contact:
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#178

Post by JoseMR »

crest wrote:
27 Apr 2020 06:00
The question would be - what is the option good for? If users don't use extensions they don't care ;) and for the users which want to use extensions it's a stumbling block so in my opinion it would be the best to get rid of this option, what do you think of it?

Regards
crest
That is a stumbling good question indeed, no extensions users will never notice, but extensions users(mostly new comers) will get overwhelmed by.

Perhaps instead of hacking this to force enable under extensions scripts, this may be best to leave it as an user option for good.

Regards
System: FreeBSD 12 RootOnZFS Mirror, MB: Supermicro X8SI6-F, Xeon X3450, 16GB DDR3 ECC RDIMMs.
XigmaNAS RootOnZFS
Addons at GitHub
BastilleBSD
Boot Environments Intro
Resources Home Page

User avatar
ernie
Forum Moderator
Forum Moderator
Posts: 1454
Joined: 26 Aug 2012 19:09
Location: France - Val d'Oise
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#179

Post by ernie »

Hi
Why not to display a warning during the installation or before the installation (warning for checking this option) ?
Example : before to launch installation thanks to check the option Xxxx. Is it disable ?
Yes = the installation is launched
No = thanks to disable it and then to launch again the installation. (Installation is not launched).

I discovered this option because of fresh installation. Normally I am just updating my embedded version via webgui. And this updating is transparent for the option.

BR
NAS 1&2:
System: GA-6LXGH(BIOS: R01 04/30/2014) / 16 Go ECC
XigmaNAS 12.1.0.4 - Ingva (revision 7542) embedded
NAS1: Xeon E3 1241@3.5GHz, 4HDD@2To/raidz2 (WD red), 3HDD@300Go/sas/raidz1 (Hitachi), 1SSD cache, Zlog on sas mirror
NAS2: G3220@3GHz, 3HDD@2To/raidz1 (Seagate), 1SSD cache, 1HDD@300Go/UFS
UPS: APC Back-UPS RS 900G
Case : Fractal Design XL R2

Extensions & services:
NAS1: OBI (Plex, BTSync, zrep, rclone, themes), nfs, UPS,
NAS2: OBI (zrep (backup mode), themes)

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 550
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] OneButtonInstaller

#180

Post by crest »

ernie wrote:
27 Apr 2020 11:23
Hi
Why not to display a warning during the installation or before the installation (warning for checking this option) ?
Example : before to launch installation thanks to check the option Xxxx. Is it disable ?
Yes = the installation is launched
No = thanks to disable it and then to launch again the installation. (Installation is not launched).

I discovered this option because of fresh installation. Normally I am just updating my embedded version via webgui. And this updating is transparent for the option.

BR
For me the conclusion would be to have this option not ticked by default on a fresh installation ... :twisted: ;)

Regards
crest
NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM
UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone, Themes:

Post Reply

Return to “Extensions / Add-ons”