Sorry we lost some posts because of database errors!

*New 12.1 series Release:
2020-09-01: XigmaNAS 12.1.0.4.7728 - released

*New 11.4 series Release:
2020-08-27: XigmaNAS 11.4.0.4.7718 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

SlimNAS on NAS4Free

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#241

Post by Northwinds »

cookiemonster wrote:
16 Oct 2020 23:32
You're just missing a full stop at the end that makes it a a relative path. Make sure you've changed directory as per the step before it. Then that full stop is what tells the command what the destination is i.e. the current working directory.
For the manual of cp for freebsd : https://www.freebsd.org/cgi/man.cgi?cp

Ah I see!

In Stuarty's guide there is a full stop (again I thought it was a typo) but it separated from the end of the path by a space - is this correct or should the full stop be directly after the path (no space)?

As it happens that man page was what I was referring to and copied the -R meaning from.

Thanks again!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#242

Post by cookiemonster »

yes the space is required.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#243

Post by Northwinds »

Fantastic! Thank you cookiemonster!

I finally got all the commands to complete successfully!

But now what do I need to do to start the server?

I tried selecting the jail in the Bastille GUI to start it but no joy - I click "Start Selected and the box just clears?

Cheers!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#244

Post by cookiemonster »

Which post number are you following? There should be a point where at the end if everything has completed correctly, service lms onestart will allow you to test that it starts correctly. When that happens, you access the lms service on the <jailip>:9000
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#245

Post by Northwinds »

cookiemonster wrote:
16 Oct 2020 23:53
Which post number are you following? There should be a point where at the end if everything has completed correctly, service lms onestart will allow you to test that it starts correctly. When that happens, you access the lms service on the <jailip>:9000
Stuarty's post # 196

Like I mentioned earlier the rest of the post goes into installing various additional codecs - I don't think he mentions how to actually start the server though.....
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#246

Post by Northwinds »

Hmm... I tried service lms onestart as you suggested from root@lms but got:

lms does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable

thanks as ever!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#247

Post by Northwinds »

T the end of post #178 (the walkthrough on installing from ports) Stuarty does add this for starting:

echo 'logitechmediaserver_enable="YES"' >> /etc/rc.conf
service logitechmediaserver onestart

But are these run from the root of the jail or elsewhere?

Thanks again for your responses - doesn't matter if you don't get back tonight - I'm about to head to an early bed as am up early tomorrow, but will check over breakfast - Cheers again!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#248

Post by cookiemonster »

All commands from inside the jail, you're still installing it. It doesn't matter where onestart is ran from but needs to be inside the jail.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#249

Post by Northwinds »

Yep - first one worked but second gave the same message:

root@lms:/ # service logitechmediaserver onestart
logitechmediaserver does not exist in /etc/rc.d or the local startup
directories (/usr/local/etc/rc.d), or is not executable

so I guess something didn't work.

:-(
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#250

Post by cookiemonster »

Did you create the user, group, start script, etc?
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#251

Post by Northwinds »

cookiemonster wrote:
18 Oct 2020 15:32
Did you create the user, group, start script, etc?
Sorry cookiemonster - not being too bright today - how do you mean?

I may have missed this?

Thanks!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#252

Post by Northwinds »

cookiemonster wrote:
18 Oct 2020 15:32
Did you create the user, group, start script, etc?
Looking further back through these posts...

Do you mean this?:

chown -R lms:lms /usr/local/lms
chown root:wheel /usr/local/etc/rc.d/lms
chmod 555 /usr/local/etc/rc.d/lms

Thanks!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#253

Post by cookiemonster »

Yes but there are other bits, right? Like for instance changing to the rc.d directory and fetching the startup script into it.
In other words unless you do every part, it is not going to work. Unless you've done it differently and then is ok to chose the parts of the post that you need.
So you did say you were following post #196. Go through it making sure you follow every step. You need to understand what each is doing and only adapt for newer version of the software i.e. lms or its dependencies i.e. perl
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#254

Post by Northwinds »

cookiemonster wrote:
18 Oct 2020 22:53
Yes but there are other bits, right? Like for instance changing to the rc.d directory and fetching the startup script into it.
In other words unless you do every part, it is not going to work. Unless you've done it differently and then is ok to chose the parts of the post that you need.
So you did say you were following post #196. Go through it making sure you follow every step. You need to understand what each is doing and only adapt for newer version of the software i.e. lms or its dependencies i.e. perl
Hey cookimonster - my bad!

I was temporarily omitting the codecs installer section and totally missed the section thereafter!

I'll create a fresh jail and do the whole thing again today.

Do you think if I'm following post #196 it would be a good idea to change the jail base from 12.1 to 11.2?

Thanks again!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#255

Post by cookiemonster »

I'd leave it on 12.1 and only go lower if necessary.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#256

Post by Northwinds »

cookiemonster wrote:
19 Oct 2020 12:15
I'd leave it on 12.1 and only go lower if necessary.
Hi again cookiemonster!

Been stuggling on with this again.

In your opinion, if I'm sticking on 12.1, which version of perl and which version of lms should I be replacing in Stuarty's post #196?

I've tried multiple versions of perl from 5.28 to 5.32 and various fifferent lms from 7.9.2 to 7.9.4 - but have noticed versions up to 7.9.7 and even an 8.0

Every combination I have tried so far leaves me with either a mistake somewher during installation or ultimately installs but won't starts?

Thanks again for your feedback!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#257

Post by cookiemonster »

It's not clear why or even _if_ the perl version and lms are a problem. Follow every step one by one ensuring there are no errors and verify afterwards.
For perl is quite easy. Once you run the build script, you'll need to check that there is a full list of artifacts (files) in a directory for installed perl version.
You realise that the rm commands are deleting directories and files, right.?
The howto being followed is implying -and it might not be clear if someone is just following commands line by line- that you get your source code (download part) and run the build routines (build command).
If the lms version and this routine has been updated to your installed version of perl, you end up with built modules.
Then the rm commands are to clean up, removing modules for other versions of perl you don't have, as they are unnecessarily taking up space.
Therefore, make sure you are not deleting the one you actually need for starters.
Post here attached the build log or send it to me and I'll look for clues.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#258

Post by cookiemonster »

Don't be disheartened but I've found a little more.
If you remember there is a step to download from github in order to build your perl modules for your OS and perl version. Then locally you go to CPAN and run the buidme.sh script.
The readme https://github.com/Logitech/slimserver- ... c/8.0/CPANfor v 8.0 of slimserver-vendor gives you a nice view of what it needs and what to do. So far so good.
Unfortunately even on this latest version the documentation on the buildme.sh scrpt reads on line 21:
FreeBSD 8.X,9.X (Perl 5.12.4).
What this means is according to it, support only goes to freeBSD ver 9.X base and perl 5.12.
Since we know we've built successfully in the past up to freeBSD ver 11.2 and perl 5.22, it is likely just the comments are out of date and we can build for later.
However it's a bit of trial and error for your version of 12.X and perl.
I've put a question there for the devs for some information. In the meantime we just need to try.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#259

Post by cookiemonster »

I had a reply from the devs. FreeBSD is not supported out of the box, meaning we have to compile binaries. We know we can, no problem.
It should be compatible with Perl at least 5.30.
So, as we were. Jail base try 12.X if too much hassle compiling, go to 11.X we know we can.
Perl is probably good to try with 5.30
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#260

Post by Northwinds »

cookiemonster wrote:
20 Oct 2020 12:50
It's not clear why or even _if_ the perl version and lms are a problem. Follow every step one by one ensuring there are no errors and verify afterwards.
For perl is quite easy. Once you run the build script, you'll need to check that there is a full list of artifacts (files) in a directory for installed perl version.
You realise that the rm commands are deleting directories and files, right.?
The howto being followed is implying -and it might not be clear if someone is just following commands line by line- that you get your source code (download part) and run the build routines (build command).
If the lms version and this routine has been updated to your installed version of perl, you end up with built modules.
Then the rm commands are to clean up, removing modules for other versions of perl you don't have, as they are unnecessarily taking up space.
Therefore, make sure you are not deleting the one you actually need for starters.
Post here attached the build log or send it to me and I'll look for clues.
Ok, so I started again with a new Bastille jail on 12.1 but didn't get very far:

nas4free: ~# jexec 1
root@lms:/ # pkg
The package management tool is not yet installed on your system.
Do you want to fetch and install it now? [y/N]: y
Bootstrapping pkg from pkg+http://pkg.FreeBSD.org/FreeBSD:12:amd64/quarterly, please wait...
pkg: Error fetching http://pkg.FreeBSD.org/FreeBSD:12:amd64 ... st/pkg.txz: No address record
A pre-built version of pkg could not be found for your system.
Consider changing PACKAGESITE or installing it from ports: 'ports-mgmt/pkg'.


????


Thanks again!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#261

Post by cookiemonster »

You might not have internet access from the jail or DNS. Just do a jail as before.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#262

Post by Northwinds »

cookiemonster wrote:
21 Oct 2020 23:57
You might not have internet access from the jail or DNS. Just do a jail as before.
Yeah - my bad - I had the wrong network interface chosen!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#263

Post by Northwinds »

Ok, latest attempt:
root@lms:/ # pkg install devel/nasm shells/bash devel/gmake net/rsync curl perl5.28-5.28.3
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#264

Post by Northwinds »

12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#265

Post by Northwinds »

then:

unzip 7*

but:
root@lms:/tmp # tar xjf l*
tar: logitechmediaserver-7.9.2.tgz: Not found in archive
tar: Error exit delayed from previous errors.

I had thought that going with perl 5.28.3 and lms 7.9.0 was playing safe but presumably from the error I need at least lms 7.9.2 ?
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#266

Post by cookiemonster »

Try just tar xzf , not tar xjf for the command to use on the compressed file.
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#267

Post by Northwinds »

cookiemonster wrote:
22 Oct 2020 14:05
Try just tar xzf , not tar xjf for the command to use on the compressed file.
thanks again!

Out of interest I did this:

root@lms:/tmp # ls -li
total 502093
410309 drwxrwxrwt 2 root wheel 2 Oct 21 22:07 .font-unix
410308 drwxrwxrwt 2 root wheel 2 Oct 21 22:07 .ICE-unix
410305 drwxrwxrwt 2 root wheel 2 Oct 21 22:07 .X11-unix
410307 drwxrwxrwt 2 root wheel 2 Oct 21 22:07 .XIM-unix
422073 -rw-r--r-- 1 root wheel 148810769 Oct 22 10:52 7.9.zip
422071 -rw-r--r-- 1 root wheel 155537396 Oct 22 10:51 logitechmediaserver-7.9.0.tgz
419932 -rw-r--r-- 1 root wheel 209299769 Oct 21 22:23 logitechmediaserver-7.9.2.tgz
422074 drwxr-xr-x 9 root wheel 10 Oct 22 10:53 slimserver-vendor-public-7.9

and then decided to do:

root@lms:/tmp # tar xzf logitechmediaserver-7.9.2.tgz

and it seemed happy, although maybe I should have done?:
tar xzf logitechmediaserver-7.9.0.tgz

not sure but will try to continue and see what happens.

Cheers again!
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#268

Post by Northwinds »

Ok, so here's the next problem:

root@lms:/tmp/slimserver-vendor-public-7.9/CPAN # ./buildme.sh -t | tee /tmp/build.log
RUN_TESTS:0 CLEAN:1 USE_HINTS:1 RENAME_x86:1 target all
Looks like your compiler is cc
FreeBSD clang version 8.0.1 (tags/RELEASE_801/final 366581) (based on LLVM 8.0.1)
Target: x86_64-unknown-freebsd12.1
Thread model: posix
InstalledDir: /usr/bin
./buildme.sh: line 469: perl: command not found
Failed to find supported Perl version for ''


not syre if the problem is the "unknown" freensd 12.1
or the.
supported Perl version for ''

or both?
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

cookiemonster
Advanced User
Advanced User
Posts: 286
Joined: 23 Mar 2014 02:58
Location: UK
Status: Offline

Re: SlimNAS on NAS4Free

#269

Post by cookiemonster »

Ah, that at least gives us something.:
The buildme script has tests for perl versions. It only goes as far as 5.26 on all branches. If you are on 5.28 then it would explain the message. Can you get Perl 5.26 ?
Main: Xigmanas 11.2.0.4 x64-full-RootOnZFS as ESXi VM with 24GB memory.
Main Host: Supermicro X8DT3 Memory: 72GB ECC; 2 Xeon E5645 CPUs; Storage: (HBA) - LSI SAS 9211-4i with 3 SATA x 1 TB in raidZ1, 1 x 3 TB SAS drive as single stripe, 3 x 4 TB SAS drives in raidZ1.
Spare1: HP DL360 G7; 6 GB ECC RAM; 1 Xeon CPU; 5 x 500 GB disks on H210i
Backup1: HP DL380 G7; 24 GB ECC RAM; 2 Xeon E5645 CPUs; 8 x 500 GB disks on IBM M1015 flashed to LSI9211-IT

Northwinds
Starter
Starter
Posts: 72
Joined: 03 Sep 2014 01:51
Status: Offline

Re: SlimNAS on NAS4Free

#270

Post by Northwinds »

cookiemonster wrote:
22 Oct 2020 16:17
Ah, that at least gives us something.:
The buildme script has tests for perl versions. It only goes as far as 5.26 on all branches. If you are on 5.28 then it would explain the message. Can you get Perl 5.26 ?
I see - that would make sense!

When I did a
pkg search perl
5.28.3
was the oldest available re the pkg command.

Not sure where I'd get 5.26 from or how I'd install it?
12.1.0.4 (7743)
x64-embedded on Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Supermicro X7SB4/E with 2x Single-port Gigabit PCI-Express Ethernet Controllers
8GB RAM
8 x Seagate ST4000VN000 4TB NAS HDD

Post Reply

Return to “Extensions / Add-ons”