*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

problem => iscsi + carp + nas4free 10.3.0.3

iSCSI over TCP/IP.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
octave
experienced User
experienced User
Posts: 127
Joined: 30 Sep 2013 12:37
Status: Offline

problem => iscsi + carp + nas4free 10.3.0.3

#1

Post by octave » 17 Sep 2016 23:43

hi all

I build a cluster with tow servers
-- 1 motherboard x8dth-I
-- 2 nic intel pro pci-e more
---- 1 lan (administration)
---- 1 lan (samba)
---- 1 lan (iscsi)
---- 1 sycnrho nas to nas
-- 1 raid hardware lsi 9650se-12ml
----12hdd 3TB for samba raid5 (ufs)
-- on motherboard
-- 1 hdd 2TB for iscsi esxi (ufs)
-- 1 hdd 2TB for iscsi hyper-v (ufs)
-- 1 hdd 2TB for iscsi proxmox (ufs)

I param 2 vip (carp)
- 1 for samba
- 1 for iscsi
If i cut ou reboot master node, the slave dont give service on both carp.
all iscsi client dont show now master service.
<iscsitarget>
<nodebase>iqn.2016-08.lan.tb-info.istgt</nodebase>
<discoveryauthmethod>Auto</discoveryauthmethod>
<discoveryauthgroup>0</discoveryauthgroup>
<timeout>30</timeout>
<nopininterval>20</nopininterval>
<maxr2t>32</maxr2t>
<maxsessions>16</maxsessions>
<maxconnections>4</maxconnections>
<firstburstlength>262144</firstburstlength>
<maxburstlength>1048576</maxburstlength>
<maxrecvdatasegmentlength>262144</maxrecvdatasegmentlength>
<maxoutstandingr2t>16</maxoutstandingr2t>
<defaulttime2wait>2</defaulttime2wait>
<defaulttime2retain>60</defaulttime2retain>
<uctladdress>127.0.0.1</uctladdress>
<uctlport>3261</uctlport>
<uctlnetmask>127.0.0.1/8</uctlnetmask>
<uctlauthmethod>CHAP mutual</uctlauthmethod>
<uctlauthgroup>1</uctlauthgroup>
<mediadirectory>/dev/hast/disk01</mediadirectory>
<authgroup>
<uuid>82ff63e9-24ee-453d-a506-bd47489c24ac</uuid>
<tag>1</tag>
<comment/>
<agauth>
<authuser>esxi</authuser>
<authsecret>upkv2ds0</authsecret>
<authmuser>iscsi</authmuser>
<authmsecret>data</authmsecret>
</agauth>
</authgroup>
<authgroup>
<uuid>e81d82cc-3521-4de8-ad7d-d31857366a49</uuid>
<tag>2</tag>
<comment/>
<agauth>
<authuser>hyper-v</authuser>
<authsecret>@upkv2ds0</authsecret>
<authmuser>iscsi</authmuser>
<authmsecret>data</authmsecret>
</agauth>
</authgroup>
<initiatorgroup>
<uuid>54669aeb-2cfe-46b5-862f-10c478d6825c</uuid>
<tag>1</tag>
<comment/>
<iginitiatorname>ALL</iginitiatorname>
<ignetmask>192.168.4.0/24</ignetmask>
</initiatorgroup>
<portalgroup>
<uuid>1844196f-bb73-48b1-8941-358128b7bf69</uuid>
<tag>1</tag>
<comment/>
<portal>0.0.0.0:3260</portal>
</portalgroup>
<extent>
<uuid>ce1ae5d4-5ca0-4a58-8399-6b15815c8575</uuid>
<name>extent0</name>
<path>/dev/hast/disk01</path>
<size/>
<sizeunit>auto</sizeunit>
<type>hast</type>
<comment/>
</extent>
<extent>
<uuid>9d58c9d1-c0a7-437d-8c64-7e6a81c7565b</uuid>
<name>extent1</name>
<path>/dev/hast/disk02</path>
<size/>
<sizeunit>auto</sizeunit>
<type>hast</type>
<comment/>
</extent>
<target>
<uuid>05a66100-b024-4a29-bdd3-55be1590497f</uuid>
<enable/>
<name>hyper-v</name>
<alias/>
<type>Disk</type>
<flags>rw</flags>
<comment/>
<authmethod>Auto</authmethod>
<digest>Auto</digest>
<queuedepth>32</queuedepth>
<inqvendor/>
<inqproduct/>
<inqrevision/>
<inqserial/>
<blocklen>512</blocklen>
<pgigmap>
<pgtag>1</pgtag>
<igtag>1</igtag>
</pgigmap>
<pgigmap>
<pgtag>1</pgtag>
<igtag>1</igtag>
</pgigmap>
<agmap>
<agtag>2</agtag>
</agmap>
<lunmap>
<lun>0</lun>
<type>Storage</type>
<extentname>extent1</extentname>
</lunmap>
</target>
<target>
<uuid>5630d892-3d70-4477-abd0-f3ea3757ffac</uuid>
<enable/>
<name>esxi</name>
<alias/>
<type>Disk</type>
<flags>rw</flags>
<comment/>
<authmethod>Auto</authmethod>
<digest>Auto</digest>
<queuedepth>32</queuedepth>
<inqvendor/>
<inqproduct/>
<inqrevision/>
<inqserial/>
<blocklen>512</blocklen>
<pgigmap>
<pgtag>1</pgtag>
<igtag>1</igtag>
</pgigmap>
<pgigmap>
<pgtag>1</pgtag>
<igtag>1</igtag>
</pgigmap>
<agmap>
<agtag>1</agtag>
</agmap>
<lunmap>
<lun>0</lun>
<type>Storage</type>
<extentname>extent0</extentname>
</lunmap>
</target>
<enable/>
</iscsitarget>
Thx if any one have a tips for help
++
You do not have the required permissions to view the files attached to this post.
Project
Cluster Pfsense (end)
Cluster ESXI /Hyperv (standby)
Cluster NAS/SAN (in project)
---
2x Dell Poweredge C6100
2x SuperMicro X8dth-i (NAS/SAN Build) ISCSI

octave
experienced User
experienced User
Posts: 127
Joined: 30 Sep 2013 12:37
Status: Offline

Re: problem => iscsi + carp + nas4free 10.3.0.3

#2

Post by octave » 19 Sep 2016 21:03

Hi everybody,
I see more than 10 people have read my post and not an intervention to help me solve this problem. I'm a little bit surprised.

I am convinced that this is a problem parameters either at carp or iSCSI, and it should interest the world to mount a cluster nas4free in good condition and avoid future pitfalls or mistakes.
I hope not to upset anyone with my problem or my problem exposure.

it is at least sunny?
Project
Cluster Pfsense (end)
Cluster ESXI /Hyperv (standby)
Cluster NAS/SAN (in project)
---
2x Dell Poweredge C6100
2x SuperMicro X8dth-i (NAS/SAN Build) ISCSI

Post Reply

Return to “iSCSI (Internet Small Computer Systems Interface)”