Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

[EXTENSION] NextOwnCloud

XigmaNAS Extensions / Add-ons

Moderator: crest

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#121

Post by Snufkin » 26 Aug 2018 16:49

crest wrote:
26 Aug 2018 06:33
did you get in touch with the app provider?
Not yet, have been waiting for your competent answer.
There could be two possible causes:
  1. bugs on XNAS side, e.g. wrong permissions, path, settings, etc,
  2. bugs on app developer's side.
Sidenote for point 1
There was funny story while connecting Linux host to SMB2-SMB3 only N4F 11.1.0.4 - Atomics (5667).
By default Linux smb.conf file keeps very few variables declared, most of them have unclear default values. Among those vars are сlient ipc min/max protocol and сlient min/max protocol which determine host Samba client behavior.
Redefining client min protocol

Code: Select all

сlient ipc min protocol=SMB2
сlient min protocol=SMB2
I was absolutely sure that the max protocol values will certainly not be less than the minimum.
It was wrong assumption and to resolve the issue I had to define max protocol explicitly.

Code: Select all

сlient ipc min protocol=SMB2
сlient ipc max protocol=SMB3
сlient min protocol=SMB2
client max protocol=SMB3
May be XNAS smbclient also suffers from the same misconfiguration?
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#122

Post by crest » 29 Aug 2018 07:59

Snufkin wrote:
26 Aug 2018 16:49
crest wrote:
26 Aug 2018 06:33
did you get in touch with the app provider?
Not yet, have been waiting for your competent answer.
8-) ;)
There could be two possible causes:
  1. bugs on XNAS side, e.g. wrong permissions, path, settings, etc,
  2. bugs on app developer's side.
Either if it is #1 or #2 - I must confess I didn't get what you want to achieve with the tool ... :roll: :oops:

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#123

Post by Snufkin » 29 Aug 2018 18:39

crest wrote:
29 Aug 2018 07:59
I didn't get what you want to achieve with the tool ... :roll: :oops:
There is Nextcloud builtin app External storage support to "...mount external storage services and devices as secondary Nextcloud storage devices". It works good for WebDAV public clouds and local server file system, but fails to connect to Samba shares in local network.

Unfortunately this builtin app lacks diagnostic info of any type, and one of Nextcloud contributor developed SMB connection test app to "...debug smb connections".

Both apps rely on "...smbclient binary required even when using the PHP module" (see SMB/CIFS Nextcloud Adminstration Manual).

If you think there is nothing wrong with XNAS smbclient, then I'll ask the developers of the corresponding apps.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#124

Post by Snufkin » 01 Sep 2018 09:38

crest wrote:
26 Aug 2018 06:33
Tried the app but it's not working for me too, shows only an error in the log:

Code: Select all

Error: Class 'Icewind\SMB\NativeServer' not found
Below is an example of how everything around Samba and smbclient can be confusing.
A couple of quotes
...lighttpd sets the path to a very minimal path that does NOT include /usr/local/bin, where smbclient is installed
The command being issued is smbclient --authentication-file=/proc/self/fd/3. Since FreeBSD doesn't have a /proc/self/fd (this is a linux thing), it is a no go.
Here is link to full text Getting OwnCloud External SMB/CIFS Storage to work.
It is, of course, already outdated, but demonstrates the complexity of porting an application originally written for Linux server to FreeBSD.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Maurizio
Starter
Starter
Posts: 53
Joined: 05 Jul 2018 21:49
Location: Linate (MIlan)
Status: Offline

Re: [EXTENSION] NextOwnCloud with MariaDB

#125

Post by Maurizio » 07 Sep 2018 10:29

I have just installed the NextCloud extension running with the SQL database (MariaDB). All works but I receive these error messages:
Screenshot-2018-09-07-10-21-30.png
The Data Folder is empty because I am using the database.
Can I remove these error massages ?
Thanks
--
Maurizio
You do not have the required permissions to view the files attached to this post.
XigmaNAS 11.2.0.4 on Dell R710 144GB RAM - RootOnZFS zroot on 2x 64GB 15k HDDs in mirror, zdata on 3x 1TB SSD in RAIDZ1.
2x XigmaNAS 11.2.0.4 - RootOnZFS on HPE Proliant Microserver gen10 X3216 - 3x 4TB WD RED. In mirror with zrep.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 4915
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: [EXTENSION] NextOwnCloud

#126

Post by raulfg3 » 07 Sep 2018 12:06

try to use /mnt/zdata/DATA as data folder, error must disappear.

revise document root, I suppose that could be: /mnt/zdata/DATA/nextcloud or something similar.
12.0.0.4 - BETA (revision 6625)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes
Old Wiki

User avatar
Maurizio
Starter
Starter
Posts: 53
Joined: 05 Jul 2018 21:49
Location: Linate (MIlan)
Status: Offline

Re: [EXTENSION] NextOwnCloud

#127

Post by Maurizio » 07 Sep 2018 16:15

Sorry for the noise, I have reinstalled the extension and all works, I have forgot to: Use this folder at the first login screen.
Only a note: if you reinstall the extension and use the SQL database, you must recreate it.
XigmaNAS 11.2.0.4 on Dell R710 144GB RAM - RootOnZFS zroot on 2x 64GB 15k HDDs in mirror, zdata on 3x 1TB SSD in RAIDZ1.
2x XigmaNAS 11.2.0.4 - RootOnZFS on HPE Proliant Microserver gen10 X3216 - 3x 4TB WD RED. In mirror with zrep.

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#128

Post by Snufkin » 18 Sep 2018 13:35

crest wrote:
26 Aug 2018 06:33
did you get in touch with the app provider?
Github issue was submitted, and no response has been received so far.
XigmaNAS underlying OS doesn't meet Nextcloud System requirements (V13, V14).
Nextcloud is focused exclusively on several Linux server distributions.

Seems with this issue we are left to ourselves.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#129

Post by crest » 24 Sep 2018 09:47

Hi Snufkin,
Snufkin wrote:
18 Sep 2018 13:35
crest wrote:
26 Aug 2018 06:33
did you get in touch with the app provider?
Github issue was submitted, and no response has been received so far.
XigmaNAS underlying OS doesn't meet Nextcloud System requirements (V13, V14).
Nextcloud is focused exclusively on several Linux server distributions.

Seems with this issue we are left to ourselves.
Hmm, at the moment I have another projekt running but afterwards I will dig deeper into this issue ...

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#130

Post by Snufkin » 24 Sep 2018 11:09

crest wrote:
24 Sep 2018 09:47
Hmm, at the moment I have another projekt running but afterwards I will dig deeper into this issue ...
Okay, we have nowhere to hurry.
In the meantime, I'll see how Setup Cron for the Nextcloud Preview Generator works.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#131

Post by Snufkin » 28 Sep 2018 22:02

Snufkin wrote:
24 Sep 2018 11:09
In the meantime...
Below is a brief report on how Nextcloud preview (thumbnails) generator was run and what came out of it. To understand the details, I ran the test in a remote shell.

Prerequisites: Nextcloud application Preview Generator installed and active.
  1. Verify current user

    Code: Select all

    id
    uid=80(www) gid=80(www) groups=80(www)
  2. If not, run the following command

    Code: Select all

    su -m www
  3. Now it's time to run Preview generator itself

    Code: Select all

    php -f /<path to web server>/nextcloud/occ preview:pre-generate
    • If Preview Generator app not installed you'll get message

      Code: Select all

        [Symfony\Component\Console\Exception\CommandNotFoundException]
        There are no commands defined in the "preview" namespace.
    • Otherwise you'll get

      Code: Select all

      The process control (PCNTL) extensions are required in case you want to interrupt
      long running commands - see http://php.net/manual/en/book.pcntl.php
  4. Preview Generator app doesn't provide any information to the log, and there were complains about it in Nextcloud forum.
As I see it, the need to install process control (PCNTL) extensions depends on how often and how many files are uploaded that require thumbnails generation. But since there is no logging, it's hard to say how long it takes to generate preview for 50, 100 or 1000 files.

Addition:
To roughly estimate time required, run Preview Generator manually.
  • Total number of files on server: ~ 31,600
  • New photos uploaded: 50
  • Thumbnails created (for each photo): 15 of different sizes.
  • Execution time: ~ 5,5 minutes.

Code: Select all

Sep 30 10:33:41	sudo: root : TTY=unknown ; PWD=/usr/local/www ; USER=www ; COMMAND=/usr/local/bin/php -f /<path to web server>/nextcloud/occ preview:pre-generate
Sep 30 10:38:13	root: The cron job 'php -f /<path to web server>/nextcloud/occ preview:pre-generate' has been executed successfully.
Last edited by Snufkin on 30 Sep 2018 11:58, edited 1 time in total.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

Kompost
NewUser
NewUser
Posts: 2
Joined: 31 Oct 2016 21:35
Status: Offline

NextOwnCloud 14.x: set "Referrer-Policy" HTTP-Header

#132

Post by Kompost » 30 Sep 2018 11:16

Since the update to Nextcloud 14.0.1 the security & setup warnings warn:
The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin" or "strict-origin-when-cross-origin".
How cloud I set these addtional parameter for the web-server?

Code: Select all

$HTTP["scheme"]=="https"{setenv.add-response-header=("Strict-Transport-Security"=>"max-age=63072000;includeSubdomains;")}
$HTTP["scheme"]=="https"{setenv.add-response-header=("Referrer-Policy"=>"no-referrer;")}
won't work. lighttpd don't start with these. Any suggestion?

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: NextOwnCloud 14.x: set "Referrer-Policy" HTTP-Header

#133

Post by crest » 02 Oct 2018 09:20

Hello Kompost,

Welcome to the forum.
Kompost wrote:
30 Sep 2018 11:16
Since the update to Nextcloud 14.0.1 the security & setup warnings warn:
The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin" or "strict-origin-when-cross-origin".
How cloud I set these addtional parameter for the web-server?

Code: Select all

$HTTP["scheme"]=="https"{setenv.add-response-header=("Strict-Transport-Security"=>"max-age=63072000;includeSubdomains;")}
$HTTP["scheme"]=="https"{setenv.add-response-header=("Referrer-Policy"=>"no-referrer;")}
won't work. lighttpd don't start with these. Any suggestion?
You should set this

Code: Select all

setenv.set-response-header = ("Referrer-Policy"=>"no-referrer")
to addtional parameters under Services > Webserver to prevent the mentioned warning.

Regards
crest

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Maurizio
Starter
Starter
Posts: 53
Joined: 05 Jul 2018 21:49
Location: Linate (MIlan)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#134

Post by Maurizio » 03 Oct 2018 14:40

Solved. I my RootOnZFS installation have installed the php72-pecl-smbclient-0.9.0_4. pkg copying the files.
In a temporary directory not in /

Code: Select all

# fetch http://pkg.freebsd.org/FreeBSD:11:amd64/latest/All/php72-pecl-smbclient-0.9.0_4.txz
# tar zxfv php72-pecl-smbclient-0.9.0_4.txz
# cp usr/local/lib/php/20170718/smbclient.so  /usr/local/lib/php/extensions/no-debug-non-zts-20170718/smbclient.so
# cp usr/local/etc/php/ext-20-smbclient.ini /usr/local/etc/php/ext-20-smbclient.ini
Reboot the server.
XigmaNAS 11.2.0.4 on Dell R710 144GB RAM - RootOnZFS zroot on 2x 64GB 15k HDDs in mirror, zdata on 3x 1TB SSD in RAIDZ1.
2x XigmaNAS 11.2.0.4 - RootOnZFS on HPE Proliant Microserver gen10 X3216 - 3x 4TB WD RED. In mirror with zrep.

sherman
Starter
Starter
Posts: 41
Joined: 27 Dec 2014 15:16
Status: Offline

[EXTENSION] NextOwnCloud

#135

Post by sherman » 20 Oct 2018 17:06

Oh, oh I am in trouble.

I tried to upgrade NC V13 towards V14 I thing from the NC webgui since it told me there is an update...
Afterwards I was told that NC ran into troubles. I looked up the error on the net and I suppose it was related to unix rights.

Anyway, I could not solve it since I am no Unix guy and thought may be a decent uninstall and reinstall might help. The hope was that the upgrade did not tough the db.
However I do not know where the NC db is 'hosted' on a Nas4free Xigmanas install via OBI extension.

And moreover the reinstall went fine but though I pointed the storage mount of my data to the right folder...the install was a and remained a fresh install. NC does not see my files in the data folder nor it does recover automatically my old setup and db.
I do not know what is needed to recover my old setup before I tried the upgrade but data folder and rsync backup are there. And I also have (I hope so) older NC config.php files.

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] NextOwnCloud

#136

Post by crest » 21 Oct 2018 10:11

Hello sherman,
sherman wrote:
20 Oct 2018 17:06
Oh, oh I am in trouble.

I tried to upgrade NC V13 towards V14 I thing from the NC webgui since it told me there is an update...
Afterwards I was told that NC ran into troubles. I looked up the error on the net and I suppose it was related to unix rights.

Anyway, I could not solve it since I am no Unix guy and thought may be a decent uninstall and reinstall might help. The hope was that the upgrade did not tough the db.
However I do not know where the NC db is 'hosted' on a Nas4free Xigmanas install via OBI extension.

And moreover the reinstall went fine but though I pointed the storage mount of my data to the right folder...the install was a and remained a fresh install. NC does not see my files in the data folder nor it does recover automatically my old setup and db.
I do not know what is needed to recover my old setup before I tried the upgrade but data folder and rsync backup are there. And I also have (I hope so) older NC config.php files.
NC don't recovers anything on a new installation, therefore you could try to recover from a backup.

If you performed a backup from inside the NextOwnCloud extension prior to the upgrade you could use
1. Restore Userdata to get back your settings and data in the upgraded/new NC installation or
2. Restore to revert the upgrade of NC to your previous version including the user data
inside the NOC extension.

Interesting would have been to know the errors you had during the upgrade process ...

NB: I moved the post to the appropriate thread ...

Regards
crest

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#137

Post by Snufkin » 01 Nov 2018 20:02

Maurizio wrote:
03 Oct 2018 14:40
Solved. I my RootOnZFS installation have installed the php72-pecl-smbclient-0.9.0_4. pkg copying the files.
In a temporary directory not in /

Code: Select all

# fetch http://pkg.freebsd.org/FreeBSD:11:amd64/latest/All/php72-pecl-smbclient-0.9.0_4.txz
# tar zxfv php72-pecl-smbclient-0.9.0_4.txz
# cp usr/local/lib/php/20170718/smbclient.so  /usr/local/lib/php/extensions/no-debug-non-zts-20170718/smbclient.so
# cp usr/local/etc/php/ext-20-smbclient.ini /usr/local/etc/php/ext-20-smbclient.ini
Reboot the server.
Thank you, Maurizio for this hint.
Recently updated Nextcloud to 14.0.3 version and got more verbose explanation in its log

Code: Select all

"Exception":"Icewind\\SMB\\Exception\\DependencyException","Message":"No valid backend available, ensure smbclient is in the path or php-smbclient is installed"
smbclient is in place, but php-smbclient module missed in XNAS embedded image.

Dear Crest, could it be possible to add above module to the embedded XNAS image?
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

doktornotor
Advanced User
Advanced User
Posts: 182
Joined: 16 May 2017 00:22
Status: Offline

Re: [EXTENSION] NextOwnCloud

#138

Post by doktornotor » 04 Nov 2018 09:37

Posted a quick howto for using MariaDB with Nextcloud with recent 11.2 XigmaNAS versions. :idea:

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#139

Post by crest » 28 Nov 2018 08:08

Hello Snufkin,
Snufkin wrote:
01 Nov 2018 20:02
Maurizio wrote:
03 Oct 2018 14:40
Solved. I my RootOnZFS installation have installed the php72-pecl-smbclient-0.9.0_4. pkg copying the files.
In a temporary directory not in /

Code: Select all

# fetch http://pkg.freebsd.org/FreeBSD:11:amd64/latest/All/php72-pecl-smbclient-0.9.0_4.txz
# tar zxfv php72-pecl-smbclient-0.9.0_4.txz
# cp usr/local/lib/php/20170718/smbclient.so  /usr/local/lib/php/extensions/no-debug-non-zts-20170718/smbclient.so
# cp usr/local/etc/php/ext-20-smbclient.ini /usr/local/etc/php/ext-20-smbclient.ini
Reboot the server.
Thank you, Maurizio for this hint.
Recently updated Nextcloud to 14.0.3 version and got more verbose explanation in its log

Code: Select all

"Exception":"Icewind\\SMB\\Exception\\DependencyException","Message":"No valid backend available, ensure smbclient is in the path or php-smbclient is installed"
smbclient is in place, but php-smbclient module missed in XNAS embedded image.

Dear Crest, could it be possible to add above module to the embedded XNAS image?
Will be included in the upcoming release of NOC.

Regards
crest

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: Nextcloud failed to connect Samba external storage

#140

Post by Snufkin » 28 Nov 2018 09:16

crest wrote:
28 Nov 2018 08:08
Hello Snufkin,
Snufkin wrote:
01 Nov 2018 20:02
...
Recently updated Nextcloud to 14.0.3 version and got more verbose explanation in its log

Code: Select all

"Exception":"Icewind\\SMB\\Exception\\DependencyException","Message":"No valid backend available, ensure smbclient is in the path or php-smbclient is installed"
smbclient is in place, but php-smbclient module missed in XNAS embedded image.

Dear Crest, could it be possible to add above module to the embedded XNAS image?
Will be included in the upcoming release of NOC.

Regards
crest
Great news, Crest!
A good chance for me to get rid of a homemade post-init patch.

Thank you for your continued support of OBI and its great pool of Extensions.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
crest
Hardware & Software Guru
Hardware & Software Guru
Posts: 862
Joined: 02 Jul 2012 22:25
Location: Vienna, Austria - GMT+1
Status: Offline

Re: [EXTENSION] NextOwnCloud

#141

Post by crest » 29 Nov 2018 08:33

Hello all,

there is a new release (v0.3.4) of this extension available => [EXTENSION] NextOwnCloud.
UPDATES CAN BE DONE DIRECTLY VIA THE WEBGUI (Extension Maintenance Tab).

For a list of changes take a look at the Version History.

If someone wants to contribute to extension translations please refer to this topic => Translations for Extensions

Regards
crest

NAS1: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI 760GM-P23; AMD Athlon(tm) II X2 250 7.58GiB RAM
NAS2: 11.2.0.4 - Omnius (Revision 6766) x64-embedded; MSI MS-7369; AMD Sempron(tm) LE-1250 8022MiB RAM

UPS: APC Back-UPS ES 550G
Extensions: OneButtonInstaller, Extended GUI, NextOwnCloud, BitTorrent Sync, Syncthing, Downloady, Midnight Commander, NCDU, MySQL, Rclone

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: [EXTENSION] NextOwnCloud

#142

Post by Snufkin » 22 Jan 2019 14:35

Nextcloud major upgrade to version 15.0.2 requires php-imagick module to be installed.

Could it be possible to include above module in upcoming NextOwnCloud extension release?
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

nasrocks
Starter
Starter
Posts: 58
Joined: 05 Nov 2014 03:39
Status: Offline

Re: [EXTENSION] NextOwnCloud

#143

Post by nasrocks » 14 Feb 2019 04:02

Hi Crest

I have a new install of Xigmanas and NextCloud.

I have set my data directory to a totally different drive that the extension. Is this reason for these errors? It looks like it is all working but I have this

The Data Folder is not used in your current NextCloud configuration!-
For security reasons this folder should NOT be set to a directory below /mnt/Xigmanas/ExtensionDirectory/WWW/NextCloud!
It is strongly recommended to remove and repeat the NextCloud installation!

User avatar
Toobie
Starter
Starter
Posts: 35
Joined: 16 Jun 2015 12:54
Status: Offline

Re: [EXTENSION] NextOwnCloud

#144

Post by Toobie » 27 Feb 2019 21:18

Hi there,

I recently updated my NAS to XigmaNAS 11.2.0.4 (6536) and unfortunately Nextcloud is giving me this error:
This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.2.
Is there any possibility to fix this, like upgrade to Nextcloud 13 by shell commands?

Regards, Tobi

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: [EXTENSION] NextOwnCloud

#145

Post by Snufkin » 27 Feb 2019 22:47

Toobie wrote:
27 Feb 2019 21:18
Hi there,

I recently updated my NAS to XigmaNAS 11.2.0.4 (6536) and unfortunately Nextcloud is giving me this error:
This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.2.
Is there any possibility to fix this, like upgrade to Nextcloud 13 by shell commands?

Regards, Tobi
I'd suggest downgrading XNAS to 6400 (PHP 7.2), upgrade Nextcloud to the latest 15.04, then upgrade XNAS to the latest 6536 (PHP 7.3). This way proved to be error free.

But I would like to warn you about small bugs in both Nextcloud and NextOwnCloud Extension, more details could be found in this post.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Toobie
Starter
Starter
Posts: 35
Joined: 16 Jun 2015 12:54
Status: Offline

Re: [EXTENSION] NextOwnCloud

#146

Post by Toobie » 28 Feb 2019 21:48

Snufkin wrote:
27 Feb 2019 22:47
Toobie wrote:
27 Feb 2019 21:18
Hi there,

I recently updated my NAS to XigmaNAS 11.2.0.4 (6536) and unfortunately Nextcloud is giving me this error:
This version of Nextcloud is not compatible with > PHP 7.2.
You are currently running 7.3.2.
Is there any possibility to fix this, like upgrade to Nextcloud 13 by shell commands?

Regards, Tobi
I'd suggest downgrading XNAS to 6400 (PHP 7.2), upgrade Nextcloud to the latest 15.04, then upgrade XNAS to the latest 6536 (PHP 7.3). This way proved to be error free.

But I would like to warn you about small bugs in both Nextcloud and NextOwnCloud Extension, more details could be found in this post.

Thanks for the quick help.
The downgrade was successfull.

But iam not able to update Nextcloud.
In the Updater (Nextcloud 14.0.8 is the latest one he finds) I can press continue update but after clicking the last command "Go back to your Nextcloud instance to finish the update" Nextcloud goes back to my start page, we all the files are stored.

So the update wont start.
Any suggest ens for that?

Regards Tobi.

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: [EXTENSION] NextOwnCloud

#147

Post by Snufkin » 28 Feb 2019 22:27

Toobie wrote:
28 Feb 2019 21:48
So the update wont start.
Any suggest ens for that?

Regards Tobi.
  1. Could you accidentally mix up two buttons, one for upgrading via Nextcloud command line tool and the other via the web interface?
  2. Have you had a successful Nextcloud upgrade in the past?
  3. What error records are there in the log?
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Toobie
Starter
Starter
Posts: 35
Joined: 16 Jun 2015 12:54
Status: Offline

Re: [EXTENSION] NextOwnCloud

#148

Post by Toobie » 01 Mar 2019 09:08

Snufkin wrote:
28 Feb 2019 22:27
  1. Could you accidentally mix up two buttons, one for upgrading via Nextcloud command line tool and the other via the web interface?
  2. Have you had a successful Nextcloud upgrade in the past?
  3. What error records are there in the log?
1. No - I always upgraded Nextcloud via web interface
2. Dont remember.. I think yes, I installed the 12 and updated to 13
3. Last entrys in the Nextcloud Logs are from the 10.02.2019 - so nothing now from my failed upgrade.
Log: https://www.dropbox.com/s/1wmx3t34fo61z ... d.log?dl=0

User avatar
Snufkin
Advanced User
Advanced User
Posts: 281
Joined: 01 Jul 2012 11:27
Location: Etc/GMT-3 (BSD style)
Status: Offline

Re: [EXTENSION] NextOwnCloud

#149

Post by Snufkin » 01 Mar 2019 12:28

Toobie wrote:
01 Mar 2019 09:08
2. Dont remember.. I think yes, I installed the 12 and updated to 13
3. Last entrys in the Nextcloud Logs are from the 10.02.2019 - so nothing now from my failed upgrade.
Log: https://www.dropbox.com/s/1wmx3t34fo61z ... d.log?dl=0
Last Nextcloud upgrade was successful

Code: Select all

{"time":"2018-02-11T19:48:49+00:00","app":"updater","message":"\\OC\\Updater::updateEnd: Update successful","version":"13.0.0.14"}
{"time":"2018-02-11T19:48:49+00:00","app":"updater","message":"\\OC\\Updater::maintenanceDisabled: Turned off maintenance mode","version":"13.0.0.14"}
{"time":"2018-02-11T19:48:49+00:00","app":"updater","message":"\\OC\\Updater::resetLogLevel: Reset log level to Warning(2)","version":"13.0.0.14"}
The case is unclear, too little data on what went wrong.

I'd suggest following steps:
  1. Verify there is a backup of your Nextcloud data created by NextOwnCloud extension script (button at extension page bottom).
  2. Write down on paper all paths for NextOwnCloud extension config page.
  3. Restore Nextcloud data and app using appropriate button at the page bottom.
  4. Verify actual extension config and your records made in p. 2.
  5. Try to upgrade Nextcloud again.
XNAS 11.2.0.4 embedded, ASUS P5B-E, Intel DC E6600, 4 GB DDR2, 2 x HGST HDN726040ALE614, 2 x WDC WD5000AAKS, Ippon Back Power Pro 400

User avatar
Toobie
Starter
Starter
Posts: 35
Joined: 16 Jun 2015 12:54
Status: Offline

Re: [EXTENSION] NextOwnCloud

#150

Post by Toobie » 05 Mar 2019 21:17

Snufkin wrote:
01 Mar 2019 12:28

I'd suggest following steps:
  1. Verify there is a backup of your Nextcloud data created by NextOwnCloud extension script (button at extension page bottom).
  2. Write down on paper all paths for NextOwnCloud extension config page.
  3. Restore Nextcloud data and app using appropriate button at the page bottom.
  4. Verify actual extension config and your records made in p. 2.
  5. Try to upgrade Nextcloud again.
Ok, I tried this - unfortunately without success
Iam again on my file start page after clicking on update.

Any other suggestion?
Manually update?

Post Reply

Return to “Extensions / Add-ons”