Latest News:
2019-03-31: XigmaNAS 11.2.0.4.6625 - released!

Latest BETA Release:
2019-03-31: XigmaNAS 12.0.0.4.6625 - BETA released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

can't access WebGUI after a while

If you are new on this forum and you don't know where to post please use this sub-forum. Somebody will answer your question and/or will move your topic into the right sub-forum.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
jamaroney
Advanced User
Advanced User
Posts: 198
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

can't access WebGUI after a while

#1

Post by jamaroney » 13 Apr 2019 12:28

I have latest XNAS embedded version installed.

About weekly, I can no longer access the WebGUI. I get the following message:

Warning: session_start(): open(/tmp/sess_91c4315cca52192d8c1dbcab29b86765, O_RDWR) failed: No space left on device (28) in /etc/inc/session.inc on line 52 Warning: session_start(): Failed to read session data: files (path: /tmp) in /etc/inc/session.inc on line 52 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/session.inc:52) in /usr/local/www/auth.inc on line 39

However, everything continues to work fine, and nothing unusual shows up in the log. The only remedy is to reboot, and then the problem will re-occur in about another week.

Suggestions?

User avatar
ms49434
Developer
Developer
Posts: 562
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: can't access WebGUI after a while

#2

Post by ms49434 » 13 Apr 2019 13:16

jamaroney wrote:
13 Apr 2019 12:28
I have latest XNAS embedded version installed.

About weekly, I can no longer access the WebGUI. I get the following message:

Warning: session_start(): open(/tmp/sess_91c4315cca52192d8c1dbcab29b86765, O_RDWR) failed: No space left on device (28) in /etc/inc/session.inc on line 52 Warning: session_start(): Failed to read session data: files (path: /tmp) in /etc/inc/session.inc on line 52 Warning: Cannot modify header information - headers already sent by (output started at /etc/inc/session.inc:52) in /usr/local/www/auth.inc on line 39

However, everything continues to work fine, and nothing unusual shows up in the log. The only remedy is to reboot, and then the problem will re-occur in about another week.

Suggestions?
Something is filling up the directory containing temporaty files. 'tmp' redirects to /var/tmp and contains a virtual filesystem which is kept in RAM (memory disk).
A reboot will work-around the issue but it won't fix it in a long term. You need to investigate which service is eating up all space. It could be flooded log files but also services like bittorrent.
Log files can be redirected to a hard drive and bittorrent directories can be configured to store their data on a hard drive as well.
1) XigmaNAS 11.2.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 11.2.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 1x HGST 10TB , services: rsync.

jamaroney
Advanced User
Advanced User
Posts: 198
Joined: 13 Aug 2012 17:32
Location: Stroudsburg, PA
Status: Offline

Re: can't access WebGUI after a while

#3

Post by jamaroney » 14 Apr 2019 13:57

Thanks for the info.

In fact, I have been getting a lot more log notices from Transmission in the last couple of months, even though all torrents are downloading/seeding just fine. I created several posts in this forum about these issues over the last couple of months, but most were not responded to.

I'll regularly purge the daemon.log file. Hopefully, that alone will allow the WebGUI to remain functional.

Post Reply

Return to “Newbie Questions”