Latest News:
*New 11.2 series Release:
2019-06-20: XigmaNAS 11.2.0.4.6766 - released!

*New 12.0 series Release:
2019-06-20: XigmaNAS 12.0.0.4.6766 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS cost money, please consider a donation to our project so we can continue to offer you the best.
We need your support! eg: PAYPAL

Errors (formally read/write) when accessing to big or many files

CIFS/SMB network sharing.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
MikeVR
NewUser
NewUser
Posts: 2
Joined: 14 Jun 2019 21:55
Status: Offline

Errors (formally read/write) when accessing to big or many files

#1

Post by MikeVR » 14 Jun 2019 22:16

12.0.0.4 - Reticulus (revision 6743) embedded on Hyper-V 2012R2. 6Gb mem for XigmaNAS.
Share connected to Win 8.1.

If I copying to or from samba share big or many files (few Gb) I got 95% error (write or read). Operation will be success only in ~5% cases. Bigger file - less chance. Not only when copy - error If ask Total Commander to calculate CRC for example (= read not to local disk, only to mem) - error of reading file after few seconds or minute in most cases on big files.

I tried absolutely different disks (hyper-v pass-through) - from USB HDD to SATA SSD. I tried UFS and ZFS. All combinations has same error. Problem not in disk's quality or disk's interface/type.

Problem not in disks or network at all: same disks, shared as samba (too) not through XigmaNAS but from hyper-v host machine has 100% stability. Same hardware, same network.
Is it known issue in XigmaNAS's samba or in hyper-v pass-through?
But moreover - I'm not sure that it's hyper-v pass-through problem because if I share same disks through XigmaNAS's ftp - no errors. All stable.
So, I think, problem in XigmaNAS's samba...

p.s. Is it ok, that on ZFS eats 97-98% mem (in any case and when loader.conf->vfs.zfs.arc_max set to 2G)?

Post Reply

Return to “CIFS/SMB (Samba)”