*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released

*New 11.3 series Release:
2020-04-16: XigmaNAS 11.3.0.4.7538 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

SOLVED: Trying to connect to a R3000XR with snmp results in error

Uninterruptable Power Supply service using NUT.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Uzi
Starter
Starter
Posts: 16
Joined: 14 Oct 2015 21:49
Status: Offline

SOLVED: Trying to connect to a R3000XR with snmp results in error

#1

Post by Uzi »

After moving one of my systems into a different location I wanted to connect it to the UPS available there.
The UPS is a HP R3000XR with the AF401 Management Card. I can connect to the card through the web browser just fine.

When trying to connect XigmaNAS (freshly updated to 11.3.0.4.6928) I get the dreaded "Error: The changes could not be applied (Error Code 1)." message.
Looking at the log I see the following:

Code: Select all

Oct  7 18:33:54 hostname root: /etc/rc.d/nut: WARNING: failed precmd routine for nut
Oct  7 18:33:54 hostname root: Failed to start service nut
Oct  7 18:33:54 hostname root: nut_upslog service started
Oct  7 18:33:54 hostname root: nut_upsmon service started
Oct  7 18:33:54 hostname upsmon[4287]: UPS [ups1@localhost]: connect failed: Connection failure: Connection refused
Oct  7 18:33:54 hostname upsmon[4287]: Communications with UPS ups1@localhost lost
Oct  7 18:33:54 hostname upssched-cmd: Communications with the UPS ups1@localhost are lost
Oct  7 18:33:55 hostname msmtp: [successfully send e-mail]
Oct  7 18:33:59 hostname upsmon[4287]: UPS [ups1@localhost]: connect failed: Connection failure: Connection refused
Oct  7 18:33:59 hostname upsmon[4287]: UPS ups1@localhost is unavailable
Oct  7 18:33:59 hostname upssched-cmd: UPS ups1@localhost - The ups is unavailable
My UPS config is as follows:

Code: Select all

Mode: Master
Master user: root
Master password: <password of root>
Identifier: ups1
Driver: snmp-ups
Port: <IP of UPS card>
Additional parameters: <none>
Shutdown Mode: UPS goes on battery
Shutdown timer: 60
Any idea what is wrong with these settings? Or is there something else I'm missing?
Last edited by Uzi on 04 Nov 2019 21:16, edited 1 time in total.

Uzi
Starter
Starter
Posts: 16
Joined: 14 Oct 2015 21:49
Status: Offline

Re: Trying to connect to a R3000XR with snmp results in error

#2

Post by Uzi »

After updating to 11.3.0.4.7014 and several reboots (for other reasons which were not caused by XigmaNAS) I tried enabling the UPS service again with the above settings.

Result: "The changes have been applied successfully."
- I get readings of the UPS
- I get runtime info of the UPS

So everything seems to work fine.

Haven't tried a simulation of a power failure yet.

Post Reply

Return to “UPS”