*New 11.3 series Release:
2019-10-05: XigmaNAS 11.3.0.4.6928 - released, 11.2 series are soon unsupported!

*New 12.0 series Release:
2019-10-05: XigmaNAS 12.0.0.4.6928 - released!

*New 11.2 series Release:
2019-09-23: XigmaNAS 11.2.0.4.6881 - released!

We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Server 11.3 auf 12.0

German community

Moderators: b0ssman, apollo567, crowi, Princo

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
friedrich
NewUser
NewUser
Posts: 4
Joined: 09 Oct 2019 12:38
Status: Offline

Server 11.3 auf 12.0

#1

Post by friedrich » 09 Oct 2019 13:00

Hallo, ein Server arbeitet mit einem RAIDZ2 (6 HDD) unter 11.3 problemlos. Neuerstellung eines USB-Sticks mit 12.0 ( embedded) führt dazu, daß der BTX-Loader nach Anzeige der HDD´s hängen bleibt. Entferne ich einige HDD´s, so startet der Server ( zwar mit Fehlermeldung über den defekten Raid) problemlos mit 12.0 bis zur Console durch. Welche Einträge auf dem RAIDZ2 verhindern das Starten des Servers, bzw. wie muß ich den ( funktionierenden) RAIDZ2 behandeln, daß das Problem gelöst wird?
Gruß Friedrich

User avatar
ms49434
Developer
Developer
Posts: 718
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Server 11.3 auf 12.0

#2

Post by ms49434 » 09 Oct 2019 14:48

was mir so auf Anhieb zum Ausprobieren einfällt:
- Controller im BIOS auf AHCI einstellen.
- Alle Festplatten vom Bootvorgang im BIOS ausklammern bzw das Gegentail davon, nämlich alle Festplatten beim Bootvorgang einbinden/sichtbar machen (nicht nur die ersten beiden).
- Zurück auf 11.3.
1) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.0.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U2, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

friedrich
NewUser
NewUser
Posts: 4
Joined: 09 Oct 2019 12:38
Status: Offline

Re: Server 11.3 auf 12.0

#3

Post by friedrich » 09 Oct 2019 16:18

Danke für die Antwort: Controller im BIOS ist auf AHCI, die Festplatten werden alle im BIOS angezeigt, 11.3 geht, aber irgendwann wird diese Version nicht mehr unterstützt. Bin mir ziemlich sicher, daß, wenn ich den RAIDZ2 auflösen würde, alles funktionieren würde. Macht nur keinen Spaß, tagelang wieder Daten raufzuschaufeln. Es ist kein elementares Problem, die 11.3 geht ja, mich interessiert der Hintergrund. Leider fehlt mir die Kenntnis der nötigen Werkzeuge, um hinter das Problem zu kommen.

winfried
NewUser
NewUser
Posts: 6
Joined: 10 Oct 2019 11:55
Status: Offline

Re: Server 11.3 auf 12.0

#4

Post by winfried » 10 Oct 2019 12:23

Hallo Friedrich,

ich hatte gerade das selbe Problem - bereits hier auf Englisch beschrieben.

Kurzer Lösungsweg:

- Boot Mode im BIOS auf "UEFI" stellen
- in LiveUSB booten
- Bei der Installation auf den Ziel-USB-Datenträger zweite Option ("Install for EFI" oder ähnlich) wählen
- Installation läuft durch, LiveUSB entfernen
- Reboot; das System sollte nun starten.
- Konfiguration wiederherstellen / anpassen, etc.

Ich hoffe es funktioniert!

Grüße, Winfried
XigmaNAS 12.0.0.4.6928
Supermicro X10SRL-F
Intel Xeon E5-1620v3 4x 3.50GHz
16GB (4x 4096MB) Kingston DDR4-2400 ECC DIMM (CL17-17-17-32) RAM
8 x Toshiba N300 4 TB HDD

friedrich
NewUser
NewUser
Posts: 4
Joined: 09 Oct 2019 12:38
Status: Offline

Re: Server 11.3 auf 12.0

#5

Post by friedrich » 10 Oct 2019 15:06

Danke, aber es funktioniert nicht. Der N54L hat im BIOS keine Einstellung für UEFI ( BIOS mod. wegen 6.HDD über eSATA). Es ist egal, ob ich einen MBR oder EFI-Modus wähle, nach Anzeige der 6 HDD ist Schluß. Egal, ob ich mit einem LiveUSB starte, oder sofort mit dem erstellten Stick starte.

winfried
NewUser
NewUser
Posts: 6
Joined: 10 Oct 2019 11:55
Status: Offline

Re: Server 11.3 auf 12.0

#6

Post by winfried » 10 Oct 2019 18:35

Ziemlich ärgerlich. Sofern nicht schon gelesen: Das Problem scheint keineswegs unbekannt, siehe auch Antwort auf meinen Beitrag im englischen Forumsbereich, HP-Server werden auch erwähnt. (Siehe auch dort)

Meine Vermutung ist dass es sich dabei eher um ein FreeBSD-spezifisches Problem handelt. Genaueres habe ich dazu aber nicht herausfinden können (Version 12 ist noch nicht allzulange veröffentlicht). Ich glaube die einfachste Lösung ist, Version 11.3 weiter zu verwenden bis das Problem gefunden bzw. behoben ist. Sofern diese stabil läuft sollte das ja kein großes Problem sein, schlimmstenfalls muss man ein paar "Zwischenupgrades" nachholen.
XigmaNAS 12.0.0.4.6928
Supermicro X10SRL-F
Intel Xeon E5-1620v3 4x 3.50GHz
16GB (4x 4096MB) Kingston DDR4-2400 ECC DIMM (CL17-17-17-32) RAM
8 x Toshiba N300 4 TB HDD

friedrich
NewUser
NewUser
Posts: 4
Joined: 09 Oct 2019 12:38
Status: Offline

Re: Server 11.3 auf 12.0

#7

Post by friedrich » 10 Oct 2019 20:28

Danke nochmal für die Mühe. Es scheint in der Tat hardwareabhängig zu sein. So habe ich einen Fileserver von 11.2 auf 12.0 über die WEBGUI direkt upgraded, obwohl anders empfohlen, hat es funktioniert.
Dagegen geht es beim N54L auch mit der empfohlenen Methode nicht. Wie oben schon gesagt, nehme ich 2-3 HDD aus dem N54L raus, bootet er bis zur Console. Nützt aber nix, weil beim Hinzufügen der HDD dann wieder Schluß ist, ärgerlich. Irgend was muß unter 12.0 gegenüber 11.3 anders sein, sonst würde mein N54L nicht mit 11.3 tadellos funktionieren.
Gruß Friedrich

winfried
NewUser
NewUser
Posts: 6
Joined: 10 Oct 2019 11:55
Status: Offline

Re: Server 11.3 auf 12.0

#8

Post by winfried » 11 Oct 2019 00:03

friedrich wrote:
10 Oct 2019 20:28
Irgend was muß unter 12.0 gegenüber 11.3 anders sein, sonst würde mein N54L nicht mit 11.3 tadellos funktionieren.
Ich befürchte auch dass es das ist. Aus der README.txt Version 11.3:
11.3.0.4.6928 wrote: Changes:
- Upgrade to FreeBSD 11.3-RELEASE-P3.
Für Version 12:
12.0.0.4.6881 wrote: Changes:
- Upgrade to FreeBSD 12.0-RELEASE-P10.
Ich gehe davon aus, dass diese Umstellung mehr mit dem BTX-Loader zu tun hat als die Änderungen von XIgmaNAS. Aber: Wenn das Problem bekannt und verbreitet ist, steigen auch die Chancen dass es jemand auf den Schirm bekommt der es beheben kann ;)
XigmaNAS 12.0.0.4.6928
Supermicro X10SRL-F
Intel Xeon E5-1620v3 4x 3.50GHz
16GB (4x 4096MB) Kingston DDR4-2400 ECC DIMM (CL17-17-17-32) RAM
8 x Toshiba N300 4 TB HDD

Post Reply

Return to “Deutsch”