*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

RAIDZ2 with 4 drives running with only 2

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
testmaster
NewUser
NewUser
Posts: 9
Joined: 12 Jul 2018 21:15
Status: Offline

RAIDZ2 with 4 drives running with only 2

#1

Post by testmaster » 02 Nov 2019 00:17

Dears

Maybe this is a "basic" question, but I can't figure out the answer.

So first off all, I'm testing this in an virtual machine.
Only testing of course.
(Because it's easier to simulate power failer, HDD-Crashes, remove the HDD when resilvering/copying new data on it and so on, without that I harm my hardware)

So I createt a new RAIDZ2 Pool with 4 drives.
Then I put some data on it.
After that I shutded down the machine, and reboot only with 2 drives of the 4 from the RAIDZ2 Pool.
As expected, the pool shows up in degraded state - all data OK - Good
(No new data was added)
So then I reboot another time, but now with all "original" 4 drives.
Then zpool shows me on minimum one drive that was detached in the "previouse step" has Checksum-Errors, but why?

User avatar
Maurizio
Starter
Starter
Posts: 59
Joined: 05 Jul 2018 21:49
Location: Linate (MIlan)
Status: Offline

Re: RAIDZ2 with 4 drives running with only 2

#2

Post by Maurizio » 07 Nov 2019 21:27

Because some data was written to the two disks. You can use the command:

Code: Select all

# zpool iostat -v
it displays I/O statistics for the pools and see if something was written to the pools.
XigmaNAS 12.0.0.4 on Dell R710 144GB RAM - RootOnZFS zroot on 2x 64GB 15k HDDs in mirror, zdata on 3x 1TB SSD in RAIDZ1.
2x XigmaNAS 11.2.0.4 - RootOnZFS on HPE Proliant Microserver gen10 X3216 - 3x 4TB WD RED. In mirror with zrep.

Post Reply

Return to “ZFS (only!)”