*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Nach Umstellung auf SSL Fehlermeldungen

German community

Moderators: b0ssman, apollo567, crowi, Princo

Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
SWS1953
Starter
Starter
Posts: 29
Joined: 13 Jun 2017 09:41
Status: Offline

Nach Umstellung auf SSL Fehlermeldungen

#1

Post by SWS1953 » 11 Nov 2019 05:09

Moins, ich habe mein NAS im Webserver auf SSL umgestellt (mit den Schlüsseln aus System-Allgemein). Damit läuft auch meine Nextcloud über OBI ganz super. Jetzt bekomme ich dann und wann im LOG folgenden Fehler:

1 2019-11-11T02:01:26.145926+01:00 xigmanas.local lighttpd 4050 - - (mod_openssl.c.1796) SSL: 1 error:1417A0C1:SSL routines:tls_post_process_client_hello:no shared cipher
Nov 11 02:01:09 xigmanas 1 2019-11-11T02:01:09.864280+01:00 xigmanas.local lighttpd 4050 - - (mod_openssl.c.1796) SSL: 1 error:14209102:SSL routines:tls_early_post_process_client_hello:unsupported protocol
Nov 10 23:36:44 xigmanas 1 2019-11-10T23:36:44.203204+01:00 xigmanas.local lighttpd 4050 - - (mod_openssl.c.1796) SSL: 1 error:1408F10B:SSL routines:ssl3_get_record:wrong version number

Vielleicht hat ja jemand eine Idee, was es sein kann
Viele Grüße

Lander
Starter
Starter
Posts: 71
Joined: 26 Feb 2015 16:15
Status: Offline

Re: Nach Umstellung auf SSL Fehlermldeungen

#2

Post by Lander » 11 Nov 2019 08:06

Schon mal sowas Versucht ?

viewtopic.php?f=29&t=12801

SWS1953
Starter
Starter
Posts: 29
Joined: 13 Jun 2017 09:41
Status: Offline

Re: Nach Umstellung auf SSL Fehlermldeungen

#3

Post by SWS1953 » 11 Nov 2019 11:35

Würde ich gerne...hast Du mal einen aktuellen Link?
Gruß Sven
You do not have the required permissions to view the files attached to this post.

Lander
Starter
Starter
Posts: 71
Joined: 26 Feb 2015 16:15
Status: Offline

Re: Nach Umstellung auf SSL Fehlermldeungen

#4

Post by Lander » 11 Nov 2019 11:42


SWS1953
Starter
Starter
Posts: 29
Joined: 13 Jun 2017 09:41
Status: Offline

Re: Nach Umstellung auf SSL Fehlermldeungen

#5

Post by SWS1953 » 11 Nov 2019 17:53

Sooooo also habe ich mich mal SELFCERT auseinander gesetzt. Habe mir ein Zertifkat erstellt und eingefügt und das zeigt Chrome auch brav an...(Natürlich immer noch als unsicher)...Leider bleiben die Fehlermeldung:

1 2019-11-11T17:33:03.418448+01:00 xigmanas.local lighttpd 40683 - - (mod_openssl.c.1762) SSL: -1 5 54 Connection reset by peer
Nov 11 17:25:08 xigmanas 1 2019-11-11T17:25:08.539961+01:00 xigmanas.local lighttpd 40683 - - (mod_openssl.c.1796) SSL: 1 error:1408F10B:SSL routines:ssl3_get_record:wrong version number

Gruß Sven

SWS1953
Starter
Starter
Posts: 29
Joined: 13 Jun 2017 09:41
Status: Offline

Re: Nach Umstellung auf SSL Fehlermeldungen

#6

Post by SWS1953 » 13 Nov 2019 04:44

Jetzt kommt noch eine neue Fehlermeldung hinzu..

1 2019-11-13T04:31:11.972262+01:00 xigmanas.local lighttpd 3141 - - (response.c.346) invalid character in URI -> 400 /ncdaten/ocs/v2.php/apps/notifications/api/v2/push?format=json&pushTokenHash=6cc52f4943cbca362a89bd6c8e588a6dbac9b75f5185fde40a26df4fd2adcfd18977148c33d1f73f3f7ea357c7cabede8b07baed4c2d5aa41203443bb827f105&devicePublicKey=-----BEGIN%20PUBLIC%20KEY-----%0AMIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEArWM8Gv3T3FiWRx275KHh%0A4rXDhJA9%2BVmNhgCLQaZvmYphxiLVV9aoyWdXR7yIGD%2BifCp9QB2530RmtfRsUBOk%0AvShyN7meiL0U6p%2FHZfpa%2BFPaHdIqS%2B%2BpoOEHZgsFUtUPR1MnEpc%2BVIxZu0ZfZvpU%0AoJHATuGe0AsoUV2Xdnsi8eDA3XQJb0TaSLfVi7hwYAJxijBc1qwXaFrDOk6tozyj%0ACJIKOF83GA1YAUrMp9QMD6MlIl4myq%2Fr6a2SD%2BiPcHzmNFd%2F6waKJw0LBeJMIgKy%0AvOrHQrabl4aasFSe%2BfN%2BxFteGecnbo3JcsaTnMeIKu4KpPedDVJq1NEX8kRROy2G%0AbQIDAQAB%0A-----END%20PUBLIC%20KEY-----%0A&proxyServer=https%3A%2F%2Fpush-notifications.nextcloud.com

Lander
Starter
Starter
Posts: 71
Joined: 26 Feb 2015 16:15
Status: Offline

Re: Nach Umstellung auf SSL Fehlermeldungen

#7

Post by Lander » 13 Nov 2019 07:43

Naja Sorry ... aber da haegt irgendwie Nextcloud mit drin wie man unschwer erkennen kann.

mNFd%2F6waKJw0LBeJMIgKy%0AvOrHQrabl4aasFSe%2BfN%2BxFteGecnbo3JcsaTnMeIKu4KpPedDVJq1NEX8kRROy2G%0AbQIDAQAB%0A-----END%20PUBLIC%20KEY-----%0A&proxyServer=https%3A%2F%2Fpush-notifications.nextcloud.com

Ich denk das ist kein xigmanas Fehler ! Vielleicht mal im Nextcloud Forum anfragen.

Shperrung
experienced User
experienced User
Posts: 102
Joined: 04 Apr 2018 16:29
Status: Offline

Re: Nach Umstellung auf SSL Fehlermeldungen

#8

Post by Shperrung » 13 Nov 2019 07:45

Hi!
Possibly you need to add "RSA" like this
----- BEGIN RSA PUBLIC KEY -----
or you may try to make the Jail with simple reverse proxy and valid SSL certificate
viewtopic.php?f=48&t=14334&p=91778#p91778
11.2.0.4 - Omnius (revision 6177) embedded -> XigmaNAS 12.0.0.4.6928 RootOnZFS
ASRock J3710-ITX, LAN: Winyao 2 ports; 16Gb RAM; WD 1Tbx2, WD 2Tb; UPS Powercom WOW500U.

SWS1953
Starter
Starter
Posts: 29
Joined: 13 Jun 2017 09:41
Status: Offline

Re: Nach Umstellung auf SSL Fehlermeldungen

#9

Post by SWS1953 » 15 Nov 2019 08:36

...Leider immer noch aktuell

Post Reply

Return to “Deutsch”