*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Wrong partition type or partition number

Filesystems(UFS, EXT2, FAT, NTFS, ZFS), mount points, partitions
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Tukan
NewUser
NewUser
Posts: 2
Joined: 09 Feb 2020 16:21
Status: Offline

Wrong partition type or partition number

#1

Post by Tukan » 09 Feb 2020 16:38

Hello everyone,

I am having trouble with creating mount points. I have 5x 2tb sata drives where first one is having xigmanas OS installed and having also mount separate mount point MBR partition type with UFS file system created. Problem goes when i try to create 2nd mount point with same parameters, MBR partition type and UFS file system. It throws out these errors:

The following input errors were detected:
Wrong partition type or partition number.
/dev/ada2s25: Can't get UFS ID.
dumpfs: /dev/ada2s25: could not find special device

Tried to do it with few partition numbers but only way i went through it was to set up Partition type to GPT.

Could anyone explain why ?

Thanks

Robert

User avatar
ms49434
Developer
Developer
Posts: 805
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Wrong partition type or partition number

#2

Post by ms49434 » 11 Feb 2020 18:29

the error message "dumpfs: /dev/ada2s25: could not find special device" indicates that this device doesn't exist on your system.

To get a list of known storage devs run

Code: Select all

geom dev list -a | grep "Geom name:" | awk '{ print $3 }'
from the command line.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Tukan
NewUser
NewUser
Posts: 2
Joined: 09 Feb 2020 16:21
Status: Offline

Re: Wrong partition type or partition number

#3

Post by Tukan » 16 Feb 2020 20:23

Here is the command output:

$ geom dev list -a | grep "Geom name:" | awk '{ print $3 }'
md0
ada0
ada0s1
ada0s2
ada0s3
ada1
ada0s1a
ada0s2b
ada0s3a
ada1p1
ada2
ufsid/5e3bbc262a74a3e9
ada3
ufsid/5e3e1e47705f1cf3
ada2p1
ada3p1
ufsid/5e3e19ff42c24ce0
ufsid/5e3bcf2951cf21c9
ufs/pool3
md1
ufsid/5dc4a081cf9000a4
ufs/embboot
md2

I see ada2 there so assuming the device exists ? any advice?

User avatar
ms49434
Developer
Developer
Posts: 805
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Wrong partition type or partition number

#4

Post by ms49434 » 17 Feb 2020 01:43

Tukan wrote:
16 Feb 2020 20:23
Here is the command output:

$ geom dev list -a | grep "Geom name:" | awk '{ print $3 }'
md0
ada0
ada0s1
ada0s2
ada0s3
ada1
ada0s1a
ada0s2b
ada0s3a
ada1p1
ada2
ufsid/5e3bbc262a74a3e9
ada3
ufsid/5e3e1e47705f1cf3
ada2p1
ada3p1
ufsid/5e3e19ff42c24ce0
ufsid/5e3bcf2951cf21c9
ufs/pool3
md1
ufsid/5dc4a081cf9000a4
ufs/embboot
md2

I see ada2 there so assuming the device exists ? any advice?
The above output confirms that ada2s25 does not exist.
Your system has a disk enumerated as ada2, initialized as GPT (ada2 + letter p) and one partition (ada2p + partition 1) => ada2p1. If you want to mount ada2p1, you have to select GPT and partition 1.
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, SLOG: Samsung 850 Pro, L2ARC: Samsung 850 Pro, Pool 2: 1x Samsung 860 EVO 1TB , services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

Post Reply

Return to “Basic storage concept”