*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Software RAID help

Software RAID information and help
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
techlord
NewUser
NewUser
Posts: 11
Joined: 08 Dec 2017 16:34
Status: Offline

Software RAID help

#1

Post by techlord » 14 Feb 2020 19:48

Hi guys!

I could use some help. I have a softraid in my xigmanas - Software gmirror RAID 1- on 2 x 500GB SATA disks. a few days ago one of the drives failed so i took these steps:

1) physically replaced the faulty drive
2) under Disk-> Management the old drive was reporting Changed so I deleted it and imported again
3) Under Disk -> Software Raid -> Maintenance
a) forget old drive
b) remove old drive
c) added the new drive to the mirror

So everything went smooth and the raid changed from Degraded to COMPLETE but I have one big issue. When I imported the new drive I did not see it was formatted NTFS. So now, under Disk- MAnagement I see:
- old drive that is working well - Filesystem - Softraid
- new drive - file system - NTFS

ada0 ST500LM021-1KJ152 500.10GB W623VRQS ahcich0 AMD Hudson-2 AHCI SATA controller Always On NTFS ONLINE
ada1 WDC WD5000AAKX-08U6AA0 500.10GB WD-WCC2EUL89369 ahcich1 AMD Hudson-2 AHCI SATA controller 20 SoftRaid ONLINE

The Softraid itself is UFS. Under the raid page I see:

Geom name: MyRAID
State: COMPLETE
Components: 2
Balance: round-robin
Slice: 4096
Flags: NONE
GenID: 1
SyncID: 2
ID: 2019960955
Type: AUTOMATIC
Providers:
1. Name: mirror/MyRAID
Mediasize: 500107861504 (466G)
Sectorsize: 512
Stripesize: 4096
Stripeoffset: 0
Mode: r1w1e3
Consumers:
1. Name: ada1
Mediasize: 500107862016 (466G)
Sectorsize: 512
Mode: r1w1e1
State: ACTIVE
Priority: 1
Flags: NONE
GenID: 1
SyncID: 2
ID: 1435227214
2. Name: ada0
Mediasize: 500107862016 (466G)
Sectorsize: 512
Stripesize: 4096
Stripeoffset: 0
Mode: r1w1e1
State: ACTIVE
Priority: 0
Flags: NONE
GenID: 1
SyncID: 2
ID: 4083601738

My question - how is that possible? Shouldn't the raid make the new disk "softraid" filesystem too? How can I fix it?

Post Reply

Return to “Software RAID”