*New 11.4 series Release:
2020-07-03: XigmaNAS 11.4.0.4.7633 - released!

*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

kerberos_kinit_password failed: Cannot contact any KDC

CIFS/SMB network sharing.
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
Knappe
experienced User
experienced User
Posts: 76
Joined: 08 May 2015 08:46
Status: Offline

kerberos_kinit_password failed: Cannot contact any KDC

#1

Post by Knappe »

XigmaNAS 12.1.0.4.7542

XigmaNAS has long been established as a member of a MS Domain.

Because there were now some problems with the access rights to files on some shares, I wanted to give the domain administrator the right to access the shares as root.
The setup was done (without errors) as in the Samba Wiki described here. It worked as expected (incl. reboot trick).

During this procedure I restartet samba more often and received following error:

Code: Select all

# /etc/rc.d/samba restart
Stopping winbindd.
Waiting for PIDS: 7197.
Stopping smbd.
Waiting for PIDS: 7193.
Stopping nmbd.
Removing stale Samba tdb files: .... done
kerberos_kinit_password Administrator@AD-Member failed: Cannot contact any KDC for requested realm
Using short domain name --  AD-Member
Joined 'XIGMASNAS' to realm ' AD-Member.domain.com'
Updating passdb.
Starting nmbd.
Starting smbd.
Starting winbindd.
According to WebGUI testjoin + testparm + account = trusted are all fine.
Get all user, groups and more via wbinfo.

Join to the domain

Code: Select all

/usr/local/bin/net ads join  AD-Member.domain.com -U Admin%password
Using short domain name --  AD-Member
Joined 'XIGMANAS' to dns domain ' AD-Member.domain.com'
DNS Update for xigmanas.AD-Member.domain.com failed: ERROR_DNS_UPDATE_FAILED
DNS update failed: NT_STATUS_UNSUCCESSFUL
so DNS update fail ... but

Code: Select all

# ping  xigmanas.AD-Member.domain.com
PING xigmanas.AD-Member.domain.com (192.168.xxx.yyy): 56 data bytes
64 bytes from 192.168.xxx.yyy: icmp_seq=0 ttl=64 time=0.630 ms
worked as exspected.

/etc/hosts:

Code: Select all

::1 localhost localhost.AD-Member.domain.com
127.0.0.1 localhost localhost.AD-Member.domain.com
192.168.xxx.yyy xigmanas.AD-Member.domain.com xigmanas
DC Server + DC Backup Server incl. DNS Server are reachable.


So what´s happened here ?
Any idear ?

Post Reply

Return to “CIFS/SMB (Samba)”