*New 12.1 series Release:
2020-04-17: XigmaNAS 12.1.0.4.7542 - released

*New 11.3 series Release:
2020-04-16: XigmaNAS 11.3.0.4.7538 - released!


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

Problem forwarding XigmaNAS

NIC, network controllers, compatibility questions, WOL, wake on lan
Forum rules
Set-Up GuideFAQsForum Rules
Post Reply
luisrodg
Starter
Starter
Posts: 17
Joined: 16 May 2020 18:05
Status: Offline

Problem forwarding XigmaNAS

#1

Post by luisrodg »

Hi
I have this testing environment:
1.png
The 192.168.1.0/24 network has my ISP's router, the other network is a cable between the two computers.

With this configuration the XigmaNAS gives me service to the two networks without problem, FTP, SMB, etc.
I need the XigmaNAS to forward or to route between the two network cards and to join the two networks (192.168.1.x and 192.168.2.X).

Add the following routes:
In PC2 192.168.1.10: 192.168.2.0/24 192.168.1.36.
In PC3 192.168.2.40: 192.168.1.0/24 192.168.2.36.

In rc.conf I added: gateway_enabled='YES'

The responses to ping are as follows:
192.168.1.36 to 192.168.1.10 and viceversa are OK.
192.168.2.36 to 192.168.2.40 and viceversa are OK.
192.168.1.10 to 192.168.2.40 and viceversa does not respond.

I think there is something misconfigured (either forwarding or routing) in FreeBSD but I don't know what I miss.

Any idea?

Thank you.
You do not have the required permissions to view the files attached to this post.

User avatar
ms49434
Developer
Developer
Posts: 915
Joined: 03 Sep 2015 18:49
Location: Neuenkirchen-Vörden, Germany - GMT+1
Contact:
Status: Offline

Re: Problem forwarding XigmaNAS

#2

Post by ms49434 »

luisrodg wrote:
21 May 2020 18:51
Hi
I have this testing environment:

1.png

The 192.168.1.0/24 network has my ISP's router, the other network is a cable between the two computers.

With this configuration the XigmaNAS gives me service to the two networks without problem, FTP, SMB, etc.
I need the XigmaNAS to forward or to route between the two network cards and to join the two networks (192.168.1.x and 192.168.2.X).

Add the following routes:
In PC2 192.168.1.10: 192.168.2.0/24 192.168.1.36.
In PC3 192.168.2.40: 192.168.1.0/24 192.168.2.36.

In rc.conf I added: gateway_enabled='YES'

The responses to ping are as follows:
192.168.1.36 to 192.168.1.10 and viceversa are OK.
192.168.2.36 to 192.168.2.40 and viceversa are OK.
192.168.1.10 to 192.168.2.40 and viceversa does not respond.

I think there is something misconfigured (either forwarding or routing) in FreeBSD but I don't know what I miss.

Any idea?

Thank you.
Did you consider creating a bridge between the two networks? More to read: Bridging
1) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 22GB out of 32GB ECC RAM, LSI 9300-8i IT mode in passthrough mode. Pool 1: 2x HGST 10TB, mirrored, L2ARC: Samsung 850 Pro; Pool 2: 1x Samsung 860 EVO 1TB, SLOG: Samsung SM883, services: Samba AD, CIFS/SMB, ftp, ctld, rsync, syncthing, zfs snapshots.
2) XigmaNAS 12.1.0.4 amd64-embedded on a Dell T20 running in a VM on ESXi 6.7U3, 8GB out of 32GB ECC RAM, IBM M1215 crossflashed, IT mode, passthrough mode, 2x HGST 10TB , services: rsync.

User avatar
raulfg3
Site Admin
Site Admin
Posts: 5086
Joined: 22 Jun 2012 22:13
Location: Madrid (ESPAÑA)
Contact:
Status: Offline

Re: Problem forwarding XigmaNAS

#3

Post by raulfg3 »

12.0.0.4 (revision 6766)+OBI on SUPERMICRO X8SIL-F 8GB of ECC RAM, 12x3TB disk in 3 vdev in RaidZ1 = 32TB Raw size only 22TB usable

Wiki
Last changes

HP T510

luisrodg
Starter
Starter
Posts: 17
Joined: 16 May 2020 18:05
Status: Offline

Re: Problem forwarding XigmaNAS

#4

Post by luisrodg »

Yes.
I created a bridge with the two network cards but I did not join the two networks (from the GUI).

Post Reply

Return to “LAN , Network controllers”