*New 12.1 series Release:
2019-11-08: XigmaNAS 12.1.0.4.7091 - released!

*New 11.3 series Release:
2019-10-19: XigmaNAS 11.3.0.4.7014 - released


We really need "Your" help on XigmaNAS https://translations.launchpad.net/xigmanas translations. Please help today!

Producing and hosting XigmaNAS costs money. Please consider donating for our project so that we can continue to offer you the best.
We need your support! eg: PAYPAL

403 -Forbidden

New installs of XigmaNAS.
Forum rules
Set-Up GuideFAQsForum Rules
lawrencezarb
NewUser
NewUser
Posts: 11
Joined: 24 Dec 2014 11:31
Status: Offline

403 -Forbidden

#1

Post by lawrencezarb » 24 Dec 2014 11:43

I have done a embeeded install of ver 9.3.0.2.1213, and now when I try and access the webgui from outside my network I get the above message.

The NIC is set with a Static router and uses the same config as version 9.2 which worked fine.

User avatar
apollo567
Site Admin
Site Admin
Posts: 716
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: 403 -Forbidden

#2

Post by apollo567 » 24 Dec 2014 12:50

strange, with 1213 DHCP should work again, please try as workaround static IP adress
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

lawrencezarb
NewUser
NewUser
Posts: 11
Joined: 24 Dec 2014 11:31
Status: Offline

Re: 403 -Forbidden

#3

Post by lawrencezarb » 24 Dec 2014 13:54

Hi, I am using a static IP address for the NAS!

User avatar
apollo567
Site Admin
Site Admin
Posts: 716
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: 403 -Forbidden

#4

Post by apollo567 » 24 Dec 2014 14:01

ok, then try DHCP :-) !
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

User avatar
alexey123
Moderator
Moderator
Posts: 1563
Joined: 19 Aug 2012 08:22
Location: Israel, Karmiel
Contact:
Status: Offline

Re: 403 -Forbidden

#5

Post by alexey123 » 24 Dec 2014 14:07

If you try access to webgui from outside your network, you need allow outside ip address on System|General Setup page, Hosts allow entry. Also you need allow your network

Example
Image
where 88.88.88.88 is allowed ip address
Home11.0.0.4 - Sayyadina (revision 4249)/ x64-embedded on SAPPHIRE Pure Mini E350 / 8G RAM / UPS Ippon Back Power Pro 600
Lab 10.2.0.2 - Prescience (revision 2545) /x64-embedded on Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz / H61M-DS2 / 4G RAM / UPS Ippon Back Power Pro 600
New XigmanasXigmaNAS version 11.2.0.4.6026 on x64-embedded on AMD A8-7600 Radeon R7 A88XM-PLUS/ 16G RAM
TEST1 11.0.0.4 - Pilingitam (revision 4333) bpi-embedded on Allwinner a20 / 1015MiB RAM

User avatar
apollo567
Site Admin
Site Admin
Posts: 716
Joined: 23 Jun 2012 06:37
Location: Ludwigshafen, Germany
Status: Offline

Re: 403 -Forbidden

#6

Post by apollo567 » 24 Dec 2014 14:42

alexey123 wrote: from outside your network
You are right alexey, I had overread this fact, as I had the similar Problem because of broken DHCP with 1190.
my NAS and its development until today: viewtopic.php?f=63&t=39&sid=039fed830cf ... 4d0abe4a04

lawrencezarb
NewUser
NewUser
Posts: 11
Joined: 24 Dec 2014 11:31
Status: Offline

Re: 403 -Forbidden

#7

Post by lawrencezarb » 24 Dec 2014 16:35

Hi, that worked, but now how do I allow gui access from ALL my PC's connected on the LAn without having to enter all their ip addresses invidually?

User avatar
alexey123
Moderator
Moderator
Posts: 1563
Joined: 19 Aug 2012 08:22
Location: Israel, Karmiel
Contact:
Status: Offline

Re: 403 -Forbidden

#8

Post by alexey123 » 24 Dec 2014 17:12

Put CIDR entry. As 192.168.1.0/24 -- in this case you allow access from all LAN
Home11.0.0.4 - Sayyadina (revision 4249)/ x64-embedded on SAPPHIRE Pure Mini E350 / 8G RAM / UPS Ippon Back Power Pro 600
Lab 10.2.0.2 - Prescience (revision 2545) /x64-embedded on Intel(R) Core(TM) i3-3220 CPU @ 3.30GHz / H61M-DS2 / 4G RAM / UPS Ippon Back Power Pro 600
New XigmanasXigmaNAS version 11.2.0.4.6026 on x64-embedded on AMD A8-7600 Radeon R7 A88XM-PLUS/ 16G RAM
TEST1 11.0.0.4 - Pilingitam (revision 4333) bpi-embedded on Allwinner a20 / 1015MiB RAM

User avatar
Lee Sharp
Advanced User
Advanced User
Posts: 255
Joined: 13 May 2013 21:12
Contact:
Status: Offline

Re: 403 -Forbidden

#9

Post by Lee Sharp » 25 Dec 2014 01:58

I like 192.168.0.0/16 myself. Too often I am on an IPSEC vpn and cursing because I forget to set it. :)

tegoo
NewUser
NewUser
Posts: 4
Joined: 03 Dec 2012 03:07
Status: Offline

Re: 403 -Forbidden

#10

Post by tegoo » 25 Dec 2014 15:19

Must be allowed to require network,Or allow all network

delta_x
NewUser
NewUser
Posts: 4
Joined: 06 Jan 2015 13:12
Status: Offline

Re: 403 -Forbidden

#11

Post by delta_x » 06 Jan 2015 13:33

Hi, I need some help to allow remote access to web gui.
I use a DDNS (xxxx.no-ip-info), how configure the "hosts allow" to permit remote access from internet ?
The ports needed on router are open, and the version 9.2 worked.
Thanks for your help.

sebasb
NewUser
NewUser
Posts: 2
Joined: 08 Jan 2015 16:54
Status: Offline

Re: 403 -Forbidden

#12

Post by sebasb » 09 Jan 2015 20:23

delta_x wrote:Hi, I need some help to allow remote access to web gui.
I use a DDNS (xxxx.no-ip-info), how configure the "hosts allow" to permit remote access from internet ?
The ports needed on router are open, and the version 9.2 worked.
Thanks for your help.
I've tried 0.0.0.0/0 or /1, 255.255.255.255/255 to not avail as well. Kinda stuck on this due to my not so good knowledge. Sometimes I need to access it from my tablet or other customers.

If someone knows how to allow from everywhere it will be great.

Thanks

sebasb
NewUser
NewUser
Posts: 2
Joined: 08 Jan 2015 16:54
Status: Offline

Re: 403 -Forbidden

#13

Post by sebasb » 09 Jan 2015 20:25

I found some progress, with 128.0.0.0/1, ot sure I will be able to access it from everywhere though

sarwanov
NewUser
NewUser
Posts: 5
Joined: 29 Jan 2015 16:08
Status: Offline

Re: 403 -Forbidden

#14

Post by sarwanov » 29 Jan 2015 16:13

Its very interesting post you shared.Thanks a lot
Graduated from Soran University with First Class Degree with Honours in Computer Science.

leo1986pc
Starter
Starter
Posts: 24
Joined: 05 May 2014 13:43
Location: Reggio Emilia, Italy
Status: Offline

Re: 403 -Forbidden

#15

Post by leo1986pc » 08 Feb 2015 10:24

this option should be disabled...

leo1986pc
Starter
Starter
Posts: 24
Joined: 05 May 2014 13:43
Location: Reggio Emilia, Italy
Status: Offline

Re: 403 -Forbidden

#16

Post by leo1986pc » 10 Feb 2015 14:30

If I want to configure my NAS via mobile phone across a LTE connection, how could I predict my IP address and set it in my configuration?

delta_x
NewUser
NewUser
Posts: 4
Joined: 06 Jan 2015 13:12
Status: Offline

Re: 403 -Forbidden

#17

Post by delta_x » 18 Feb 2015 12:47

leo1986pc wrote:this option should be disabled...
How disable this option ?

leo1986pc
Starter
Starter
Posts: 24
Joined: 05 May 2014 13:43
Location: Reggio Emilia, Italy
Status: Offline

Re: 403 -Forbidden

#18

Post by leo1986pc » 18 Feb 2015 13:04

Sorry, i mean that I want to disable but i'm not able to do it.

delta_x
NewUser
NewUser
Posts: 4
Joined: 06 Jan 2015 13:12
Status: Offline

Re: 403 -Forbidden

#19

Post by delta_x » 18 Feb 2015 13:44

I'm stuck, I can not access from the internet :(
In version 9.2 all correct and working in 9.3 does not allow access, always the "403 - Forbidden"...

Maybe I will have to leave this crap version and format again with 9.2.
The most amazing is that've looked everywhere and I find no answer.

Perhaps one of the experts who frequent this forum may clarify this question, I'm sure there's a lot more people with this problem.

tgtechno
NewUser
NewUser
Posts: 5
Joined: 06 Feb 2013 15:28
Status: Offline

Re: 403 -Forbidden

#20

Post by tgtechno » 24 Feb 2015 03:07

sebasb wrote:
delta_x wrote:Hi, I need some help to allow remote access to web gui.
I use a DDNS (xxxx.no-ip-info), how configure the "hosts allow" to permit remote access from internet ?
The ports needed on router are open, and the version 9.2 worked.
Thanks for your help.
I've tried 0.0.0.0/0 or /1, 255.255.255.255/255 to not avail as well. Kinda stuck on this due to my not so good knowledge. Sometimes I need to access it from my tablet or other customers.

If someone knows how to allow from everywhere it will be great.

Thanks
I have the exact same problem 9.3.0.2 (1349) ... can't get to the WebGUI from outside the local network and I was able to on previous revision(s) of the firmware (9.2.x.x).

zakroma
Starter
Starter
Posts: 22
Joined: 26 Jun 2012 07:43
Status: Offline

Re: 403 -Forbidden

#21

Post by zakroma » 26 Feb 2015 12:32

When Im trying to add a range of IPs into the Hosts allowed box, I get the

Code: Select all

Webserver document root is missing.
How do I resolve it?

UPD just disabled the webserver service and it all worked just fine

tgtechno
NewUser
NewUser
Posts: 5
Joined: 06 Feb 2013 15:28
Status: Offline

Re: 403 -Forbidden

#22

Post by tgtechno » 01 Mar 2015 15:26

tgtechno wrote:
sebasb wrote:
delta_x wrote:Hi, I need some help to allow remote access to web gui.
I use a DDNS (xxxx.no-ip-info), how configure the "hosts allow" to permit remote access from internet ?
The ports needed on router are open, and the version 9.2 worked.
Thanks for your help.
I've tried 0.0.0.0/0 or /1, 255.255.255.255/255 to not avail as well. Kinda stuck on this due to my not so good knowledge. Sometimes I need to access it from my tablet or other customers.

If someone knows how to allow from everywhere it will be great.

Thanks
I have the exact same problem 9.3.0.2 (1349) ... can't get to the WebGUI from outside the local network and I was able to on previous revision(s) of the firmware (9.2.x.x).
Tried a lot more troubleshooting and still cannot get the WebGUI using version 9.3.0.2 (1349) to work from outside a local network:
  • Access to the WebGUI through the local network with the "hosts allow" box blank works fine.
  • Previous version(s) worked fine - this is a problem that showed up after 'upgrading.'
  • I tried adding all sorts of combinations for the "hosts allow" field to allow ALL IPs access to the WebGUI from other IPs with no success, similar to what sebsab did (i.e. put in 0.0.0.0/0 which should allow any IP to access the system and specific external IPs I knew I was using). I still get the "403 - Forbidden" page.
  • I have tried switching from https:// to http:// and also changed the security certificate with no success. I confirmed the port forwarding was enabled to use port 443 for https and 80 for plain http.
    It is clear the outside networks are reaching the NAS4Free box as I get the notification that a new certificate is being used when using https:, but then the 403 page shows up again.
  • I temporarily enabled the webserver service to serve up plain pages, and that works fine from external IPs
Can anyone help, please?

armandh
Advanced User
Advanced User
Posts: 403
Joined: 23 Jun 2012 04:15
Location: St Louis County Missouri USA
Status: Offline

Re: 403 -Forbidden

#23

Post by armandh » 02 Mar 2015 02:54

for storage files, enable the web server...
pick a port number and set webserver to the desired share and enabled the index page
then setting the router IP forwarding such that the wan side (IP):8086 forwards to the (N4F-IP):8086 port
it just worked, in my case browsing.....
from the lan 192.186.xxx.xxx:8086 and from the internet side [router wan side IP]:8086

port 80 is the set up web page, avoid it or forward it depending on your wish.
4 thread 3300 Mhz Intel i3, 1 TB ZFS mirror, available RAM 7.823 Gb, 64 bit NAS4Free 9.1.0.1 rev 573 [88 watts, 48 Mbps]
2 thread 1600 Mhz atom/ion, 1 TB ZFS mirror, available RAM 3.083 Gb, 64 bit NAS4Free-9.1.0.1 rev 573 [27 watts, 35 Mbps]
2 thread 3900 Mhz AMD A6-6400K, 2 TB ZFS Mirror, available RAM 7.557 Gb, 64 bit Nas4Free 9.3.0.2.1771 [89 watts, 68 Mbps]

tgtechno
NewUser
NewUser
Posts: 5
Joined: 06 Feb 2013 15:28
Status: Offline

Re: 403 -Forbidden

#24

Post by tgtechno » 02 Mar 2015 15:56

armandh wrote:for storage files, enable the web server...
pick a port number and set webserver to the desired share and enabled the index page
then setting the router IP forwarding such that the wan side (IP):8086 forwards to the (N4F-IP):8086 port
it just worked, in my case browsing.....
from the lan 192.186.xxx.xxx:8086 and from the internet side [router wan side IP]:8086

port 80 is the set up web page, avoid it or forward it depending on your wish.


I am not interested in running the webserver, only accessing the NAS4Free WebGUI remotely. I enabled the webserver service only to see if the NAS4Free box responded to WAN IP requests (it did), however the WebGUI still does not respond to WAN IPs even with the webserver service OFF. There must have been a code change because this did work in earlier NAS4Free versions.

I will try a non-standard port for the WebGUI (such as 8086) and see if that helps.

tgtechno
NewUser
NewUser
Posts: 5
Joined: 06 Feb 2013 15:28
Status: Offline

Re: 403 -Forbidden

#25

Post by tgtechno » 03 Mar 2015 03:25

tgtechno wrote:
armandh wrote:for storage files, enable the web server...
pick a port number and set webserver to the desired share and enabled the index page
then setting the router IP forwarding such that the wan side (IP):8086 forwards to the (N4F-IP):8086 port
it just worked, in my case browsing.....
from the lan 192.186.xxx.xxx:8086 and from the internet side [router wan side IP]:8086

port 80 is the set up web page, avoid it or forward it depending on your wish.


I am not interested in running the webserver, only accessing the NAS4Free WebGUI remotely. I enabled the webserver service only to see if the NAS4Free box responded to WAN IP requests (it did), however the WebGUI still does not respond to WAN IPs even with the webserver service OFF. There must have been a code change because this did work in earlier NAS4Free versions.

I will try a non-standard port for the WebGUI (such as 8086) and see if that helps.


OK, I think I resolved the issue ... for some reason the 'hosts allow' box doesn't seem to process the string 0.0.0.0/0 ... but it doesn't report it as a malformed CIDR address either. I was led to believe this string would allow the entire internet to access the WebGUI.

The 'hosts allow' DOES process the following string:
0.0.0.0/1 128.0.0.0/2 192.0.0.0/3 224.0.0.0/4 240.0.0.0/5 248.0.0.0/6 252.0.0.0/7 254.0.0.0/8

which allows any IP between 0.0.0.0 - 255.0.0.0 to access the WebGUI which meets my need.

Pappmann
Starter
Starter
Posts: 19
Joined: 14 Sep 2012 14:55
Status: Offline

Re: 403 -Forbidden

#26

Post by Pappmann » 21 Mar 2015 18:04

tgtechno wrote:
The 'hosts allow' DOES process the following string:
0.0.0.0/1 128.0.0.0/2 192.0.0.0/3 224.0.0.0/4 240.0.0.0/5 248.0.0.0/6 252.0.0.0/7 254.0.0.0/8

which allows any IP between 0.0.0.0 - 255.0.0.0 to access the WebGUI which meets my need.
That works, great!

Thanks

User avatar
Lee Sharp
Advanced User
Advanced User
Posts: 255
Joined: 13 May 2013 21:12
Contact:
Status: Offline

Re: 403 -Forbidden

#27

Post by Lee Sharp » 26 Mar 2015 21:53

This bit me again today at a client. I forgot I would be locked out, and it was plugged into a network I had no direct access to so I couldn't plug in a laptop and allow access. It sure would have been nice to be able to ssh in and fix this. Or have it default to "open" and not "closed" since you can easily lock yourself out.

User avatar
ChriZathens
Forum Moderator
Forum Moderator
Posts: 833
Joined: 23 Jun 2012 09:14
Location: Athens, Greece
Contact:
Status: Offline

Re: 403 -Forbidden

#28

Post by ChriZathens » 28 Mar 2015 18:08

IIRC, via ssh you can edit lighttpd. conf, restart lighttpd and webui is accessible again. You can then enter webui, insert desired range in webui and it will survive the reboot.
Temporar fix, I know...
And I agree that this setting should be disabled by default. In the future I suppose it will be fixed.
My Nas
  1. Case: Fractal Design Define R2
  2. M/B: Supermicro x9scl-f
  3. CPU: Intel Celeron G1620
  4. RAM: 16GB DDR3 ECC (2 x Kingston KVR1333D3E9S/8G)
  5. PSU: Chieftec 850w 80+ modular
  6. Storage: 8x2TB HDDs in a RaidZ2 array ~ 10.1 TB usable disk space
  7. O/S: XigmaNAS 11.2.0.4.6625 -amd64 embedded
  8. Extra H/W: Dell Perc H310 SAS controller, crosflashed to LSI 9211-8i IT mode, 8GB Innodisk D150SV SATADOM for O/S

Backup Nas: HP N40L (4x1TB HP branded Seagate disks in RaidZ configuration - 8GB ECC RAM)

delta_x
NewUser
NewUser
Posts: 4
Joined: 06 Jan 2015 13:12
Status: Offline

Re: 403 -Forbidden

#29

Post by delta_x » 14 Apr 2015 14:58

Thanks, they work :D

OK, I think I resolved the issue ... for some reason the 'hosts allow' box doesn't seem to process the string 0.0.0.0/0 ... but it doesn't report it as a malformed CIDR address either. I was led to believe this string would allow the entire internet to access the WebGUI.

The 'hosts allow' DOES process the following string:
0.0.0.0/1 128.0.0.0/2 192.0.0.0/3 224.0.0.0/4 240.0.0.0/5 248.0.0.0/6 252.0.0.0/7 254.0.0.0/8

which allows any IP between 0.0.0.0 - 255.0.0.0 to access the WebGUI which meets my need.

joker_75
NewUser
NewUser
Posts: 1
Joined: 25 May 2015 22:36
Status: Offline

Re: 403 -Forbidden

#30

Post by joker_75 » 25 May 2015 23:45

really great job
after 3 days workin on it with no result and lots of forums full of stuff that want work this was rescue for my nas befor i drop it out of the window

great thanks for that

i just took it in via copy and paste and all probs where gone.

Post Reply

Return to “Install XigmaNAS”